%global _empty_manifest_terminate_build 0 Name: python-dramatiq Version: 1.14.2 Release: 1 Summary: Background Processing for Python 3. License: GNU Lesser General Public License v3 or later (LGPLv3+) URL: https://pypi.org/project/dramatiq/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5a/9e/fd1ff7b2a85216b65a2cd114a1713dc3bf988a4d89b6bd5ce4a1d6a8c190/dramatiq-1.14.2.tar.gz BuildArch: noarch Requires: python3-prometheus-client Requires: python3-pylibmc Requires: python3-pika Requires: python3-redis Requires: python3-watchdog Requires: python3-watchdog-gevent Requires: python3-gevent Requires: python3-pylibmc Requires: python3-pika Requires: python3-redis Requires: python3-watchdog Requires: python3-watchdog-gevent Requires: python3-gevent Requires: python3-alabaster Requires: python3-sphinx Requires: python3-sphinxcontrib-napoleon Requires: python3-flake8 Requires: python3-flake8-bugbear Requires: python3-flake8-quotes Requires: python3-isort Requires: python3-bumpversion Requires: python3-hiredis Requires: python3-twine Requires: python3-wheel Requires: python3-pytest Requires: python3-pytest-benchmark[histogram] Requires: python3-pytest-cov Requires: python3-tox Requires: python3-gevent Requires: python3-pylibmc Requires: python3-pika Requires: python3-redis Requires: python3-watchdog Requires: python3-watchdog-gevent %description # dramatiq [![Build Status](https://github.com/Bogdanp/dramatiq/workflows/CI/badge.svg)](https://github.com/Bogdanp/dramatiq/actions?query=workflow%3A%22CI%22) [![PyPI version](https://badge.fury.io/py/dramatiq.svg)](https://badge.fury.io/py/dramatiq) [![Documentation](https://img.shields.io/badge/doc-latest-brightgreen.svg)](http://dramatiq.io) [![Discuss](https://img.shields.io/badge/discuss-online-orange.svg)](https://groups.io/g/dramatiq-users) *A fast and reliable distributed task processing library for Python 3.*
**Changelog**: https://dramatiq.io/changelog.html
**Community**: https://groups.io/g/dramatiq-users
**Documentation**: https://dramatiq.io

Sponsors


Franz: macOS Kafka Client


## Installation If you want to use it with [RabbitMQ] pip install 'dramatiq[rabbitmq, watch]' or if you want to use it with [Redis] pip install 'dramatiq[redis, watch]' ## Quickstart Make sure you've got [RabbitMQ] running, then create a new file called `example.py`: ``` python import dramatiq import requests import sys @dramatiq.actor def count_words(url): response = requests.get(url) count = len(response.text.split(" ")) print(f"There are {count} words at {url!r}.") if __name__ == "__main__": count_words.send(sys.argv[1]) ``` In one terminal, run your workers: dramatiq example In another, start enqueueing messages: python example.py http://example.com python example.py https://github.com python example.py https://news.ycombinator.com Check out the [user guide] to learn more! ## License dramatiq is licensed under the LGPL. Please see [COPYING] and [COPYING.LESSER] for licensing details. [COPYING.LESSER]: https://github.com/Bogdanp/dramatiq/blob/master/COPYING.LESSER [COPYING]: https://github.com/Bogdanp/dramatiq/blob/master/COPYING [RabbitMQ]: https://www.rabbitmq.com/ [Redis]: https://redis.io [user guide]: https://dramatiq.io/guide.html %package -n python3-dramatiq Summary: Background Processing for Python 3. Provides: python-dramatiq BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-dramatiq # dramatiq [![Build Status](https://github.com/Bogdanp/dramatiq/workflows/CI/badge.svg)](https://github.com/Bogdanp/dramatiq/actions?query=workflow%3A%22CI%22) [![PyPI version](https://badge.fury.io/py/dramatiq.svg)](https://badge.fury.io/py/dramatiq) [![Documentation](https://img.shields.io/badge/doc-latest-brightgreen.svg)](http://dramatiq.io) [![Discuss](https://img.shields.io/badge/discuss-online-orange.svg)](https://groups.io/g/dramatiq-users) *A fast and reliable distributed task processing library for Python 3.*
**Changelog**: https://dramatiq.io/changelog.html
**Community**: https://groups.io/g/dramatiq-users
**Documentation**: https://dramatiq.io

Sponsors


Franz: macOS Kafka Client


## Installation If you want to use it with [RabbitMQ] pip install 'dramatiq[rabbitmq, watch]' or if you want to use it with [Redis] pip install 'dramatiq[redis, watch]' ## Quickstart Make sure you've got [RabbitMQ] running, then create a new file called `example.py`: ``` python import dramatiq import requests import sys @dramatiq.actor def count_words(url): response = requests.get(url) count = len(response.text.split(" ")) print(f"There are {count} words at {url!r}.") if __name__ == "__main__": count_words.send(sys.argv[1]) ``` In one terminal, run your workers: dramatiq example In another, start enqueueing messages: python example.py http://example.com python example.py https://github.com python example.py https://news.ycombinator.com Check out the [user guide] to learn more! ## License dramatiq is licensed under the LGPL. Please see [COPYING] and [COPYING.LESSER] for licensing details. [COPYING.LESSER]: https://github.com/Bogdanp/dramatiq/blob/master/COPYING.LESSER [COPYING]: https://github.com/Bogdanp/dramatiq/blob/master/COPYING [RabbitMQ]: https://www.rabbitmq.com/ [Redis]: https://redis.io [user guide]: https://dramatiq.io/guide.html %package help Summary: Development documents and examples for dramatiq Provides: python3-dramatiq-doc %description help # dramatiq [![Build Status](https://github.com/Bogdanp/dramatiq/workflows/CI/badge.svg)](https://github.com/Bogdanp/dramatiq/actions?query=workflow%3A%22CI%22) [![PyPI version](https://badge.fury.io/py/dramatiq.svg)](https://badge.fury.io/py/dramatiq) [![Documentation](https://img.shields.io/badge/doc-latest-brightgreen.svg)](http://dramatiq.io) [![Discuss](https://img.shields.io/badge/discuss-online-orange.svg)](https://groups.io/g/dramatiq-users) *A fast and reliable distributed task processing library for Python 3.*
**Changelog**: https://dramatiq.io/changelog.html
**Community**: https://groups.io/g/dramatiq-users
**Documentation**: https://dramatiq.io

Sponsors


Franz: macOS Kafka Client


## Installation If you want to use it with [RabbitMQ] pip install 'dramatiq[rabbitmq, watch]' or if you want to use it with [Redis] pip install 'dramatiq[redis, watch]' ## Quickstart Make sure you've got [RabbitMQ] running, then create a new file called `example.py`: ``` python import dramatiq import requests import sys @dramatiq.actor def count_words(url): response = requests.get(url) count = len(response.text.split(" ")) print(f"There are {count} words at {url!r}.") if __name__ == "__main__": count_words.send(sys.argv[1]) ``` In one terminal, run your workers: dramatiq example In another, start enqueueing messages: python example.py http://example.com python example.py https://github.com python example.py https://news.ycombinator.com Check out the [user guide] to learn more! ## License dramatiq is licensed under the LGPL. Please see [COPYING] and [COPYING.LESSER] for licensing details. [COPYING.LESSER]: https://github.com/Bogdanp/dramatiq/blob/master/COPYING.LESSER [COPYING]: https://github.com/Bogdanp/dramatiq/blob/master/COPYING [RabbitMQ]: https://www.rabbitmq.com/ [Redis]: https://redis.io [user guide]: https://dramatiq.io/guide.html %prep %autosetup -n dramatiq-1.14.2 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-dramatiq -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Mon Apr 10 2023 Python_Bot - 1.14.2-1 - Package Spec generated