%global _empty_manifest_terminate_build 0
Name: python-feature-engine
Version: 1.6.0
Release: 1
Summary: Feature engineering package with Scikit-learn's fit transform functionality
License: BSD 3 clause
URL: http://github.com/feature-engine/feature_engine
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5e/71/60f381ce9e68004e96cb325b8c040800b35f3854a95a197412260edee124/feature_engine-1.6.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scikit-learn
Requires: python3-scipy
Requires: python3-statsmodels
%description
# Feature Engine
[](https://pypi.org/project/feature-engine/)
[](https://github.com/feature-engine/feature_engine/blob/master/LICENSE.md)
[](https://pypi.org/project/feature-engine)
[](https://anaconda.org/conda-forge/feature_engine)
[](https://app.circleci.com/pipelines/github/feature-engine/feature_engine)
[](https://codecov.io/github/feature-engine/feature_engine)
[](https://feature-engine.readthedocs.io/en/latest/index.html)
[](https://github.com/psf/black)
[](https://github.com/feature-engine/feature_engine/graphs/contributors)
[](https://gitter.im/feature_engine/community)
[](https://pepy.tech/project/feature-engine)
[](https://pepy.tech/project/feature-engine)
[](https://zenodo.org/badge/latestdoi/163630824)
[](https://doi.org/10.21105/joss.03642)
[](https://www.firsttimersonly.com/)
[](https://www.trainindata.com/)
[](http://feature-engine.readthedocs.io)
Feature-engine is a Python library with multiple transformers to engineer and select features for use in machine learning models.
Feature-engine's transformers follow Scikit-learn's functionality with fit() and transform() methods to learn the
transforming parameters from the data and then transform it.
## Feature-engine features in the following resources
* [Feature Engineering for Machine Learning, Online Course](https://www.trainindata.com/p/feature-engineering-for-machine-learning)
* [Feature Selection for Machine Learning, Online Course](https://www.trainindata.com/p/feature-selection-for-machine-learning)
* [Feature Engineering for Time Series Forecasting, Online Course](https://www.trainindata.com/p/feature-engineering-for-forecasting)
* [Python Feature Engineering Cookbook](https://packt.link/0ewSo)
* [Feature Selection in Machine Learning with Python Book](https://leanpub.com/feature-selection-in-machine-learning)
## Blogs about Feature-engine
* [Feature-engine: A new open-source Python package for feature engineering](https://trainindata.medium.com/feature-engine-a-new-open-source-python-package-for-feature-engineering-29a0ab88ea7c)
* [Practical Code Implementations of Feature Engineering for Machine Learning with Python](https://towardsdatascience.com/practical-code-implementations-of-feature-engineering-for-machine-learning-with-python-f13b953d4bcd)
## Documentation
* [Documentation](https://feature-engine.trainindata.com)
## Current Feature-engine's transformers include functionality for:
* Missing Data Imputation
* Categorical Encoding
* Discretisation
* Outlier Capping or Removal
* Variable Transformation
* Variable Creation
* Variable Selection
* Datetime Features
* Time Series
* Preprocessing
* Scikit-learn Wrappers
### Imputation Methods
* MeanMedianImputer
* RandomSampleImputer
* EndTailImputer
* AddMissingIndicator
* CategoricalImputer
* ArbitraryNumberImputer
* DropMissingData
### Encoding Methods
* OneHotEncoder
* OrdinalEncoder
* CountFrequencyEncoder
* MeanEncoder
* WoEEncoder
* RareLabelEncoder
* DecisionTreeEncoder
* StringSimilarityEncoder
### Discretisation methods
* EqualFrequencyDiscretiser
* EqualWidthDiscretiser
* GeometricWidthDiscretiser
* DecisionTreeDiscretiser
* ArbitraryDiscreriser
### Outlier Handling methods
* Winsorizer
* ArbitraryOutlierCapper
* OutlierTrimmer
### Variable Transformation methods
* LogTransformer
* LogCpTransformer
* ReciprocalTransformer
* ArcsinTransformer
* PowerTransformer
* BoxCoxTransformer
* YeoJohnsonTransformer
### Variable Creation:
* MathFeatures
* RelativeFeatures
* CyclicalFeatures
### Feature Selection:
* DropFeatures
* DropConstantFeatures
* DropDuplicateFeatures
* DropCorrelatedFeatures
* SmartCorrelationSelection
* ShuffleFeaturesSelector
* SelectBySingleFeaturePerformance
* SelectByTargetMeanPerformance
* RecursiveFeatureElimination
* RecursiveFeatureAddition
* DropHighPSIFeatures
* SelectByInformationValue
* ProbeFeatureSelection
### Datetime
* DatetimeFeatures
* DatetimeSubtraction
### Time Series
* LagFeatures
* WindowFeatures
* ExpandingWindowFeatures
### Preprocessing
* MatchCategories
* MatchVariables
### Wrappers:
* SklearnTransformerWrapper
## Installation
From PyPI using pip:
```
pip install feature_engine
```
From Anaconda:
```
conda install -c conda-forge feature_engine
```
Or simply clone it:
```
git clone https://github.com/feature-engine/feature_engine.git
```
## Example Usage
```python
>>> import pandas as pd
>>> from feature_engine.encoding import RareLabelEncoder
>>> data = {'var_A': ['A'] * 10 + ['B'] * 10 + ['C'] * 2 + ['D'] * 1}
>>> data = pd.DataFrame(data)
>>> data['var_A'].value_counts()
```
```
Out[1]:
A 10
B 10
C 2
D 1
Name: var_A, dtype: int64
```
```python
>>> rare_encoder = RareLabelEncoder(tol=0.10, n_categories=3)
>>> data_encoded = rare_encoder.fit_transform(data)
>>> data_encoded['var_A'].value_counts()
```
```
Out[2]:
A 10
B 10
Rare 3
Name: var_A, dtype: int64
```
Find more examples in our [Jupyter Notebook Gallery](https://nbviewer.org/github/feature-engine/feature-engine-examples/tree/main/)
or in the [documentation](https://feature-engine.trainindata.com).
## Contribute
Details about how to contribute can be found in the [Contribute Page](https://feature-engine.trainindata.com/en/latest/contribute/index.html)
Briefly:
- Fork the repo
- Clone your fork into your local computer: ``git clone https://github.com//feature_engine.git``
- navigate into the repo folder ``cd feature_engine``
- Install Feature-engine as a developer: ``pip install -e .``
- Optional: Create and activate a virtual environment with any tool of choice
- Install Feature-engine dependencies: ``pip install -r requirements.txt`` and ``pip install -r test_requirements.txt``
- Create a feature branch with a meaningful name for your feature: ``git checkout -b myfeaturebranch``
- Develop your feature, tests and documentation
- Make sure the tests pass
- Make a PR
Thank you!!
### Documentation
Feature-engine documentation is built using [Sphinx](https://www.sphinx-doc.org) and is hosted on [Read the Docs](https://readthedocs.org/).
To build the documentation make sure you have the dependencies installed: from the root directory: ``pip install -r docs/requirements.txt``.
Now you can build the docs using: ``sphinx-build -b html docs build``
## License
BSD 3-Clause
## Sponsor us
[Sponsor us](https://github.com/sponsors/feature-engine) and support further our
mission to democratize machine learning and programming tools through open-source
software.
%package -n python3-feature-engine
Summary: Feature engineering package with Scikit-learn's fit transform functionality
Provides: python-feature-engine
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-feature-engine
# Feature Engine
[](https://pypi.org/project/feature-engine/)
[](https://github.com/feature-engine/feature_engine/blob/master/LICENSE.md)
[](https://pypi.org/project/feature-engine)
[](https://anaconda.org/conda-forge/feature_engine)
[](https://app.circleci.com/pipelines/github/feature-engine/feature_engine)
[](https://codecov.io/github/feature-engine/feature_engine)
[](https://feature-engine.readthedocs.io/en/latest/index.html)
[](https://github.com/psf/black)
[](https://github.com/feature-engine/feature_engine/graphs/contributors)
[](https://gitter.im/feature_engine/community)
[](https://pepy.tech/project/feature-engine)
[](https://pepy.tech/project/feature-engine)
[](https://zenodo.org/badge/latestdoi/163630824)
[](https://doi.org/10.21105/joss.03642)
[](https://www.firsttimersonly.com/)
[](https://www.trainindata.com/)
[](http://feature-engine.readthedocs.io)
Feature-engine is a Python library with multiple transformers to engineer and select features for use in machine learning models.
Feature-engine's transformers follow Scikit-learn's functionality with fit() and transform() methods to learn the
transforming parameters from the data and then transform it.
## Feature-engine features in the following resources
* [Feature Engineering for Machine Learning, Online Course](https://www.trainindata.com/p/feature-engineering-for-machine-learning)
* [Feature Selection for Machine Learning, Online Course](https://www.trainindata.com/p/feature-selection-for-machine-learning)
* [Feature Engineering for Time Series Forecasting, Online Course](https://www.trainindata.com/p/feature-engineering-for-forecasting)
* [Python Feature Engineering Cookbook](https://packt.link/0ewSo)
* [Feature Selection in Machine Learning with Python Book](https://leanpub.com/feature-selection-in-machine-learning)
## Blogs about Feature-engine
* [Feature-engine: A new open-source Python package for feature engineering](https://trainindata.medium.com/feature-engine-a-new-open-source-python-package-for-feature-engineering-29a0ab88ea7c)
* [Practical Code Implementations of Feature Engineering for Machine Learning with Python](https://towardsdatascience.com/practical-code-implementations-of-feature-engineering-for-machine-learning-with-python-f13b953d4bcd)
## Documentation
* [Documentation](https://feature-engine.trainindata.com)
## Current Feature-engine's transformers include functionality for:
* Missing Data Imputation
* Categorical Encoding
* Discretisation
* Outlier Capping or Removal
* Variable Transformation
* Variable Creation
* Variable Selection
* Datetime Features
* Time Series
* Preprocessing
* Scikit-learn Wrappers
### Imputation Methods
* MeanMedianImputer
* RandomSampleImputer
* EndTailImputer
* AddMissingIndicator
* CategoricalImputer
* ArbitraryNumberImputer
* DropMissingData
### Encoding Methods
* OneHotEncoder
* OrdinalEncoder
* CountFrequencyEncoder
* MeanEncoder
* WoEEncoder
* RareLabelEncoder
* DecisionTreeEncoder
* StringSimilarityEncoder
### Discretisation methods
* EqualFrequencyDiscretiser
* EqualWidthDiscretiser
* GeometricWidthDiscretiser
* DecisionTreeDiscretiser
* ArbitraryDiscreriser
### Outlier Handling methods
* Winsorizer
* ArbitraryOutlierCapper
* OutlierTrimmer
### Variable Transformation methods
* LogTransformer
* LogCpTransformer
* ReciprocalTransformer
* ArcsinTransformer
* PowerTransformer
* BoxCoxTransformer
* YeoJohnsonTransformer
### Variable Creation:
* MathFeatures
* RelativeFeatures
* CyclicalFeatures
### Feature Selection:
* DropFeatures
* DropConstantFeatures
* DropDuplicateFeatures
* DropCorrelatedFeatures
* SmartCorrelationSelection
* ShuffleFeaturesSelector
* SelectBySingleFeaturePerformance
* SelectByTargetMeanPerformance
* RecursiveFeatureElimination
* RecursiveFeatureAddition
* DropHighPSIFeatures
* SelectByInformationValue
* ProbeFeatureSelection
### Datetime
* DatetimeFeatures
* DatetimeSubtraction
### Time Series
* LagFeatures
* WindowFeatures
* ExpandingWindowFeatures
### Preprocessing
* MatchCategories
* MatchVariables
### Wrappers:
* SklearnTransformerWrapper
## Installation
From PyPI using pip:
```
pip install feature_engine
```
From Anaconda:
```
conda install -c conda-forge feature_engine
```
Or simply clone it:
```
git clone https://github.com/feature-engine/feature_engine.git
```
## Example Usage
```python
>>> import pandas as pd
>>> from feature_engine.encoding import RareLabelEncoder
>>> data = {'var_A': ['A'] * 10 + ['B'] * 10 + ['C'] * 2 + ['D'] * 1}
>>> data = pd.DataFrame(data)
>>> data['var_A'].value_counts()
```
```
Out[1]:
A 10
B 10
C 2
D 1
Name: var_A, dtype: int64
```
```python
>>> rare_encoder = RareLabelEncoder(tol=0.10, n_categories=3)
>>> data_encoded = rare_encoder.fit_transform(data)
>>> data_encoded['var_A'].value_counts()
```
```
Out[2]:
A 10
B 10
Rare 3
Name: var_A, dtype: int64
```
Find more examples in our [Jupyter Notebook Gallery](https://nbviewer.org/github/feature-engine/feature-engine-examples/tree/main/)
or in the [documentation](https://feature-engine.trainindata.com).
## Contribute
Details about how to contribute can be found in the [Contribute Page](https://feature-engine.trainindata.com/en/latest/contribute/index.html)
Briefly:
- Fork the repo
- Clone your fork into your local computer: ``git clone https://github.com//feature_engine.git``
- navigate into the repo folder ``cd feature_engine``
- Install Feature-engine as a developer: ``pip install -e .``
- Optional: Create and activate a virtual environment with any tool of choice
- Install Feature-engine dependencies: ``pip install -r requirements.txt`` and ``pip install -r test_requirements.txt``
- Create a feature branch with a meaningful name for your feature: ``git checkout -b myfeaturebranch``
- Develop your feature, tests and documentation
- Make sure the tests pass
- Make a PR
Thank you!!
### Documentation
Feature-engine documentation is built using [Sphinx](https://www.sphinx-doc.org) and is hosted on [Read the Docs](https://readthedocs.org/).
To build the documentation make sure you have the dependencies installed: from the root directory: ``pip install -r docs/requirements.txt``.
Now you can build the docs using: ``sphinx-build -b html docs build``
## License
BSD 3-Clause
## Sponsor us
[Sponsor us](https://github.com/sponsors/feature-engine) and support further our
mission to democratize machine learning and programming tools through open-source
software.
%package help
Summary: Development documents and examples for feature-engine
Provides: python3-feature-engine-doc
%description help
# Feature Engine
[](https://pypi.org/project/feature-engine/)
[](https://github.com/feature-engine/feature_engine/blob/master/LICENSE.md)
[](https://pypi.org/project/feature-engine)
[](https://anaconda.org/conda-forge/feature_engine)
[](https://app.circleci.com/pipelines/github/feature-engine/feature_engine)
[](https://codecov.io/github/feature-engine/feature_engine)
[](https://feature-engine.readthedocs.io/en/latest/index.html)
[](https://github.com/psf/black)
[](https://github.com/feature-engine/feature_engine/graphs/contributors)
[](https://gitter.im/feature_engine/community)
[](https://pepy.tech/project/feature-engine)
[](https://pepy.tech/project/feature-engine)
[](https://zenodo.org/badge/latestdoi/163630824)
[](https://doi.org/10.21105/joss.03642)
[](https://www.firsttimersonly.com/)
[](https://www.trainindata.com/)
[](http://feature-engine.readthedocs.io)
Feature-engine is a Python library with multiple transformers to engineer and select features for use in machine learning models.
Feature-engine's transformers follow Scikit-learn's functionality with fit() and transform() methods to learn the
transforming parameters from the data and then transform it.
## Feature-engine features in the following resources
* [Feature Engineering for Machine Learning, Online Course](https://www.trainindata.com/p/feature-engineering-for-machine-learning)
* [Feature Selection for Machine Learning, Online Course](https://www.trainindata.com/p/feature-selection-for-machine-learning)
* [Feature Engineering for Time Series Forecasting, Online Course](https://www.trainindata.com/p/feature-engineering-for-forecasting)
* [Python Feature Engineering Cookbook](https://packt.link/0ewSo)
* [Feature Selection in Machine Learning with Python Book](https://leanpub.com/feature-selection-in-machine-learning)
## Blogs about Feature-engine
* [Feature-engine: A new open-source Python package for feature engineering](https://trainindata.medium.com/feature-engine-a-new-open-source-python-package-for-feature-engineering-29a0ab88ea7c)
* [Practical Code Implementations of Feature Engineering for Machine Learning with Python](https://towardsdatascience.com/practical-code-implementations-of-feature-engineering-for-machine-learning-with-python-f13b953d4bcd)
## Documentation
* [Documentation](https://feature-engine.trainindata.com)
## Current Feature-engine's transformers include functionality for:
* Missing Data Imputation
* Categorical Encoding
* Discretisation
* Outlier Capping or Removal
* Variable Transformation
* Variable Creation
* Variable Selection
* Datetime Features
* Time Series
* Preprocessing
* Scikit-learn Wrappers
### Imputation Methods
* MeanMedianImputer
* RandomSampleImputer
* EndTailImputer
* AddMissingIndicator
* CategoricalImputer
* ArbitraryNumberImputer
* DropMissingData
### Encoding Methods
* OneHotEncoder
* OrdinalEncoder
* CountFrequencyEncoder
* MeanEncoder
* WoEEncoder
* RareLabelEncoder
* DecisionTreeEncoder
* StringSimilarityEncoder
### Discretisation methods
* EqualFrequencyDiscretiser
* EqualWidthDiscretiser
* GeometricWidthDiscretiser
* DecisionTreeDiscretiser
* ArbitraryDiscreriser
### Outlier Handling methods
* Winsorizer
* ArbitraryOutlierCapper
* OutlierTrimmer
### Variable Transformation methods
* LogTransformer
* LogCpTransformer
* ReciprocalTransformer
* ArcsinTransformer
* PowerTransformer
* BoxCoxTransformer
* YeoJohnsonTransformer
### Variable Creation:
* MathFeatures
* RelativeFeatures
* CyclicalFeatures
### Feature Selection:
* DropFeatures
* DropConstantFeatures
* DropDuplicateFeatures
* DropCorrelatedFeatures
* SmartCorrelationSelection
* ShuffleFeaturesSelector
* SelectBySingleFeaturePerformance
* SelectByTargetMeanPerformance
* RecursiveFeatureElimination
* RecursiveFeatureAddition
* DropHighPSIFeatures
* SelectByInformationValue
* ProbeFeatureSelection
### Datetime
* DatetimeFeatures
* DatetimeSubtraction
### Time Series
* LagFeatures
* WindowFeatures
* ExpandingWindowFeatures
### Preprocessing
* MatchCategories
* MatchVariables
### Wrappers:
* SklearnTransformerWrapper
## Installation
From PyPI using pip:
```
pip install feature_engine
```
From Anaconda:
```
conda install -c conda-forge feature_engine
```
Or simply clone it:
```
git clone https://github.com/feature-engine/feature_engine.git
```
## Example Usage
```python
>>> import pandas as pd
>>> from feature_engine.encoding import RareLabelEncoder
>>> data = {'var_A': ['A'] * 10 + ['B'] * 10 + ['C'] * 2 + ['D'] * 1}
>>> data = pd.DataFrame(data)
>>> data['var_A'].value_counts()
```
```
Out[1]:
A 10
B 10
C 2
D 1
Name: var_A, dtype: int64
```
```python
>>> rare_encoder = RareLabelEncoder(tol=0.10, n_categories=3)
>>> data_encoded = rare_encoder.fit_transform(data)
>>> data_encoded['var_A'].value_counts()
```
```
Out[2]:
A 10
B 10
Rare 3
Name: var_A, dtype: int64
```
Find more examples in our [Jupyter Notebook Gallery](https://nbviewer.org/github/feature-engine/feature-engine-examples/tree/main/)
or in the [documentation](https://feature-engine.trainindata.com).
## Contribute
Details about how to contribute can be found in the [Contribute Page](https://feature-engine.trainindata.com/en/latest/contribute/index.html)
Briefly:
- Fork the repo
- Clone your fork into your local computer: ``git clone https://github.com//feature_engine.git``
- navigate into the repo folder ``cd feature_engine``
- Install Feature-engine as a developer: ``pip install -e .``
- Optional: Create and activate a virtual environment with any tool of choice
- Install Feature-engine dependencies: ``pip install -r requirements.txt`` and ``pip install -r test_requirements.txt``
- Create a feature branch with a meaningful name for your feature: ``git checkout -b myfeaturebranch``
- Develop your feature, tests and documentation
- Make sure the tests pass
- Make a PR
Thank you!!
### Documentation
Feature-engine documentation is built using [Sphinx](https://www.sphinx-doc.org) and is hosted on [Read the Docs](https://readthedocs.org/).
To build the documentation make sure you have the dependencies installed: from the root directory: ``pip install -r docs/requirements.txt``.
Now you can build the docs using: ``sphinx-build -b html docs build``
## License
BSD 3-Clause
## Sponsor us
[Sponsor us](https://github.com/sponsors/feature-engine) and support further our
mission to democratize machine learning and programming tools through open-source
software.
%prep
%autosetup -n feature-engine-1.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-feature-engine -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.6.0-1
- Package Spec generated