%global _empty_manifest_terminate_build 0
Name: python-ansimarkup
Version: 1.5.0
Release: 1
Summary: Produce colored terminal text with an xml-like markup
License: Revised BSD License
URL: https://github.com/gvalkov/python-ansimarkup
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/17/57/2ca7c2ab234a01ac778b22fed926e7a63194699b4c1695517653723ae85f/ansimarkup-1.5.0.tar.gz
BuildArch: noarch
Requires: python3-colorama
Requires: python3-bumpversion
Requires: python3-check-manifest
Requires: python3-readme-renderer
Requires: python3-flake8
Requires: python3-pep8-naming
Requires: python3-tox
Requires: python3-pytest
Requires: python3-pytest-cov
%description
|pypi| |build| |license|
Ansimarkup is an XML-like markup for producing colored terminal text.
from ansimarkup import ansiprint as print
print("bold text"))
print("red text", "red text on a green background")
print("orange text")
%package -n python3-ansimarkup
Summary: Produce colored terminal text with an xml-like markup
Provides: python-ansimarkup
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ansimarkup
|pypi| |build| |license|
Ansimarkup is an XML-like markup for producing colored terminal text.
from ansimarkup import ansiprint as print
print("bold text"))
print("red text", "red text on a green background")
print("orange text")
%package help
Summary: Development documents and examples for ansimarkup
Provides: python3-ansimarkup-doc
%description help
|pypi| |build| |license|
Ansimarkup is an XML-like markup for producing colored terminal text.
from ansimarkup import ansiprint as print
print("bold text"))
print("red text", "red text on a green background")
print("orange text")
%prep
%autosetup -n ansimarkup-1.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ansimarkup -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.5.0-1
- Package Spec generated