%global _empty_manifest_terminate_build 0
Name:		python-pgcopy
Version:	1.5.0
Release:	1
Summary:	Fast db insert with postgresql binary copy
License:	MIT
URL:		https://pgcopy.readthedocs.io/en/latest/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/59/dc/89621e9c7752cb2394898a67bebd4445483edfd86d42851defc6b9252af8/pgcopy-1.5.0.tar.gz
BuildArch:	noarch

Requires:	python3-psycopg2
Requires:	python3-pytz

%description
Use pgcopy_ for fast data loading into
PostgreSQL with `binary copy`_.

%package -n python3-pgcopy
Summary:	Fast db insert with postgresql binary copy
Provides:	python-pgcopy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pgcopy
Use pgcopy_ for fast data loading into
PostgreSQL with `binary copy`_.

%package help
Summary:	Development documents and examples for pgcopy
Provides:	python3-pgcopy-doc
%description help
Use pgcopy_ for fast data loading into
PostgreSQL with `binary copy`_.

%prep
%autosetup -n pgcopy-1.5.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pgcopy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.0-1
- Package Spec generated