%global _empty_manifest_terminate_build 0
Name: python-django-amazon-ses
Version: 4.0.1
Release: 1
Summary: A Django email backend that uses Boto3 to interact with Amazon Simple Email Service (SES).
License: Apache License 2.0
URL: https://github.com/azavea/django-amazon-ses
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/75/942582e7017ee8a4b63a829a8c0c4623577d2d4c47be793a5643d5c6257b/django-amazon-ses-4.0.1.tar.gz
BuildArch: noarch
Requires: python3-boto3
Requires: python3-Django
%description
A Django email backend that uses `Boto 3 `_ to interact with `Amazon Simple Email Service (SES) `_.
%package -n python3-django-amazon-ses
Summary: A Django email backend that uses Boto3 to interact with Amazon Simple Email Service (SES).
Provides: python-django-amazon-ses
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-amazon-ses
A Django email backend that uses `Boto 3 `_ to interact with `Amazon Simple Email Service (SES) `_.
%package help
Summary: Development documents and examples for django-amazon-ses
Provides: python3-django-amazon-ses-doc
%description help
A Django email backend that uses `Boto 3 `_ to interact with `Amazon Simple Email Service (SES) `_.
%prep
%autosetup -n django-amazon-ses-4.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-amazon-ses -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 4.0.1-1
- Package Spec generated