%global _empty_manifest_terminate_build 0
Name:		python-typogrify
Version:	2.0.7
Release:	1
Summary:	Filters to enhance web typography, including support for Django & Jinja templates
License:	BSD
URL:		https://github.com/mintchaos/typogrify
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8a/bf/64959d6187d42472acb846bcf462347c9124952c05bd57e5769d5f28f9a6/typogrify-2.0.7.tar.gz
BuildArch:	noarch


%description
The following command will install via ``pip``. Pay particular attention to the
package name::
    pip install typogrify
Alternatively, you can run the following command inside the project's root
directory::
    python setup.py install
Last but not least, you can simply move the enclosed ``typogrify`` folder
into your Python path.

%package -n python3-typogrify
Summary:	Filters to enhance web typography, including support for Django & Jinja templates
Provides:	python-typogrify
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-typogrify
The following command will install via ``pip``. Pay particular attention to the
package name::
    pip install typogrify
Alternatively, you can run the following command inside the project's root
directory::
    python setup.py install
Last but not least, you can simply move the enclosed ``typogrify`` folder
into your Python path.

%package help
Summary:	Development documents and examples for typogrify
Provides:	python3-typogrify-doc
%description help
The following command will install via ``pip``. Pay particular attention to the
package name::
    pip install typogrify
Alternatively, you can run the following command inside the project's root
directory::
    python setup.py install
Last but not least, you can simply move the enclosed ``typogrify`` folder
into your Python path.

%prep
%autosetup -n typogrify-2.0.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-typogrify -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.7-1
- Package Spec generated