%global _empty_manifest_terminate_build 0
Name:		python-vaex-core
Version:	4.16.1
Release:	1
Summary:	Core of vaex
License:	MIT
URL:		https://www.github.com/maartenbreddels/vaex
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/75/d5/9cfa9627386e6bc8cd374e708f1e844402ddd07edd25111e3efef195dd67/vaex-core-4.16.1.tar.gz

Requires:	python3-numpy
Requires:	python3-aplus
Requires:	python3-tabulate
Requires:	python3-future
Requires:	python3-pyyaml
Requires:	python3-progressbar2
Requires:	python3-requests
Requires:	python3-six
Requires:	python3-cloudpickle
Requires:	python3-pandas
Requires:	python3-dask
Requires:	python3-nest-asyncio
Requires:	python3-pyarrow
Requires:	python3-frozendict
Requires:	python3-blake3
Requires:	python3-filelock
Requires:	python3-pydantic
Requires:	python3-rich
Requires:	python3-gcsfs
Requires:	python3-s3fs

%description


%package -n python3-vaex-core
Summary:	Core of vaex
Provides:	python-vaex-core
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-vaex-core


%package help
Summary:	Development documents and examples for vaex-core
Provides:	python3-vaex-core-doc
%description help


%prep
%autosetup -n vaex-core-4.16.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vaex-core -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 4.16.1-1
- Package Spec generated