%global _empty_manifest_terminate_build 0
Name: python-you-get
Version: 0.4.1650
Release: 1
Summary: Dumb downloader that scrapes the web
License: MIT
URL: https://you-get.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/92/39/423701a8346435292fdde5ad78beb5437ebb7718f6faa16e1546d3ef479b/you-get-0.4.1650.tar.gz
BuildArch: noarch
Requires: python3-PySocks
%description
|PyPI version| |Build Status| |Gitter|
`You-Get `__ is a tiny command-line utility to
download media contents (videos, audios, images) from the Web, in case
there is no other handy way to do it.
Here's how you use ``you-get`` to download a video from `this web
page `__:
$ you-get http://www.fsf.org/blogs/rms/20140407-geneva-tedx-talk-free-software-free-society
Site: fsf.org
Title: TEDxGE2014_Stallman05_LQ
Type: WebM video (video/webm)
Size: 27.12 MiB (28435804 Bytes)
Downloading TEDxGE2014_Stallman05_LQ.webm ...
100.0% ( 27.1/27.1 MB) ├████████████████████████████████████████┤[1/1] 12 MB/s
And here's why you might want to use it:
- You enjoyed something on the Internet, and just want to download them
for your own pleasure.
- You watch your favorite videos online from your computer, but you are
prohibited from saving them. You feel that you have no control over
your own computer. (And it's not how an open Web is supposed to
work.)
- You want to get rid of any closed-source technology or proprietary
JavaScript code, and disallow things like Flash running on your
computer.
- You are an adherent of hacker culture and free software.
What ``you-get`` can do for you:
- Download videos / audios from popular websites such as YouTube,
Youku, Niconico, and a bunch more. (See the `full list of supported
sites <#supported-sites>`__)
- Stream an online video in your media player. No web browser, no more
ads.
- Download images (of interest) by scraping a web page.
- Download arbitrary non-HTML contents, i.e., binary files.
Interested? `Install it <#installation>`__ now and `get started by
examples <#getting-started>`__.
Are you a Python programmer? Then check out `the
source `__ and fork it!
%package -n python3-you-get
Summary: Dumb downloader that scrapes the web
Provides: python-you-get
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-you-get
|PyPI version| |Build Status| |Gitter|
`You-Get `__ is a tiny command-line utility to
download media contents (videos, audios, images) from the Web, in case
there is no other handy way to do it.
Here's how you use ``you-get`` to download a video from `this web
page `__:
$ you-get http://www.fsf.org/blogs/rms/20140407-geneva-tedx-talk-free-software-free-society
Site: fsf.org
Title: TEDxGE2014_Stallman05_LQ
Type: WebM video (video/webm)
Size: 27.12 MiB (28435804 Bytes)
Downloading TEDxGE2014_Stallman05_LQ.webm ...
100.0% ( 27.1/27.1 MB) ├████████████████████████████████████████┤[1/1] 12 MB/s
And here's why you might want to use it:
- You enjoyed something on the Internet, and just want to download them
for your own pleasure.
- You watch your favorite videos online from your computer, but you are
prohibited from saving them. You feel that you have no control over
your own computer. (And it's not how an open Web is supposed to
work.)
- You want to get rid of any closed-source technology or proprietary
JavaScript code, and disallow things like Flash running on your
computer.
- You are an adherent of hacker culture and free software.
What ``you-get`` can do for you:
- Download videos / audios from popular websites such as YouTube,
Youku, Niconico, and a bunch more. (See the `full list of supported
sites <#supported-sites>`__)
- Stream an online video in your media player. No web browser, no more
ads.
- Download images (of interest) by scraping a web page.
- Download arbitrary non-HTML contents, i.e., binary files.
Interested? `Install it <#installation>`__ now and `get started by
examples <#getting-started>`__.
Are you a Python programmer? Then check out `the
source `__ and fork it!
%package help
Summary: Development documents and examples for you-get
Provides: python3-you-get-doc
%description help
|PyPI version| |Build Status| |Gitter|
`You-Get `__ is a tiny command-line utility to
download media contents (videos, audios, images) from the Web, in case
there is no other handy way to do it.
Here's how you use ``you-get`` to download a video from `this web
page `__:
$ you-get http://www.fsf.org/blogs/rms/20140407-geneva-tedx-talk-free-software-free-society
Site: fsf.org
Title: TEDxGE2014_Stallman05_LQ
Type: WebM video (video/webm)
Size: 27.12 MiB (28435804 Bytes)
Downloading TEDxGE2014_Stallman05_LQ.webm ...
100.0% ( 27.1/27.1 MB) ├████████████████████████████████████████┤[1/1] 12 MB/s
And here's why you might want to use it:
- You enjoyed something on the Internet, and just want to download them
for your own pleasure.
- You watch your favorite videos online from your computer, but you are
prohibited from saving them. You feel that you have no control over
your own computer. (And it's not how an open Web is supposed to
work.)
- You want to get rid of any closed-source technology or proprietary
JavaScript code, and disallow things like Flash running on your
computer.
- You are an adherent of hacker culture and free software.
What ``you-get`` can do for you:
- Download videos / audios from popular websites such as YouTube,
Youku, Niconico, and a bunch more. (See the `full list of supported
sites <#supported-sites>`__)
- Stream an online video in your media player. No web browser, no more
ads.
- Download images (of interest) by scraping a web page.
- Download arbitrary non-HTML contents, i.e., binary files.
Interested? `Install it <#installation>`__ now and `get started by
examples <#getting-started>`__.
Are you a Python programmer? Then check out `the
source `__ and fork it!
%prep
%autosetup -n you-get-0.4.1650
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-you-get -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.4.1650-1
- Package Spec generated