%global _empty_manifest_terminate_build 0
Name:		python-tamr-unify-client
Version:	1.6.0
Release:	1
Summary:	Python Client for the Tamr API
License:	Apache-2.0
URL:		https://tamr-client.readthedocs.io/en/stable/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4a/b6/0ff7335bb99570769c013351a711218d143bf847ff4d8293266fefcc330b/tamr-unify-client-1.6.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-dataclasses

%description
*Quick links:*
**[Docs](https://tamr-client.readthedocs.io/en/stable/)** |
**[Contributing](https://tamr-client.readthedocs.io/en/stable/contributor-guide.html)** |

%package -n python3-tamr-unify-client
Summary:	Python Client for the Tamr API
Provides:	python-tamr-unify-client
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tamr-unify-client
*Quick links:*
**[Docs](https://tamr-client.readthedocs.io/en/stable/)** |
**[Contributing](https://tamr-client.readthedocs.io/en/stable/contributor-guide.html)** |

%package help
Summary:	Development documents and examples for tamr-unify-client
Provides:	python3-tamr-unify-client-doc
%description help
*Quick links:*
**[Docs](https://tamr-client.readthedocs.io/en/stable/)** |
**[Contributing](https://tamr-client.readthedocs.io/en/stable/contributor-guide.html)** |

%prep
%autosetup -n tamr-unify-client-1.6.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tamr-unify-client -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.0-1
- Package Spec generated