%global _empty_manifest_terminate_build 0
Name: python-trueskill
Version: 0.4.5
Release: 1
Summary: The video game rating system
License: BSD
URL: http://trueskill.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d0/b1/572f309178eacdccd9f9f5f3e3e14fb3543a89c6259d62b36660350af2b9/trueskill-0.4.5.tar.gz
BuildArch: noarch
%description
TrueSkill
~~~~~~~~~
An implementation of the TrueSkill algorithm for Python. TrueSkill is a rating
system among game players and it is used on Xbox Live to rank and match
players.
.. sourcecode:: python
from trueskill import Rating, quality_1vs1, rate_1vs1
alice, bob = Rating(25), Rating(30) # assign Alice and Bob's ratings
if quality_1vs1(alice, bob) < 0.50:
print('This match seems to be not so fair')
alice, bob = rate_1vs1(alice, bob) # update the ratings after the match
Links
`````
Documentation
http://trueskill.org/
GitHub:
http://github.com/sublee/trueskill
Mailing list:
trueskill@librelist.com
List archive:
http://librelist.com/browser/trueskill
Continuous integration (Travis CI)
https://travis-ci.org/sublee/trueskill
.. image:: https://api.travis-ci.org/sublee/trueskill.png
See Also
````````
- `TrueSkill(TM) Ranking System by Microsoft
`_
- `"Computing Your Skill" by Jeff Moser `_
- `"The Math Behind TrueSkill" by Jeff Moser `_
- `TrueSkill Calcurator by Microsoft
`_
%package -n python3-trueskill
Summary: The video game rating system
Provides: python-trueskill
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-trueskill
TrueSkill
~~~~~~~~~
An implementation of the TrueSkill algorithm for Python. TrueSkill is a rating
system among game players and it is used on Xbox Live to rank and match
players.
.. sourcecode:: python
from trueskill import Rating, quality_1vs1, rate_1vs1
alice, bob = Rating(25), Rating(30) # assign Alice and Bob's ratings
if quality_1vs1(alice, bob) < 0.50:
print('This match seems to be not so fair')
alice, bob = rate_1vs1(alice, bob) # update the ratings after the match
Links
`````
Documentation
http://trueskill.org/
GitHub:
http://github.com/sublee/trueskill
Mailing list:
trueskill@librelist.com
List archive:
http://librelist.com/browser/trueskill
Continuous integration (Travis CI)
https://travis-ci.org/sublee/trueskill
.. image:: https://api.travis-ci.org/sublee/trueskill.png
See Also
````````
- `TrueSkill(TM) Ranking System by Microsoft
`_
- `"Computing Your Skill" by Jeff Moser `_
- `"The Math Behind TrueSkill" by Jeff Moser `_
- `TrueSkill Calcurator by Microsoft
`_
%package help
Summary: Development documents and examples for trueskill
Provides: python3-trueskill-doc
%description help
TrueSkill
~~~~~~~~~
An implementation of the TrueSkill algorithm for Python. TrueSkill is a rating
system among game players and it is used on Xbox Live to rank and match
players.
.. sourcecode:: python
from trueskill import Rating, quality_1vs1, rate_1vs1
alice, bob = Rating(25), Rating(30) # assign Alice and Bob's ratings
if quality_1vs1(alice, bob) < 0.50:
print('This match seems to be not so fair')
alice, bob = rate_1vs1(alice, bob) # update the ratings after the match
Links
`````
Documentation
http://trueskill.org/
GitHub:
http://github.com/sublee/trueskill
Mailing list:
trueskill@librelist.com
List archive:
http://librelist.com/browser/trueskill
Continuous integration (Travis CI)
https://travis-ci.org/sublee/trueskill
.. image:: https://api.travis-ci.org/sublee/trueskill.png
See Also
````````
- `TrueSkill(TM) Ranking System by Microsoft
`_
- `"Computing Your Skill" by Jeff Moser `_
- `"The Math Behind TrueSkill" by Jeff Moser `_
- `TrueSkill Calcurator by Microsoft
`_
%prep
%autosetup -n trueskill-0.4.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-trueskill -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.4.5-1
- Package Spec generated