%global _empty_manifest_terminate_build 0
Name:		python-supervisor-wildcards
Version:	0.1.3
Release:	1
Summary:	Implemenents start/stop/restart commands with both parallel and wildcard support for Supervisor.
License:	BSD
URL:		http://github.com/aleszoulek/supervisor-wildcards
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/cb/78/ce6bf00c3310660ab9ebd7c4656a9ebf888a42a58b95a7565b03d40c2f00/supervisor-wildcards-0.1.3.tar.gz
BuildArch:	noarch


%description


%package -n python3-supervisor-wildcards
Summary:	Implemenents start/stop/restart commands with both parallel and wildcard support for Supervisor.
Provides:	python-supervisor-wildcards
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-supervisor-wildcards


%package help
Summary:	Development documents and examples for supervisor-wildcards
Provides:	python3-supervisor-wildcards-doc
%description help


%prep
%autosetup -n supervisor-wildcards-0.1.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-supervisor-wildcards -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3-1
- Package Spec generated