%global _empty_manifest_terminate_build 0
Name: python-animec
Version: 0.4.2
Release: 1
Summary: A module to get data about anime characters, news, info, lyrics and more.
License: MIT
URL: https://github.com/DriftAsimov/animec
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7b/df/1d13470a94b550b3c18721107744411ec422fcdd7963e5c92ca83c87bbb8/animec-0.4.2.tar.gz
BuildArch: noarch
Requires: python3-bs4
Requires: python3-urllib3
%description


# Animec
A module to get data about anime characters, news, info, lyrics and more.
The module scrapes [myanimelist](https://myanimelist.net/) to parse requested data.
If you wish to see a feature, please raise an [issue](https://github.com/DriftAsimov/animec). We will surely work on it.
You can also join our [Discord](https://discord.gg/x3qAZV3) to get regular updates about the module.
See the Docs for a complete documentation: https://animec.readthedocs.io/en/latest/.
## Installation and Usage
To install the module:
```python
pip install animec
```
To import the module:
```python
import animec
# OR
from animec import *
```
## Examples
### Extracting an anime character's data
```python
result = Charsearch("okabe rintarou")
print(result.title, result.url, result.image_url, sep="\n")
'''
Output: (As retrieved from myanimelist), check the documentation for a list of all supported attributes
Rintarou Okabe (岡部 倫太郎)
https://myanimelist.net/character/35252/Rintarou_Okabe
https://cdn.myanimelist.net/images/characters/6/122643.jpg
'''
```
### Requesting anime news
```python
news = Aninews() #default value is 3, check the documentation for a list of all supported attributes
print(news.titles) #returns news titles
print(news.descripion) #returns news description
```
### Getting anime info and recommendations
```python
anime = Anime("dr stone")
print(anime.url)
print(anime.name)
print(anime.description) #check the documentation for a list of all supported attributes
print(anime.recommend()) #returns a list of anime recommendations
```
### Anime Lyrics
```python
lyrics = Anilyrics("Ashiato")
print(lyrics.romaji())
```
## Links
* [Documentation](https://animec.readthedocs.io/en/latest/)
* [GitHub](https://github.com/DriftAsimov)
* [MyAnimeList](https://myanimelist.net/)
* [Animesonglyrics](https://www.animesonglyrics.com/)
* [Kaomoji](http://kaomoji.ru/en/)
* [Discord](https://discord.gg/x3qAZV3)
%package -n python3-animec
Summary: A module to get data about anime characters, news, info, lyrics and more.
Provides: python-animec
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-animec


# Animec
A module to get data about anime characters, news, info, lyrics and more.
The module scrapes [myanimelist](https://myanimelist.net/) to parse requested data.
If you wish to see a feature, please raise an [issue](https://github.com/DriftAsimov/animec). We will surely work on it.
You can also join our [Discord](https://discord.gg/x3qAZV3) to get regular updates about the module.
See the Docs for a complete documentation: https://animec.readthedocs.io/en/latest/.
## Installation and Usage
To install the module:
```python
pip install animec
```
To import the module:
```python
import animec
# OR
from animec import *
```
## Examples
### Extracting an anime character's data
```python
result = Charsearch("okabe rintarou")
print(result.title, result.url, result.image_url, sep="\n")
'''
Output: (As retrieved from myanimelist), check the documentation for a list of all supported attributes
Rintarou Okabe (岡部 倫太郎)
https://myanimelist.net/character/35252/Rintarou_Okabe
https://cdn.myanimelist.net/images/characters/6/122643.jpg
'''
```
### Requesting anime news
```python
news = Aninews() #default value is 3, check the documentation for a list of all supported attributes
print(news.titles) #returns news titles
print(news.descripion) #returns news description
```
### Getting anime info and recommendations
```python
anime = Anime("dr stone")
print(anime.url)
print(anime.name)
print(anime.description) #check the documentation for a list of all supported attributes
print(anime.recommend()) #returns a list of anime recommendations
```
### Anime Lyrics
```python
lyrics = Anilyrics("Ashiato")
print(lyrics.romaji())
```
## Links
* [Documentation](https://animec.readthedocs.io/en/latest/)
* [GitHub](https://github.com/DriftAsimov)
* [MyAnimeList](https://myanimelist.net/)
* [Animesonglyrics](https://www.animesonglyrics.com/)
* [Kaomoji](http://kaomoji.ru/en/)
* [Discord](https://discord.gg/x3qAZV3)
%package help
Summary: Development documents and examples for animec
Provides: python3-animec-doc
%description help


# Animec
A module to get data about anime characters, news, info, lyrics and more.
The module scrapes [myanimelist](https://myanimelist.net/) to parse requested data.
If you wish to see a feature, please raise an [issue](https://github.com/DriftAsimov/animec). We will surely work on it.
You can also join our [Discord](https://discord.gg/x3qAZV3) to get regular updates about the module.
See the Docs for a complete documentation: https://animec.readthedocs.io/en/latest/.
## Installation and Usage
To install the module:
```python
pip install animec
```
To import the module:
```python
import animec
# OR
from animec import *
```
## Examples
### Extracting an anime character's data
```python
result = Charsearch("okabe rintarou")
print(result.title, result.url, result.image_url, sep="\n")
'''
Output: (As retrieved from myanimelist), check the documentation for a list of all supported attributes
Rintarou Okabe (岡部 倫太郎)
https://myanimelist.net/character/35252/Rintarou_Okabe
https://cdn.myanimelist.net/images/characters/6/122643.jpg
'''
```
### Requesting anime news
```python
news = Aninews() #default value is 3, check the documentation for a list of all supported attributes
print(news.titles) #returns news titles
print(news.descripion) #returns news description
```
### Getting anime info and recommendations
```python
anime = Anime("dr stone")
print(anime.url)
print(anime.name)
print(anime.description) #check the documentation for a list of all supported attributes
print(anime.recommend()) #returns a list of anime recommendations
```
### Anime Lyrics
```python
lyrics = Anilyrics("Ashiato")
print(lyrics.romaji())
```
## Links
* [Documentation](https://animec.readthedocs.io/en/latest/)
* [GitHub](https://github.com/DriftAsimov)
* [MyAnimeList](https://myanimelist.net/)
* [Animesonglyrics](https://www.animesonglyrics.com/)
* [Kaomoji](http://kaomoji.ru/en/)
* [Discord](https://discord.gg/x3qAZV3)
%prep
%autosetup -n animec-0.4.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-animec -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.4.2-1
- Package Spec generated