%global _empty_manifest_terminate_build 0
Name: python-easydev
Version: 0.12.1
Release: 1
Summary: Common utilities to ease the development of Python packages
License: BSD-3-Clause
URL: http://github.com/cokelaer/easydev
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/57/26/eb26a8dd1ca11869a00cfac5ed272cadf68566ac2f0e973b4982eaf7213b/easydev-0.12.1.tar.gz
BuildArch: noarch
%description
easydev
##########
.. image:: https://badge.fury.io/py/easydev.svg
:target: https://pypi.python.org/pypi/easydev
.. image:: https://github.com/cokelaer/easydev/actions/workflows/main.yml/badge.svg
:target: https://github.com/cokelaer/easydev/actions/workflows/main.yml
.. image:: https://coveralls.io/repos/cokelaer/easydev/badge.svg?branch=main
:target: https://coveralls.io/r/cokelaer/easydev?branch=main
:documentation: http://easydev-python.readthedocs.io/en/latest/
:contributions: Please join https://github.com/cokelaer/easydev
:source: Please use https://github.com/cokelaer/easydev
:issues: Please use https://github.com/cokelaer/easydev/issues
:Python version supported: 3.7, 3.8, 3.9, 3.10
The `easydev `_ package
provides miscellaneous functions that are repeatidly used during
the development of Python packages. The goal is to help developers on
speeding up their own dev. It has been used also as an incubator for other
packages (e.g., http://pypi.python.org/pypi/colormap) and is stable.
.. warning:: I'm not pretending to provide universal and bug-free tools. The
tools provided may also change. However, **easydev** is used
in a few other packages such as
`bioservices `_,
`sequana `_ or
`GDSCTools `_ to give a few
examples.
%package -n python3-easydev
Summary: Common utilities to ease the development of Python packages
Provides: python-easydev
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-easydev
easydev
##########
.. image:: https://badge.fury.io/py/easydev.svg
:target: https://pypi.python.org/pypi/easydev
.. image:: https://github.com/cokelaer/easydev/actions/workflows/main.yml/badge.svg
:target: https://github.com/cokelaer/easydev/actions/workflows/main.yml
.. image:: https://coveralls.io/repos/cokelaer/easydev/badge.svg?branch=main
:target: https://coveralls.io/r/cokelaer/easydev?branch=main
:documentation: http://easydev-python.readthedocs.io/en/latest/
:contributions: Please join https://github.com/cokelaer/easydev
:source: Please use https://github.com/cokelaer/easydev
:issues: Please use https://github.com/cokelaer/easydev/issues
:Python version supported: 3.7, 3.8, 3.9, 3.10
The `easydev `_ package
provides miscellaneous functions that are repeatidly used during
the development of Python packages. The goal is to help developers on
speeding up their own dev. It has been used also as an incubator for other
packages (e.g., http://pypi.python.org/pypi/colormap) and is stable.
.. warning:: I'm not pretending to provide universal and bug-free tools. The
tools provided may also change. However, **easydev** is used
in a few other packages such as
`bioservices `_,
`sequana `_ or
`GDSCTools `_ to give a few
examples.
%package help
Summary: Development documents and examples for easydev
Provides: python3-easydev-doc
%description help
easydev
##########
.. image:: https://badge.fury.io/py/easydev.svg
:target: https://pypi.python.org/pypi/easydev
.. image:: https://github.com/cokelaer/easydev/actions/workflows/main.yml/badge.svg
:target: https://github.com/cokelaer/easydev/actions/workflows/main.yml
.. image:: https://coveralls.io/repos/cokelaer/easydev/badge.svg?branch=main
:target: https://coveralls.io/r/cokelaer/easydev?branch=main
:documentation: http://easydev-python.readthedocs.io/en/latest/
:contributions: Please join https://github.com/cokelaer/easydev
:source: Please use https://github.com/cokelaer/easydev
:issues: Please use https://github.com/cokelaer/easydev/issues
:Python version supported: 3.7, 3.8, 3.9, 3.10
The `easydev `_ package
provides miscellaneous functions that are repeatidly used during
the development of Python packages. The goal is to help developers on
speeding up their own dev. It has been used also as an incubator for other
packages (e.g., http://pypi.python.org/pypi/colormap) and is stable.
.. warning:: I'm not pretending to provide universal and bug-free tools. The
tools provided may also change. However, **easydev** is used
in a few other packages such as
`bioservices `_,
`sequana `_ or
`GDSCTools `_ to give a few
examples.
%prep
%autosetup -n easydev-0.12.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-easydev -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.12.1-1
- Package Spec generated