%global _empty_manifest_terminate_build 0
Name:		python-frictionless
Version:	5.10.5
Release:	1
Summary:	Data management framework for Python that provides functionality to describe, extract, validate, and transform tabular data
License:	MIT
URL:		https://github.com/frictionlessdata/frictionless-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3b/ae/41c0b969964134e603db53f4fa7d567961d1dc88529d6dd02e97bce6a191/frictionless-5.10.5.tar.gz
BuildArch:	noarch

Requires:	python3-petl
Requires:	python3-marko
Requires:	python3-attrs
Requires:	python3-jinja2
Requires:	python3-pyyaml
Requires:	python3-isodate
Requires:	python3-rfc3986
Requires:	python3-chardet
Requires:	python3-pydantic
Requires:	python3-requests
Requires:	python3-humanize
Requires:	python3-tabulate
Requires:	python3-jsonschema
Requires:	python3-simpleeval
Requires:	python3-stringcase
Requires:	python3-typer[all]
Requires:	python3-validators
Requires:	python3-slugify
Requires:	python3-dateutil
Requires:	python3-typing-extensions
Requires:	python3-fastapi
Requires:	python3-uvicorn
Requires:	python3-multipart
Requires:	python3-boto3
Requires:	python3-google-api-python-client
Requires:	python3-frictionless-ckan-mapper
Requires:	python3-datasette
Requires:	python3-moto
Requires:	python3-httpx
Requires:	python3-black
Requires:	python3-yattag
Requires:	python3-pylama
Requires:	python3-pytest
Requires:	python3-pyright
Requires:	python3-ipython
Requires:	python3-livemark
Requires:	python3-pytest-cov
Requires:	python3-pytest-vcr
Requires:	python3-pytest-mock
Requires:	python3-pytest-only
Requires:	python3-oauth2client
Requires:	python3-requests-mock
Requires:	python3-pytest-dotenv
Requires:	python3-pytest-timeout
Requires:	python3-pytest-lazy-fixture
Requires:	python3-xlrd
Requires:	python3-xlwt
Requires:	python3-openpyxl
Requires:	python3-tableschema-to-template
Requires:	python3-pygithub
Requires:	python3-pygsheets
Requires:	python3-pyquery
Requires:	python3-ijson
Requires:	python3-jsonlines
Requires:	python3-livemark
Requires:	python3-sqlalchemy
Requires:	python3-pymysql
Requires:	python3-ezodf
Requires:	python3-lxml
Requires:	python3-pandas
Requires:	python3-fastparquet
Requires:	python3-sqlalchemy
Requires:	python3-psycopg
Requires:	python3-psycopg2
Requires:	python3-savReaderWriter
Requires:	python3-sqlalchemy
Requires:	python3-visidata
Requires:	python3-grako
Requires:	python3-pyzenodo3

%description
             3  blank-header      Header in field at position "3" is blank
             4  duplicate-header  Header "name" in field "4" is duplicated
    2        3  missing-cell      Row "2" has a missing cell in field "field3"
    2        4  missing-cell      Row "2" has a missing cell in field "name2"
    3        3  missing-cell      Row "3" has a missing cell in field "field3"
    3        4  missing-cell      Row "3" has a missing cell in field "name2"
    4           blank-row         Row "4" is completely blank
    5        5  extra-cell        Row "5" has an extra value in field  "5"
```
## Documentation
Please visit our documentation portal:
- https://framework.frictionlessdata.io

%package -n python3-frictionless
Summary:	Data management framework for Python that provides functionality to describe, extract, validate, and transform tabular data
Provides:	python-frictionless
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-frictionless
             3  blank-header      Header in field at position "3" is blank
             4  duplicate-header  Header "name" in field "4" is duplicated
    2        3  missing-cell      Row "2" has a missing cell in field "field3"
    2        4  missing-cell      Row "2" has a missing cell in field "name2"
    3        3  missing-cell      Row "3" has a missing cell in field "field3"
    3        4  missing-cell      Row "3" has a missing cell in field "name2"
    4           blank-row         Row "4" is completely blank
    5        5  extra-cell        Row "5" has an extra value in field  "5"
```
## Documentation
Please visit our documentation portal:
- https://framework.frictionlessdata.io

%package help
Summary:	Development documents and examples for frictionless
Provides:	python3-frictionless-doc
%description help
             3  blank-header      Header in field at position "3" is blank
             4  duplicate-header  Header "name" in field "4" is duplicated
    2        3  missing-cell      Row "2" has a missing cell in field "field3"
    2        4  missing-cell      Row "2" has a missing cell in field "name2"
    3        3  missing-cell      Row "3" has a missing cell in field "field3"
    3        4  missing-cell      Row "3" has a missing cell in field "name2"
    4           blank-row         Row "4" is completely blank
    5        5  extra-cell        Row "5" has an extra value in field  "5"
```
## Documentation
Please visit our documentation portal:
- https://framework.frictionlessdata.io

%prep
%autosetup -n frictionless-5.10.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-frictionless -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 5.10.5-1
- Package Spec generated