%global _empty_manifest_terminate_build 0
Name: python-randfacts
Version: 0.20.1
Release: 1
Summary: Package to generate random facts
License: MIT License
URL: https://github.com/TabulateJarl8/randfacts
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/58/3e/c2d84de058ebd855fcbe2392eea0d7cbd1ed526792e5dbd2e5055450a16f/randfacts-0.20.1.tar.gz
BuildArch: noarch
%description
Randfacts is a Python module that generates random facts. You can use `randfacts.get_fact()` to return a random fun fact. Disclaimer: Facts are not guaranteed to be true.
# Installation
randfacts can either be installed via pip or via the AUR, whichever way you prefer.
### Installation via pip:
```sh
$ pip3 install randfacts
```
### Installation via AUR:
Via your AUR helper, like paru:
```sh
$ paru -S python-randfacts
```
Or manually
```sh
$ git clone https://aur.archlinux.org/python-randfacts.git && cd python-randfacts
$ makepkg -si
```
# Usage and examples
```python
import randfacts
x = randfacts.get_fact()
print(x)
```
The above example will print a random fact like:
`Penguins can't taste sweet or savory flavors, only sour and salty ones`
This package has a filter option to filter out potentially inappropriate facts. The filter is on by default. To disable the filter, you can just set the `filter_enabled` parameter to `False`.
```python
from randfacts import get_fact
print(get_fact(False))
# or
print(get_fact(filter_enabled=False))
```
`get_fact` also has a parameter that will make the function only return unsafe facts. This argument takes precedence over the `filter_enabled` argument. For example:
```py
print(get_fact(only_unsafe=True))
```
If you want to access the list of facts directly, you can just import the `safe_facts`, `unsafe_facts`, or `all_facts` lists from the randfacts module.
## Command line usage
randfacts can be executed via the command line with the following commands:
Normal execution; only SFW (safe for work) facts
```sh
$ python3 -m randfacts
```
The unsafe argument can be supplied to provide only NSFW (not safe for work) facts
```sh
$ python3 -m randfacts --unsafe
```
The mixed argument can be provided to provide both SFW and NSFW facts.
```sh
$ python3 -m randfacts --mixed
```
More help.
```sh
$ python3 -m randfacts --help
```
%package -n python3-randfacts
Summary: Package to generate random facts
Provides: python-randfacts
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-randfacts
Randfacts is a Python module that generates random facts. You can use `randfacts.get_fact()` to return a random fun fact. Disclaimer: Facts are not guaranteed to be true.
# Installation
randfacts can either be installed via pip or via the AUR, whichever way you prefer.
### Installation via pip:
```sh
$ pip3 install randfacts
```
### Installation via AUR:
Via your AUR helper, like paru:
```sh
$ paru -S python-randfacts
```
Or manually
```sh
$ git clone https://aur.archlinux.org/python-randfacts.git && cd python-randfacts
$ makepkg -si
```
# Usage and examples
```python
import randfacts
x = randfacts.get_fact()
print(x)
```
The above example will print a random fact like:
`Penguins can't taste sweet or savory flavors, only sour and salty ones`
This package has a filter option to filter out potentially inappropriate facts. The filter is on by default. To disable the filter, you can just set the `filter_enabled` parameter to `False`.
```python
from randfacts import get_fact
print(get_fact(False))
# or
print(get_fact(filter_enabled=False))
```
`get_fact` also has a parameter that will make the function only return unsafe facts. This argument takes precedence over the `filter_enabled` argument. For example:
```py
print(get_fact(only_unsafe=True))
```
If you want to access the list of facts directly, you can just import the `safe_facts`, `unsafe_facts`, or `all_facts` lists from the randfacts module.
## Command line usage
randfacts can be executed via the command line with the following commands:
Normal execution; only SFW (safe for work) facts
```sh
$ python3 -m randfacts
```
The unsafe argument can be supplied to provide only NSFW (not safe for work) facts
```sh
$ python3 -m randfacts --unsafe
```
The mixed argument can be provided to provide both SFW and NSFW facts.
```sh
$ python3 -m randfacts --mixed
```
More help.
```sh
$ python3 -m randfacts --help
```
%package help
Summary: Development documents and examples for randfacts
Provides: python3-randfacts-doc
%description help
Randfacts is a Python module that generates random facts. You can use `randfacts.get_fact()` to return a random fun fact. Disclaimer: Facts are not guaranteed to be true.
# Installation
randfacts can either be installed via pip or via the AUR, whichever way you prefer.
### Installation via pip:
```sh
$ pip3 install randfacts
```
### Installation via AUR:
Via your AUR helper, like paru:
```sh
$ paru -S python-randfacts
```
Or manually
```sh
$ git clone https://aur.archlinux.org/python-randfacts.git && cd python-randfacts
$ makepkg -si
```
# Usage and examples
```python
import randfacts
x = randfacts.get_fact()
print(x)
```
The above example will print a random fact like:
`Penguins can't taste sweet or savory flavors, only sour and salty ones`
This package has a filter option to filter out potentially inappropriate facts. The filter is on by default. To disable the filter, you can just set the `filter_enabled` parameter to `False`.
```python
from randfacts import get_fact
print(get_fact(False))
# or
print(get_fact(filter_enabled=False))
```
`get_fact` also has a parameter that will make the function only return unsafe facts. This argument takes precedence over the `filter_enabled` argument. For example:
```py
print(get_fact(only_unsafe=True))
```
If you want to access the list of facts directly, you can just import the `safe_facts`, `unsafe_facts`, or `all_facts` lists from the randfacts module.
## Command line usage
randfacts can be executed via the command line with the following commands:
Normal execution; only SFW (safe for work) facts
```sh
$ python3 -m randfacts
```
The unsafe argument can be supplied to provide only NSFW (not safe for work) facts
```sh
$ python3 -m randfacts --unsafe
```
The mixed argument can be provided to provide both SFW and NSFW facts.
```sh
$ python3 -m randfacts --mixed
```
More help.
```sh
$ python3 -m randfacts --help
```
%prep
%autosetup -n randfacts-0.20.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-randfacts -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.20.1-1
- Package Spec generated