%global _empty_manifest_terminate_build 0
Name: python-librespot
Version: 0.0.7
Release: 1
Summary: Open Source Spotify Client
License: Apache-2.0
URL: https://github.com/kokarare1212/librespot-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/c9/26a87a96891d88265c5fd979c7efa5468c5828d82b192e2d4a0e7a3f3a3f/librespot-0.0.7.tar.gz
BuildArch: noarch
Requires: python3-defusedxml
Requires: python3-protobuf
Requires: python3-pycryptodomex
Requires: python3-pyogg
Requires: python3-requests
Requires: python3-websocket-client
Requires: python3-zeroconf
%description



[](https://deepsource.io/gh/kokarare1212/librespot-python/?ref=repository-badge)
# Librespot-Python
Open Source Spotify Client
## About The Project
This project was developed to make the music streaming service Spotify available
on any device.
## Attention!
This repository has been completely rewritten from the transplant.
There may be some functions that are not implemented yet.
If so, please feel free to open an issue.
## Note
It is still in the idea stage, so there is a possibility of unintended behavior
or major specification changes.
We **DO NOT** encourage piracy and **DO NOT** support any form of downloader/recorder designed with the help of this repository and in general anything that goes against the Spotify ToS.
For other guidelines, please see [CODE_OF_CONDUCT.md](https://github.com/kokarare1212/librespot-python/blob/main/CODE_OF_CONDUCT.md).
## Getting Started
### Prerequisites
- [Python](https://python.org/)
### Installation
Stable Version
```commandline
pip install librespot
```
Snapshot Version \***Recommended**
```commandline
pip install git+https://github.com/kokarare1212/librespot-python
```
## Usage
### Use Zeroconf for Login
```python
from librespot.zeroconf import ZeroconfServer
zeroconf = ZeroconfServer.Builder().create()
```
### Get Spotify's OAuth token
```python
from librespot.core import Session
session = Session.Builder() \
.user_pass("Username", "Password") \
.create()
access_token = session.tokens().get("playlist-read")
```
### Get Music Stream
*Currently, music streaming is supported, but it may cause unintended behavior.
```python
from librespot.core import Session
from librespot.metadata import TrackId
from librespot.audio.decoders import AudioQuality, VorbisOnlyAudioQuality
session = Session.Builder() \
.user_pass("Username", "Password") \
.create()
track_id = TrackId.from_uri("spotify:track:xxxxxxxxxxxxxxxxxxxxxx")
stream = session.content_feeder().load(track_id, VorbisOnlyAudioQuality(AudioQuality.VERY_HIGH), False, None)
# stream.input_stream.stream().read() to get one byte of the music stream.
```
Other uses are
[examples](https://github.com/kokarare1212/librespot-python/tree/main/examples)
or read [this document](https://librespot-python.rtfd.io) for detailed
specifications.
## Debug
To display the debug information, you need to inject the following code at the
top of the code.
```python
import logging
logging.basicConfig(level=logging.DEBUG)
```
## Contributing
Pull requests are welcome.
## License
Distributed under the Apache-2.0 License. See
[LICENSE.txt](https://github.com/kokarare1212/librespot-python/blob/main/LICENSE.txt)
for more information.
## Related Projects
- [Librespot](https://github.com/librespot-org/librespot) (Concept)
- [Librespot-Java](https://github.com/librespot-org/librespot-java) (Core)
## Special thanks
%package -n python3-librespot
Summary: Open Source Spotify Client
Provides: python-librespot
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-librespot



[](https://deepsource.io/gh/kokarare1212/librespot-python/?ref=repository-badge)
# Librespot-Python
Open Source Spotify Client
## About The Project
This project was developed to make the music streaming service Spotify available
on any device.
## Attention!
This repository has been completely rewritten from the transplant.
There may be some functions that are not implemented yet.
If so, please feel free to open an issue.
## Note
It is still in the idea stage, so there is a possibility of unintended behavior
or major specification changes.
We **DO NOT** encourage piracy and **DO NOT** support any form of downloader/recorder designed with the help of this repository and in general anything that goes against the Spotify ToS.
For other guidelines, please see [CODE_OF_CONDUCT.md](https://github.com/kokarare1212/librespot-python/blob/main/CODE_OF_CONDUCT.md).
## Getting Started
### Prerequisites
- [Python](https://python.org/)
### Installation
Stable Version
```commandline
pip install librespot
```
Snapshot Version \***Recommended**
```commandline
pip install git+https://github.com/kokarare1212/librespot-python
```
## Usage
### Use Zeroconf for Login
```python
from librespot.zeroconf import ZeroconfServer
zeroconf = ZeroconfServer.Builder().create()
```
### Get Spotify's OAuth token
```python
from librespot.core import Session
session = Session.Builder() \
.user_pass("Username", "Password") \
.create()
access_token = session.tokens().get("playlist-read")
```
### Get Music Stream
*Currently, music streaming is supported, but it may cause unintended behavior.
```python
from librespot.core import Session
from librespot.metadata import TrackId
from librespot.audio.decoders import AudioQuality, VorbisOnlyAudioQuality
session = Session.Builder() \
.user_pass("Username", "Password") \
.create()
track_id = TrackId.from_uri("spotify:track:xxxxxxxxxxxxxxxxxxxxxx")
stream = session.content_feeder().load(track_id, VorbisOnlyAudioQuality(AudioQuality.VERY_HIGH), False, None)
# stream.input_stream.stream().read() to get one byte of the music stream.
```
Other uses are
[examples](https://github.com/kokarare1212/librespot-python/tree/main/examples)
or read [this document](https://librespot-python.rtfd.io) for detailed
specifications.
## Debug
To display the debug information, you need to inject the following code at the
top of the code.
```python
import logging
logging.basicConfig(level=logging.DEBUG)
```
## Contributing
Pull requests are welcome.
## License
Distributed under the Apache-2.0 License. See
[LICENSE.txt](https://github.com/kokarare1212/librespot-python/blob/main/LICENSE.txt)
for more information.
## Related Projects
- [Librespot](https://github.com/librespot-org/librespot) (Concept)
- [Librespot-Java](https://github.com/librespot-org/librespot-java) (Core)
## Special thanks
%package help
Summary: Development documents and examples for librespot
Provides: python3-librespot-doc
%description help



[](https://deepsource.io/gh/kokarare1212/librespot-python/?ref=repository-badge)
# Librespot-Python
Open Source Spotify Client
## About The Project
This project was developed to make the music streaming service Spotify available
on any device.
## Attention!
This repository has been completely rewritten from the transplant.
There may be some functions that are not implemented yet.
If so, please feel free to open an issue.
## Note
It is still in the idea stage, so there is a possibility of unintended behavior
or major specification changes.
We **DO NOT** encourage piracy and **DO NOT** support any form of downloader/recorder designed with the help of this repository and in general anything that goes against the Spotify ToS.
For other guidelines, please see [CODE_OF_CONDUCT.md](https://github.com/kokarare1212/librespot-python/blob/main/CODE_OF_CONDUCT.md).
## Getting Started
### Prerequisites
- [Python](https://python.org/)
### Installation
Stable Version
```commandline
pip install librespot
```
Snapshot Version \***Recommended**
```commandline
pip install git+https://github.com/kokarare1212/librespot-python
```
## Usage
### Use Zeroconf for Login
```python
from librespot.zeroconf import ZeroconfServer
zeroconf = ZeroconfServer.Builder().create()
```
### Get Spotify's OAuth token
```python
from librespot.core import Session
session = Session.Builder() \
.user_pass("Username", "Password") \
.create()
access_token = session.tokens().get("playlist-read")
```
### Get Music Stream
*Currently, music streaming is supported, but it may cause unintended behavior.
```python
from librespot.core import Session
from librespot.metadata import TrackId
from librespot.audio.decoders import AudioQuality, VorbisOnlyAudioQuality
session = Session.Builder() \
.user_pass("Username", "Password") \
.create()
track_id = TrackId.from_uri("spotify:track:xxxxxxxxxxxxxxxxxxxxxx")
stream = session.content_feeder().load(track_id, VorbisOnlyAudioQuality(AudioQuality.VERY_HIGH), False, None)
# stream.input_stream.stream().read() to get one byte of the music stream.
```
Other uses are
[examples](https://github.com/kokarare1212/librespot-python/tree/main/examples)
or read [this document](https://librespot-python.rtfd.io) for detailed
specifications.
## Debug
To display the debug information, you need to inject the following code at the
top of the code.
```python
import logging
logging.basicConfig(level=logging.DEBUG)
```
## Contributing
Pull requests are welcome.
## License
Distributed under the Apache-2.0 License. See
[LICENSE.txt](https://github.com/kokarare1212/librespot-python/blob/main/LICENSE.txt)
for more information.
## Related Projects
- [Librespot](https://github.com/librespot-org/librespot) (Concept)
- [Librespot-Java](https://github.com/librespot-org/librespot-java) (Core)
## Special thanks
%prep
%autosetup -n librespot-0.0.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-librespot -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.0.7-1
- Package Spec generated