%global _empty_manifest_terminate_build 0
Name: python-neomodel
Version: 5.0.0
Release: 1
Summary: An object mapper for the neo4j graph database.
License: MIT
URL: https://pypi.org/project/neomodel/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a2/b2/e5182ad4773151a7d42e71fad358159018f3adcdc49c8b4863c059a07e47/neomodel-5.0.0.tar.gz
BuildArch: noarch
Requires: python3-neo4j-driver
Requires: python3-pytz
Requires: python3-neobolt
Requires: python3-six
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pre-commit
Requires: python3-black
Requires: python3-isort
Requires: python3-Shapely
%description
This project did not receive releases between December 2021 and early 2023. Active maintenance of the project is now being picked up again.
Please look at the Issues page, and especially this thread for more information about the current plan : https://github.com/neo4j-contrib/neomodel/issues/653
**Please note:**
*This repository now tracks release 5.0 of neomodel that works with Neo4j 5.x and Neo4j 4.4*.
The last neomodel 4.x release was `neomodel 4.0.10 `_.
%package -n python3-neomodel
Summary: An object mapper for the neo4j graph database.
Provides: python-neomodel
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-neomodel
This project did not receive releases between December 2021 and early 2023. Active maintenance of the project is now being picked up again.
Please look at the Issues page, and especially this thread for more information about the current plan : https://github.com/neo4j-contrib/neomodel/issues/653
**Please note:**
*This repository now tracks release 5.0 of neomodel that works with Neo4j 5.x and Neo4j 4.4*.
The last neomodel 4.x release was `neomodel 4.0.10 `_.
%package help
Summary: Development documents and examples for neomodel
Provides: python3-neomodel-doc
%description help
This project did not receive releases between December 2021 and early 2023. Active maintenance of the project is now being picked up again.
Please look at the Issues page, and especially this thread for more information about the current plan : https://github.com/neo4j-contrib/neomodel/issues/653
**Please note:**
*This repository now tracks release 5.0 of neomodel that works with Neo4j 5.x and Neo4j 4.4*.
The last neomodel 4.x release was `neomodel 4.0.10 `_.
%prep
%autosetup -n neomodel-5.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-neomodel -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 5.0.0-1
- Package Spec generated