%global _empty_manifest_terminate_build 0 Name: python-pgrep Version: 2020.12.3 Release: 1 Summary: pgrep python wrapper License: Unlicense URL: https://github.com/andrewp-as-is/pgrep.py Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e9/ad/a2f2e4238f4228764eab4d8e8b57fb26cd917ea56bcd421fe51a5c6d4250/pgrep-2020.12.3.tar.gz BuildArch: noarch %description [![](https://img.shields.io/pypi/v/pgrep.svg?maxAge=3600)](https://pypi.org/project/pgrep/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install pgrep ``` #### Examples ```python >>> import pgrep >>> pgrep.pgrep("Finder") [322] >>> pgrep.pgrep("bash") [416, 434, 30681, 30918] >>> pgrep.pgrep("not-existing-process") [] ```

readme42.com

%package -n python3-pgrep Summary: pgrep python wrapper Provides: python-pgrep BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-pgrep [![](https://img.shields.io/pypi/v/pgrep.svg?maxAge=3600)](https://pypi.org/project/pgrep/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install pgrep ``` #### Examples ```python >>> import pgrep >>> pgrep.pgrep("Finder") [322] >>> pgrep.pgrep("bash") [416, 434, 30681, 30918] >>> pgrep.pgrep("not-existing-process") [] ```

readme42.com

%package help Summary: Development documents and examples for pgrep Provides: python3-pgrep-doc %description help [![](https://img.shields.io/pypi/v/pgrep.svg?maxAge=3600)](https://pypi.org/project/pgrep/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install pgrep ``` #### Examples ```python >>> import pgrep >>> pgrep.pgrep("Finder") [322] >>> pgrep.pgrep("bash") [416, 434, 30681, 30918] >>> pgrep.pgrep("not-existing-process") [] ```

readme42.com

%prep %autosetup -n pgrep-2020.12.3 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-pgrep -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Apr 11 2023 Python_Bot - 2020.12.3-1 - Package Spec generated