%global _empty_manifest_terminate_build 0
Name: python-Flask-QRcode
Version: 3.1.0
Release: 1
Summary: A concise Flask extension to render QR codes on Jinja2 templates using python-qrcode
License: GPLv3
URL: https://github.com/marcoagner/Flask-QRcode
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6f/2a/69e9ec20a6215ec5ea0c8346f65cd249537e3e72ce34414be61d39f9b83c/Flask-QRcode-3.1.0.tar.gz
BuildArch: noarch
Requires: python3-Flask
Requires: python3-qrcode
Requires: python3-pillow
%description
[![PyPI version](https://badge.fury.io/py/Flask-QRcode.svg)](https://badge.fury.io/py/Flask-QRcode)
> A concise Flask extension to easily render QR codes on Jinja2 templates using
[python-qrcode](https://github.com/lincolnloop/python-qrcode)
You can read the [full documentation here](https://marcoagner.github.io/Flask-QRcode/).
![](QRcode.png)
## Installation
```
pip install Flask-QRcode
```
## Usage:
### Extend the app:
```
from flask_qrcode import QRcode
# [...]
QRcode(app)
# [...]
```
### Then use it within your templates:
#### Basic usage:
### More examples:
For more examples, just run the sample application in this repository.
[Sample Application](https://github.com/marcoagner/Flask-QRcode/tree/master/sample_application)
## Contributing:
Thank you for considering contributing to this package.
As this is a simple package, the process is pretty straightforward...
1. Fork this repository
2. Checkout from master with to a feature branch with a name related to what is being contributed (e.g. "colored-qrcodes")
\**It's highly recommended that your contribution either creates a new **feature**, **fixes** something OR **refactors** the code and does not mix these (e.g. one PR fixing some existent feature and refactoring non-related code).*
3. Install dependencies and flask_qrcode on editable mode
```
pip install -e . # for installing flask_qrcode on editable mode
```
4. Do your magic
5. Provide new tests for your work and check that both this and the old ones
are passing
6. Pull Request!
## Testing:
1. Install dependencies and flask_qrcode on editable mode
```
pip install -e . # for installing flask_qrcode on editable mode
```
2. Run pytest
```
python setup.py test # on package's root dir
```
%package -n python3-Flask-QRcode
Summary: A concise Flask extension to render QR codes on Jinja2 templates using python-qrcode
Provides: python-Flask-QRcode
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Flask-QRcode
[![PyPI version](https://badge.fury.io/py/Flask-QRcode.svg)](https://badge.fury.io/py/Flask-QRcode)
> A concise Flask extension to easily render QR codes on Jinja2 templates using
[python-qrcode](https://github.com/lincolnloop/python-qrcode)
You can read the [full documentation here](https://marcoagner.github.io/Flask-QRcode/).
![](QRcode.png)
## Installation
```
pip install Flask-QRcode
```
## Usage:
### Extend the app:
```
from flask_qrcode import QRcode
# [...]
QRcode(app)
# [...]
```
### Then use it within your templates:
#### Basic usage:
### More examples:
For more examples, just run the sample application in this repository.
[Sample Application](https://github.com/marcoagner/Flask-QRcode/tree/master/sample_application)
## Contributing:
Thank you for considering contributing to this package.
As this is a simple package, the process is pretty straightforward...
1. Fork this repository
2. Checkout from master with to a feature branch with a name related to what is being contributed (e.g. "colored-qrcodes")
\**It's highly recommended that your contribution either creates a new **feature**, **fixes** something OR **refactors** the code and does not mix these (e.g. one PR fixing some existent feature and refactoring non-related code).*
3. Install dependencies and flask_qrcode on editable mode
```
pip install -e . # for installing flask_qrcode on editable mode
```
4. Do your magic
5. Provide new tests for your work and check that both this and the old ones
are passing
6. Pull Request!
## Testing:
1. Install dependencies and flask_qrcode on editable mode
```
pip install -e . # for installing flask_qrcode on editable mode
```
2. Run pytest
```
python setup.py test # on package's root dir
```
%package help
Summary: Development documents and examples for Flask-QRcode
Provides: python3-Flask-QRcode-doc
%description help
[![PyPI version](https://badge.fury.io/py/Flask-QRcode.svg)](https://badge.fury.io/py/Flask-QRcode)
> A concise Flask extension to easily render QR codes on Jinja2 templates using
[python-qrcode](https://github.com/lincolnloop/python-qrcode)
You can read the [full documentation here](https://marcoagner.github.io/Flask-QRcode/).
![](QRcode.png)
## Installation
```
pip install Flask-QRcode
```
## Usage:
### Extend the app:
```
from flask_qrcode import QRcode
# [...]
QRcode(app)
# [...]
```
### Then use it within your templates:
#### Basic usage:
### More examples:
For more examples, just run the sample application in this repository.
[Sample Application](https://github.com/marcoagner/Flask-QRcode/tree/master/sample_application)
## Contributing:
Thank you for considering contributing to this package.
As this is a simple package, the process is pretty straightforward...
1. Fork this repository
2. Checkout from master with to a feature branch with a name related to what is being contributed (e.g. "colored-qrcodes")
\**It's highly recommended that your contribution either creates a new **feature**, **fixes** something OR **refactors** the code and does not mix these (e.g. one PR fixing some existent feature and refactoring non-related code).*
3. Install dependencies and flask_qrcode on editable mode
```
pip install -e . # for installing flask_qrcode on editable mode
```
4. Do your magic
5. Provide new tests for your work and check that both this and the old ones
are passing
6. Pull Request!
## Testing:
1. Install dependencies and flask_qrcode on editable mode
```
pip install -e . # for installing flask_qrcode on editable mode
```
2. Run pytest
```
python setup.py test # on package's root dir
```
%prep
%autosetup -n Flask-QRcode-3.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-QRcode -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 3.1.0-1
- Package Spec generated