%global _empty_manifest_terminate_build 0
Name:		python-PyGeoj
Version:	1.0.0
Release:	1
Summary:	A simple Python GeoJSON file reader and writer.
License:	MIT
URL:		http://github.com/karimbahgat/PyGeoj
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f6/6c/c569e49b24beeef47dd15e02f583fb0ab0b3c95fffae71e8f5fe50a8297e/PyGeoj-1.0.0.tar.gz
BuildArch:	noarch


%description
PyGeoj is a simple Python GeoJSON file reader and writer intended for
end-users. It exposees dictionary structures as high level objects with
convenience methods, so the user does not have to get caught up in the
details of the format specification.

%package -n python3-PyGeoj
Summary:	A simple Python GeoJSON file reader and writer.
Provides:	python-PyGeoj
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-PyGeoj
PyGeoj is a simple Python GeoJSON file reader and writer intended for
end-users. It exposees dictionary structures as high level objects with
convenience methods, so the user does not have to get caught up in the
details of the format specification.

%package help
Summary:	Development documents and examples for PyGeoj
Provides:	python3-PyGeoj-doc
%description help
PyGeoj is a simple Python GeoJSON file reader and writer intended for
end-users. It exposees dictionary structures as high level objects with
convenience methods, so the user does not have to get caught up in the
details of the format specification.

%prep
%autosetup -n PyGeoj-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-PyGeoj -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated