%global _empty_manifest_terminate_build 0
Name:		python-pies
Version:	2.6.7
Release:	1
Summary:	The simplest way to write one program that runs on both Python 2 and Python 3.
License:	MIT
URL:		https://github.com/timothycrosley/pies
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/54/d2/aab9e975477e75e47608417e9610a9e47721a7c889e42be5cc363280087f/pies-2.6.7.tar.gz
BuildArch:	noarch


%description
|PyPI version| |PyPi downloads| |Build Status| |License| |Bitdeli Badge|
The simplest (and tastiest) way to write one program that runs on both
Python 2.6+ and Python 3.

%package -n python3-pies
Summary:	The simplest way to write one program that runs on both Python 2 and Python 3.
Provides:	python-pies
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pies
|PyPI version| |PyPi downloads| |Build Status| |License| |Bitdeli Badge|
The simplest (and tastiest) way to write one program that runs on both
Python 2.6+ and Python 3.

%package help
Summary:	Development documents and examples for pies
Provides:	python3-pies-doc
%description help
|PyPI version| |PyPi downloads| |Build Status| |License| |Bitdeli Badge|
The simplest (and tastiest) way to write one program that runs on both
Python 2.6+ and Python 3.

%prep
%autosetup -n pies-2.6.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pies -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.6.7-1
- Package Spec generated