%global _empty_manifest_terminate_build 0 Name: python-ciphey Version: 5.14.0 Release: 1 Summary: Automated Decryption Tool License: MIT URL: https://pypi.org/project/ciphey/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a5/db/9e0411803c768cd7f5c6986c9da406ae7e4b6b6a1d8ad0dc191cff6dbdaf/ciphey-5.14.0.tar.gz BuildArch: noarch Requires: python3-rich Requires: python3-pyyaml Requires: python3-loguru Requires: python3-pylint Requires: python3-flake8 Requires: python3-cipheydists Requires: python3-cipheycore Requires: python3-appdirs Requires: python3-typing_inspect Requires: python3-base58 Requires: python3-base91 Requires: python3-pybase62 Requires: python3-click Requires: python3-mock Requires: python3-pywhat %description

Translations
๐Ÿ‡ฉ๐Ÿ‡ช DE ๐Ÿ‡ซ๐Ÿ‡ท FR ๐Ÿ‡ญ๐Ÿ‡บ HU ๐Ÿ‡ฎ๐Ÿ‡ฉ ID ๐Ÿ‡ฎ๐Ÿ‡น IT ๐Ÿ‡ณ๐Ÿ‡ฑ NL ๐Ÿ‡ง๐Ÿ‡ท PT-BR ๐Ÿ‡ท๐Ÿ‡บ RU ๐Ÿ‡จ๐Ÿ‡ณ ZH

โžก๏ธ Documentation | Discord | Installation Guide โฌ…๏ธ
Ciphey

Discord Ciphey
Fully automated decryption/decoding/cracking tool using natural language processing & artificial intelligence, along with some common sense.


## [Installation Guide](https://github.com/Ciphey/Ciphey/wiki/Installation) |

๐Ÿ Python |

๐Ÿ‹ Docker (Universal) |

๐ŸŽ MacPorts (macOS)| | --------------------------------------------------------------------- | --------------------------------------------------------------------------------- | --------------------------------------------------------------------------------- | |

|

|

| | `python3 -m pip install ciphey --upgrade` | `docker run -it --rm remnux/ciphey` | `sudo port install ciphey` | | Linux | Mac OS | Windows | | ----------------------------------------------------------------------------------------------------------------------- | -------------------------------------------------------------------------------------------------------------------------- | ------------------------------------------------------------------------------------------------------------------------- | | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Linux) | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Mac%20OS) | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Windows) |
# ๐Ÿค” What is this? Input encrypted text, get the decrypted text back. > "What type of encryption?" That's the point. You don't know, you just know it's possibly encrypted. Ciphey will figure it out for you. Ciphey can solve most things in 3 seconds or less.

Ciphey demo

Ciphey aims to be a tool to automate a lot of decryptions & decodings such as multiple base encodings, classical ciphers, hashes or more advanced cryptography. If you don't know much about cryptography, or you want to quickly check the ciphertext before working on it yourself, Ciphey is for you. **The technical part.** Ciphey uses a custom built artificial intelligence module (_AuSearch_) with a _Cipher Detection Interface_ to approximate what something is encrypted with. And then a custom-built, customisable natural language processing _Language Checker Interface_, which can detect when the given text becomes plaintext. No neural networks or bloated AI here. We only use what is fast and minimal. And that's just the tip of the iceberg. For the full technical explanation, check out our [documentation](https://github.com/Ciphey/Ciphey/wiki). # โœจ Features - **50+ encryptions/encodings supported** such as binary, Morse code and Base64. Classical ciphers like the Caesar cipher, Affine cipher and the Vigenere cipher. Along with modern encryption like repeating-key XOR and more. **[For the full list, click here](https://github.com/Ciphey/Ciphey/wiki/Supported-Ciphers)** - **Custom Built Artificial Intelligence with Augmented Search (AuSearch) for answering the question "what encryption was used?"** Resulting in decryptions taking less than 3 seconds. - **Custom built natural language processing module** Ciphey can determine whether something is plaintext or not. Whether that plaintext is JSON, a CTF flag, or English, Ciphey can get it in a couple of milliseconds. - **Multi Language Support** at present, only German & English (with AU, UK, CAN, USA variants). - **Supports encryptions and hashes** Which the alternatives such as CyberChef Magic do not. - **[C++ core](https://github.com/Ciphey/CipheyCore)** Blazingly fast. # ๐Ÿ”ญ Ciphey vs CyberChef ## ๐Ÿ” Base64 Encoded 42 times
Name โšก Ciphey โšก ๐Ÿข CyberChef ๐Ÿข
Gif The guy she tells you not to worry about You
Time 2 seconds 6 seconds
Setup
  • Run ciphey on the file
  • Set the regex param to "{"
  • You need to know how many times to recurse
  • You need to know it's Base64 all the way down
  • You need to load CyberChef (it's a bloated JS app)
  • Know enough about CyberChef to create this pipeline
  • Invert the match
Note The gifs may load at different times, so one may appear significantly faster than another.
A note on magic CyberChef's most similar feature to Ciphey is Magic. Magic fails instantly on this input and crashes. The only way we could force CyberChef to compete was to manually define it. We also tested CyberChef and Ciphey with a **6gb file**. Ciphey cracked it in **5 minutes and 54 seconds**. CyberChef crashed before it even started. ## ๐Ÿ“Š Ciphey vs Katana vs CyberChef Magic | **Name** | โšก Ciphey โšก | ๐Ÿ—ก๏ธ Katana ๐Ÿ—ก๏ธ | ๐Ÿข CyberChef Magic ๐Ÿข | | ------------------------------------------ | ------------ | ------------ | --------------------- | | Advanced Language Checker | โœ… | โŒ | โœ… | | Supports Encryptions | โœ… | โœ… | โŒ | | Releases named after Dystopian themes ๐ŸŒƒ | โœ… | โŒ | โŒ | | Supports hashes | โœ… | โœ… | โŒ | | Easy to set up | โœ… | โŒ | โœ… | | Can guess what something is encrypted with | โœ… | โŒ | โŒ | | Created for hackers by hackers | โœ… | โœ… | โŒ | # ๐ŸŽฌ Getting Started If you're having trouble with installing Ciphey, [read this.](https://github.com/Ciphey/Ciphey/wiki/Common-Issues-&-Their-Solutions) ## โ€ผ๏ธ Important Links (Docs, Installation guide, Discord Support) | Installation Guide | Documentation | Discord | Docker Image (from REMnux) | | --------------------------------------------------------------------------- | --------------------------------------------------------- | ------------------------------------------- | --------------------------------------------------------------------------------------------------- | | ๐Ÿ“– [Installation Guide](https://github.com/Ciphey/Ciphey/wiki/Installation) | ๐Ÿ“š [Documentation](https://github.com/Ciphey/Ciphey/wiki) | ๐Ÿฆœ [Discord](https://discord.gg/zYTM3rZM4T) | ๐Ÿ‹ [Docker Documentation](https://docs.remnux.org/run-tools-in-containers/remnux-containers#ciphey) | ## ๐Ÿƒโ€โ™€๏ธRunning Ciphey There are 3 ways to run Ciphey. 1. File Input `ciphey -f encrypted.txt` 2. Unqualified input `ciphey -- "Encrypted input"` 3. Normal way `ciphey -t "Encrypted input"` ![Gif showing 3 ways to run Ciphey](https://github.com/Ciphey/Ciphey/raw/master/Pictures_for_README/3ways.gif) To get rid of the progress bars, probability table, and all the noise use the quiet mode. `ciphey -t "encrypted text here" -q` For a full list of arguments, run `ciphey --help`. ### โš—๏ธ Importing Ciphey You can import Ciphey\'s main and use it in your own programs and code. `from Ciphey.__main__ import main` # ๐ŸŽช Contributors Ciphey was invented by [Bee](https://github.com/bee-san) in 2008, and revived in 2019. Ciphey wouldn't be where it was today without [Cyclic3](https://github.com/Cyclic3) - president of UoL's Cyber Security Society. Ciphey was revived & recreated by the [Cyber Security Society](https://www.cybersoc.cf/) for use in CTFs. If you're ever in Liverpool, consider giving a talk or sponsoring our events. Email us at `cybersecurity@society.liverpoolguild.org` to find out more ๐Ÿค  **Major Credit** to George H for working out how we could use proper algorithms to speed up the search process. **Special thanks** to [varghalladesign](https://www.facebook.com/varghalladesign) for designing the logo. Check out their other design work! ## ๐Ÿ•โ€๐Ÿฆบ [Contributing](https://github.com/Ciphey/Ciphey/wiki/Contributing) Don't be afraid to contribute! We have many, many things you can do to help out. Each of them labelled and easily explained with examples. If you're trying to contribute but stuck, tag @bee-san โœจ Alternatively, join the Discord group and send a message there (link in [contrib file](https://github.com/Ciphey/Ciphey/wiki/Contributing)) or at the top of this README as a badge. Please read the [contributing file](https://github.com/Ciphey/Ciphey/wiki/Contributing) for exact details on how to contribute โœจ By doing so, you'll get your name added to the README below and get to be apart of an ever-growing project! [![Stargazers over time](https://starchart.cc/Ciphey/Ciphey.svg)](https://starchart.cc/Ciphey/Ciphey) ## ๐Ÿ’ฐ Financial Contributors The contributions will be used to fund not only the future of Ciphey and its authors, but also Cyber Security Society at the University of Liverpool. GitHub doesn't support "sponsor this project and we'll evenly distribute the money", so pick a link and we'll sort it out on our end ๐Ÿฅฐ ## โœจ Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

cyclic3

๐ŸŽจ ๐Ÿšง ๐Ÿ’ป ๐Ÿค”

Brandon

๐ŸŽจ ๐Ÿšง ๐Ÿ’ป ๐Ÿค”

michalani

๐Ÿ’ป

ashb07

๐Ÿ’ป

Shardion

๐Ÿ›

Bryan

๐ŸŒ ๐Ÿ“–

Lukas Gabriel

๐Ÿ’ป ๐Ÿ› ๐ŸŒ ๐Ÿค”

Darshan

๐Ÿ›

SkeletalDemise

๐Ÿ’ป

Christian Clauss

๐Ÿ’ป ๐Ÿ›

Machinexa2

๐Ÿ–‹

Anant Verma

๐Ÿ’ป ๐Ÿ›

XVXTOR

๐Ÿ“–

Itamikame

๐Ÿ’ป

MikeMerz

๐Ÿ’ป

Jacob Galam

๐Ÿ’ป ๐Ÿ›

TuxTheXplorer

๐ŸŒ

Itamai

๐Ÿ’ป ๐Ÿ›

Filipe

๐ŸŒ

Malathi

๐Ÿ’ป

Jack

๐ŸŒ

Younes

๐ŸŒ

Marnick Vandecauter

๐ŸŒ

Michael V

๐Ÿ’ป

chuinzer

๐ŸŒ

blackcat-917

๐ŸŒ ๐Ÿ“–

ร…smund Brekke

๐Ÿ’ป

Sashreek Shankar

๐Ÿ’ป

cryptobadger

๐Ÿ’ป ๐Ÿ›

elf

๐Ÿ’ป

Roger Yu

๐Ÿ’ป

dysleixa

๐Ÿ’ป

Mohammad Zulfikar

๐Ÿ“–
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package -n python3-ciphey Summary: Automated Decryption Tool Provides: python-ciphey BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-ciphey

Translations
๐Ÿ‡ฉ๐Ÿ‡ช DE ๐Ÿ‡ซ๐Ÿ‡ท FR ๐Ÿ‡ญ๐Ÿ‡บ HU ๐Ÿ‡ฎ๐Ÿ‡ฉ ID ๐Ÿ‡ฎ๐Ÿ‡น IT ๐Ÿ‡ณ๐Ÿ‡ฑ NL ๐Ÿ‡ง๐Ÿ‡ท PT-BR ๐Ÿ‡ท๐Ÿ‡บ RU ๐Ÿ‡จ๐Ÿ‡ณ ZH

โžก๏ธ Documentation | Discord | Installation Guide โฌ…๏ธ
Ciphey

Discord Ciphey
Fully automated decryption/decoding/cracking tool using natural language processing & artificial intelligence, along with some common sense.


## [Installation Guide](https://github.com/Ciphey/Ciphey/wiki/Installation) |

๐Ÿ Python |

๐Ÿ‹ Docker (Universal) |

๐ŸŽ MacPorts (macOS)| | --------------------------------------------------------------------- | --------------------------------------------------------------------------------- | --------------------------------------------------------------------------------- | |

|

|

| | `python3 -m pip install ciphey --upgrade` | `docker run -it --rm remnux/ciphey` | `sudo port install ciphey` | | Linux | Mac OS | Windows | | ----------------------------------------------------------------------------------------------------------------------- | -------------------------------------------------------------------------------------------------------------------------- | ------------------------------------------------------------------------------------------------------------------------- | | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Linux) | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Mac%20OS) | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Windows) |
# ๐Ÿค” What is this? Input encrypted text, get the decrypted text back. > "What type of encryption?" That's the point. You don't know, you just know it's possibly encrypted. Ciphey will figure it out for you. Ciphey can solve most things in 3 seconds or less.

Ciphey demo

Ciphey aims to be a tool to automate a lot of decryptions & decodings such as multiple base encodings, classical ciphers, hashes or more advanced cryptography. If you don't know much about cryptography, or you want to quickly check the ciphertext before working on it yourself, Ciphey is for you. **The technical part.** Ciphey uses a custom built artificial intelligence module (_AuSearch_) with a _Cipher Detection Interface_ to approximate what something is encrypted with. And then a custom-built, customisable natural language processing _Language Checker Interface_, which can detect when the given text becomes plaintext. No neural networks or bloated AI here. We only use what is fast and minimal. And that's just the tip of the iceberg. For the full technical explanation, check out our [documentation](https://github.com/Ciphey/Ciphey/wiki). # โœจ Features - **50+ encryptions/encodings supported** such as binary, Morse code and Base64. Classical ciphers like the Caesar cipher, Affine cipher and the Vigenere cipher. Along with modern encryption like repeating-key XOR and more. **[For the full list, click here](https://github.com/Ciphey/Ciphey/wiki/Supported-Ciphers)** - **Custom Built Artificial Intelligence with Augmented Search (AuSearch) for answering the question "what encryption was used?"** Resulting in decryptions taking less than 3 seconds. - **Custom built natural language processing module** Ciphey can determine whether something is plaintext or not. Whether that plaintext is JSON, a CTF flag, or English, Ciphey can get it in a couple of milliseconds. - **Multi Language Support** at present, only German & English (with AU, UK, CAN, USA variants). - **Supports encryptions and hashes** Which the alternatives such as CyberChef Magic do not. - **[C++ core](https://github.com/Ciphey/CipheyCore)** Blazingly fast. # ๐Ÿ”ญ Ciphey vs CyberChef ## ๐Ÿ” Base64 Encoded 42 times
Name โšก Ciphey โšก ๐Ÿข CyberChef ๐Ÿข
Gif The guy she tells you not to worry about You
Time 2 seconds 6 seconds
Setup
  • Run ciphey on the file
  • Set the regex param to "{"
  • You need to know how many times to recurse
  • You need to know it's Base64 all the way down
  • You need to load CyberChef (it's a bloated JS app)
  • Know enough about CyberChef to create this pipeline
  • Invert the match
Note The gifs may load at different times, so one may appear significantly faster than another.
A note on magic CyberChef's most similar feature to Ciphey is Magic. Magic fails instantly on this input and crashes. The only way we could force CyberChef to compete was to manually define it. We also tested CyberChef and Ciphey with a **6gb file**. Ciphey cracked it in **5 minutes and 54 seconds**. CyberChef crashed before it even started. ## ๐Ÿ“Š Ciphey vs Katana vs CyberChef Magic | **Name** | โšก Ciphey โšก | ๐Ÿ—ก๏ธ Katana ๐Ÿ—ก๏ธ | ๐Ÿข CyberChef Magic ๐Ÿข | | ------------------------------------------ | ------------ | ------------ | --------------------- | | Advanced Language Checker | โœ… | โŒ | โœ… | | Supports Encryptions | โœ… | โœ… | โŒ | | Releases named after Dystopian themes ๐ŸŒƒ | โœ… | โŒ | โŒ | | Supports hashes | โœ… | โœ… | โŒ | | Easy to set up | โœ… | โŒ | โœ… | | Can guess what something is encrypted with | โœ… | โŒ | โŒ | | Created for hackers by hackers | โœ… | โœ… | โŒ | # ๐ŸŽฌ Getting Started If you're having trouble with installing Ciphey, [read this.](https://github.com/Ciphey/Ciphey/wiki/Common-Issues-&-Their-Solutions) ## โ€ผ๏ธ Important Links (Docs, Installation guide, Discord Support) | Installation Guide | Documentation | Discord | Docker Image (from REMnux) | | --------------------------------------------------------------------------- | --------------------------------------------------------- | ------------------------------------------- | --------------------------------------------------------------------------------------------------- | | ๐Ÿ“– [Installation Guide](https://github.com/Ciphey/Ciphey/wiki/Installation) | ๐Ÿ“š [Documentation](https://github.com/Ciphey/Ciphey/wiki) | ๐Ÿฆœ [Discord](https://discord.gg/zYTM3rZM4T) | ๐Ÿ‹ [Docker Documentation](https://docs.remnux.org/run-tools-in-containers/remnux-containers#ciphey) | ## ๐Ÿƒโ€โ™€๏ธRunning Ciphey There are 3 ways to run Ciphey. 1. File Input `ciphey -f encrypted.txt` 2. Unqualified input `ciphey -- "Encrypted input"` 3. Normal way `ciphey -t "Encrypted input"` ![Gif showing 3 ways to run Ciphey](https://github.com/Ciphey/Ciphey/raw/master/Pictures_for_README/3ways.gif) To get rid of the progress bars, probability table, and all the noise use the quiet mode. `ciphey -t "encrypted text here" -q` For a full list of arguments, run `ciphey --help`. ### โš—๏ธ Importing Ciphey You can import Ciphey\'s main and use it in your own programs and code. `from Ciphey.__main__ import main` # ๐ŸŽช Contributors Ciphey was invented by [Bee](https://github.com/bee-san) in 2008, and revived in 2019. Ciphey wouldn't be where it was today without [Cyclic3](https://github.com/Cyclic3) - president of UoL's Cyber Security Society. Ciphey was revived & recreated by the [Cyber Security Society](https://www.cybersoc.cf/) for use in CTFs. If you're ever in Liverpool, consider giving a talk or sponsoring our events. Email us at `cybersecurity@society.liverpoolguild.org` to find out more ๐Ÿค  **Major Credit** to George H for working out how we could use proper algorithms to speed up the search process. **Special thanks** to [varghalladesign](https://www.facebook.com/varghalladesign) for designing the logo. Check out their other design work! ## ๐Ÿ•โ€๐Ÿฆบ [Contributing](https://github.com/Ciphey/Ciphey/wiki/Contributing) Don't be afraid to contribute! We have many, many things you can do to help out. Each of them labelled and easily explained with examples. If you're trying to contribute but stuck, tag @bee-san โœจ Alternatively, join the Discord group and send a message there (link in [contrib file](https://github.com/Ciphey/Ciphey/wiki/Contributing)) or at the top of this README as a badge. Please read the [contributing file](https://github.com/Ciphey/Ciphey/wiki/Contributing) for exact details on how to contribute โœจ By doing so, you'll get your name added to the README below and get to be apart of an ever-growing project! [![Stargazers over time](https://starchart.cc/Ciphey/Ciphey.svg)](https://starchart.cc/Ciphey/Ciphey) ## ๐Ÿ’ฐ Financial Contributors The contributions will be used to fund not only the future of Ciphey and its authors, but also Cyber Security Society at the University of Liverpool. GitHub doesn't support "sponsor this project and we'll evenly distribute the money", so pick a link and we'll sort it out on our end ๐Ÿฅฐ ## โœจ Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

cyclic3

๐ŸŽจ ๐Ÿšง ๐Ÿ’ป ๐Ÿค”

Brandon

๐ŸŽจ ๐Ÿšง ๐Ÿ’ป ๐Ÿค”

michalani

๐Ÿ’ป

ashb07

๐Ÿ’ป

Shardion

๐Ÿ›

Bryan

๐ŸŒ ๐Ÿ“–

Lukas Gabriel

๐Ÿ’ป ๐Ÿ› ๐ŸŒ ๐Ÿค”

Darshan

๐Ÿ›

SkeletalDemise

๐Ÿ’ป

Christian Clauss

๐Ÿ’ป ๐Ÿ›

Machinexa2

๐Ÿ–‹

Anant Verma

๐Ÿ’ป ๐Ÿ›

XVXTOR

๐Ÿ“–

Itamikame

๐Ÿ’ป

MikeMerz

๐Ÿ’ป

Jacob Galam

๐Ÿ’ป ๐Ÿ›

TuxTheXplorer

๐ŸŒ

Itamai

๐Ÿ’ป ๐Ÿ›

Filipe

๐ŸŒ

Malathi

๐Ÿ’ป

Jack

๐ŸŒ

Younes

๐ŸŒ

Marnick Vandecauter

๐ŸŒ

Michael V

๐Ÿ’ป

chuinzer

๐ŸŒ

blackcat-917

๐ŸŒ ๐Ÿ“–

ร…smund Brekke

๐Ÿ’ป

Sashreek Shankar

๐Ÿ’ป

cryptobadger

๐Ÿ’ป ๐Ÿ›

elf

๐Ÿ’ป

Roger Yu

๐Ÿ’ป

dysleixa

๐Ÿ’ป

Mohammad Zulfikar

๐Ÿ“–
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package help Summary: Development documents and examples for ciphey Provides: python3-ciphey-doc %description help

Translations
๐Ÿ‡ฉ๐Ÿ‡ช DE ๐Ÿ‡ซ๐Ÿ‡ท FR ๐Ÿ‡ญ๐Ÿ‡บ HU ๐Ÿ‡ฎ๐Ÿ‡ฉ ID ๐Ÿ‡ฎ๐Ÿ‡น IT ๐Ÿ‡ณ๐Ÿ‡ฑ NL ๐Ÿ‡ง๐Ÿ‡ท PT-BR ๐Ÿ‡ท๐Ÿ‡บ RU ๐Ÿ‡จ๐Ÿ‡ณ ZH

โžก๏ธ Documentation | Discord | Installation Guide โฌ…๏ธ
Ciphey

Discord Ciphey
Fully automated decryption/decoding/cracking tool using natural language processing & artificial intelligence, along with some common sense.


## [Installation Guide](https://github.com/Ciphey/Ciphey/wiki/Installation) |

๐Ÿ Python |

๐Ÿ‹ Docker (Universal) |

๐ŸŽ MacPorts (macOS)| | --------------------------------------------------------------------- | --------------------------------------------------------------------------------- | --------------------------------------------------------------------------------- | |

|

|

| | `python3 -m pip install ciphey --upgrade` | `docker run -it --rm remnux/ciphey` | `sudo port install ciphey` | | Linux | Mac OS | Windows | | ----------------------------------------------------------------------------------------------------------------------- | -------------------------------------------------------------------------------------------------------------------------- | ------------------------------------------------------------------------------------------------------------------------- | | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Linux) | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Mac%20OS) | ![GitHub Workflow Status](https://img.shields.io/github/workflow/status/ciphey/ciphey/Python%20application?label=Windows) |
# ๐Ÿค” What is this? Input encrypted text, get the decrypted text back. > "What type of encryption?" That's the point. You don't know, you just know it's possibly encrypted. Ciphey will figure it out for you. Ciphey can solve most things in 3 seconds or less.

Ciphey demo

Ciphey aims to be a tool to automate a lot of decryptions & decodings such as multiple base encodings, classical ciphers, hashes or more advanced cryptography. If you don't know much about cryptography, or you want to quickly check the ciphertext before working on it yourself, Ciphey is for you. **The technical part.** Ciphey uses a custom built artificial intelligence module (_AuSearch_) with a _Cipher Detection Interface_ to approximate what something is encrypted with. And then a custom-built, customisable natural language processing _Language Checker Interface_, which can detect when the given text becomes plaintext. No neural networks or bloated AI here. We only use what is fast and minimal. And that's just the tip of the iceberg. For the full technical explanation, check out our [documentation](https://github.com/Ciphey/Ciphey/wiki). # โœจ Features - **50+ encryptions/encodings supported** such as binary, Morse code and Base64. Classical ciphers like the Caesar cipher, Affine cipher and the Vigenere cipher. Along with modern encryption like repeating-key XOR and more. **[For the full list, click here](https://github.com/Ciphey/Ciphey/wiki/Supported-Ciphers)** - **Custom Built Artificial Intelligence with Augmented Search (AuSearch) for answering the question "what encryption was used?"** Resulting in decryptions taking less than 3 seconds. - **Custom built natural language processing module** Ciphey can determine whether something is plaintext or not. Whether that plaintext is JSON, a CTF flag, or English, Ciphey can get it in a couple of milliseconds. - **Multi Language Support** at present, only German & English (with AU, UK, CAN, USA variants). - **Supports encryptions and hashes** Which the alternatives such as CyberChef Magic do not. - **[C++ core](https://github.com/Ciphey/CipheyCore)** Blazingly fast. # ๐Ÿ”ญ Ciphey vs CyberChef ## ๐Ÿ” Base64 Encoded 42 times
Name โšก Ciphey โšก ๐Ÿข CyberChef ๐Ÿข
Gif The guy she tells you not to worry about You
Time 2 seconds 6 seconds
Setup
  • Run ciphey on the file
  • Set the regex param to "{"
  • You need to know how many times to recurse
  • You need to know it's Base64 all the way down
  • You need to load CyberChef (it's a bloated JS app)
  • Know enough about CyberChef to create this pipeline
  • Invert the match
Note The gifs may load at different times, so one may appear significantly faster than another.
A note on magic CyberChef's most similar feature to Ciphey is Magic. Magic fails instantly on this input and crashes. The only way we could force CyberChef to compete was to manually define it. We also tested CyberChef and Ciphey with a **6gb file**. Ciphey cracked it in **5 minutes and 54 seconds**. CyberChef crashed before it even started. ## ๐Ÿ“Š Ciphey vs Katana vs CyberChef Magic | **Name** | โšก Ciphey โšก | ๐Ÿ—ก๏ธ Katana ๐Ÿ—ก๏ธ | ๐Ÿข CyberChef Magic ๐Ÿข | | ------------------------------------------ | ------------ | ------------ | --------------------- | | Advanced Language Checker | โœ… | โŒ | โœ… | | Supports Encryptions | โœ… | โœ… | โŒ | | Releases named after Dystopian themes ๐ŸŒƒ | โœ… | โŒ | โŒ | | Supports hashes | โœ… | โœ… | โŒ | | Easy to set up | โœ… | โŒ | โœ… | | Can guess what something is encrypted with | โœ… | โŒ | โŒ | | Created for hackers by hackers | โœ… | โœ… | โŒ | # ๐ŸŽฌ Getting Started If you're having trouble with installing Ciphey, [read this.](https://github.com/Ciphey/Ciphey/wiki/Common-Issues-&-Their-Solutions) ## โ€ผ๏ธ Important Links (Docs, Installation guide, Discord Support) | Installation Guide | Documentation | Discord | Docker Image (from REMnux) | | --------------------------------------------------------------------------- | --------------------------------------------------------- | ------------------------------------------- | --------------------------------------------------------------------------------------------------- | | ๐Ÿ“– [Installation Guide](https://github.com/Ciphey/Ciphey/wiki/Installation) | ๐Ÿ“š [Documentation](https://github.com/Ciphey/Ciphey/wiki) | ๐Ÿฆœ [Discord](https://discord.gg/zYTM3rZM4T) | ๐Ÿ‹ [Docker Documentation](https://docs.remnux.org/run-tools-in-containers/remnux-containers#ciphey) | ## ๐Ÿƒโ€โ™€๏ธRunning Ciphey There are 3 ways to run Ciphey. 1. File Input `ciphey -f encrypted.txt` 2. Unqualified input `ciphey -- "Encrypted input"` 3. Normal way `ciphey -t "Encrypted input"` ![Gif showing 3 ways to run Ciphey](https://github.com/Ciphey/Ciphey/raw/master/Pictures_for_README/3ways.gif) To get rid of the progress bars, probability table, and all the noise use the quiet mode. `ciphey -t "encrypted text here" -q` For a full list of arguments, run `ciphey --help`. ### โš—๏ธ Importing Ciphey You can import Ciphey\'s main and use it in your own programs and code. `from Ciphey.__main__ import main` # ๐ŸŽช Contributors Ciphey was invented by [Bee](https://github.com/bee-san) in 2008, and revived in 2019. Ciphey wouldn't be where it was today without [Cyclic3](https://github.com/Cyclic3) - president of UoL's Cyber Security Society. Ciphey was revived & recreated by the [Cyber Security Society](https://www.cybersoc.cf/) for use in CTFs. If you're ever in Liverpool, consider giving a talk or sponsoring our events. Email us at `cybersecurity@society.liverpoolguild.org` to find out more ๐Ÿค  **Major Credit** to George H for working out how we could use proper algorithms to speed up the search process. **Special thanks** to [varghalladesign](https://www.facebook.com/varghalladesign) for designing the logo. Check out their other design work! ## ๐Ÿ•โ€๐Ÿฆบ [Contributing](https://github.com/Ciphey/Ciphey/wiki/Contributing) Don't be afraid to contribute! We have many, many things you can do to help out. Each of them labelled and easily explained with examples. If you're trying to contribute but stuck, tag @bee-san โœจ Alternatively, join the Discord group and send a message there (link in [contrib file](https://github.com/Ciphey/Ciphey/wiki/Contributing)) or at the top of this README as a badge. Please read the [contributing file](https://github.com/Ciphey/Ciphey/wiki/Contributing) for exact details on how to contribute โœจ By doing so, you'll get your name added to the README below and get to be apart of an ever-growing project! [![Stargazers over time](https://starchart.cc/Ciphey/Ciphey.svg)](https://starchart.cc/Ciphey/Ciphey) ## ๐Ÿ’ฐ Financial Contributors The contributions will be used to fund not only the future of Ciphey and its authors, but also Cyber Security Society at the University of Liverpool. GitHub doesn't support "sponsor this project and we'll evenly distribute the money", so pick a link and we'll sort it out on our end ๐Ÿฅฐ ## โœจ Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

cyclic3

๐ŸŽจ ๐Ÿšง ๐Ÿ’ป ๐Ÿค”

Brandon

๐ŸŽจ ๐Ÿšง ๐Ÿ’ป ๐Ÿค”

michalani

๐Ÿ’ป

ashb07

๐Ÿ’ป

Shardion

๐Ÿ›

Bryan

๐ŸŒ ๐Ÿ“–

Lukas Gabriel

๐Ÿ’ป ๐Ÿ› ๐ŸŒ ๐Ÿค”

Darshan

๐Ÿ›

SkeletalDemise

๐Ÿ’ป

Christian Clauss

๐Ÿ’ป ๐Ÿ›

Machinexa2

๐Ÿ–‹

Anant Verma

๐Ÿ’ป ๐Ÿ›

XVXTOR

๐Ÿ“–

Itamikame

๐Ÿ’ป

MikeMerz

๐Ÿ’ป

Jacob Galam

๐Ÿ’ป ๐Ÿ›

TuxTheXplorer

๐ŸŒ

Itamai

๐Ÿ’ป ๐Ÿ›

Filipe

๐ŸŒ

Malathi

๐Ÿ’ป

Jack

๐ŸŒ

Younes

๐ŸŒ

Marnick Vandecauter

๐ŸŒ

Michael V

๐Ÿ’ป

chuinzer

๐ŸŒ

blackcat-917

๐ŸŒ ๐Ÿ“–

ร…smund Brekke

๐Ÿ’ป

Sashreek Shankar

๐Ÿ’ป

cryptobadger

๐Ÿ’ป ๐Ÿ›

elf

๐Ÿ’ป

Roger Yu

๐Ÿ’ป

dysleixa

๐Ÿ’ป

Mohammad Zulfikar

๐Ÿ“–
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %prep %autosetup -n ciphey-5.14.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-ciphey -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Apr 11 2023 Python_Bot - 5.14.0-1 - Package Spec generated