%global _empty_manifest_terminate_build 0
Name: python-rtpy
Version: 1.4.9
Release: 1
Summary: Python wrapper for the JFrog Artifactory REST API.
License: Apache-2.0
URL: https://github.com/Orange-OpenSource/rtpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/77/f5/2fa8d044cea1026f2020c78262b129d133b439ea170793c8fd1ca535a472/rtpy-1.4.9.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
# rtpy
[![image](https://img.shields.io/pypi/v/rtpy.svg)](https://pypi.org/project/rtpy/)
[![image](https://img.shields.io/pypi/pyversions/rtpy.svg)](https://pypi.org/project/rtpy/)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)
[![Documentation Status](https://readthedocs.org/projects/rtpy/badge/?version=latest)](https://rtpy.readthedocs.io/en/latest/?badge=latest)
[![image](https://img.shields.io/pypi/l/rtpy.svg)](https://pypi.org/project/rtpy/)
Python wrapper for the **[JFrog Artifactory REST API](https://www.jfrog.com/confluence/display/RTF/Artifactory+REST+API)**
## Documentation
**[https://rtpy.rtfd.io](https://rtpy.rtfd.io)**
## Installation
```shell
$ pip install rtpy
```
## Usage
```python
import rtpy
# instantiate a rtpy.Rtpy object
settings = {}
settings["af_url"] = "http://..."
settings["api_key"] = "123QWA..."
# settings["username"] = "my_username"
# settings["password"] = "my_password"
af = rtpy.Rtpy(settings)
# use a method
r = af.system_and_configuration.system_health_ping()
print(r)
# OK
```
## Running the tests
### Requirements :
- Dependencies : see [tool.poetry.dependencies] and [tool.poetry.dev-dependencies] in [pyproject.toml](./pyproject.toml)
- Artifactory instance (with a valid license) running
**NEVER run the tests on a production instance!**
### Launch
- Set the following environment variables:
- AF_TEST_URL
- AF_TEST_USERNAME
- AF_TEST_PASSWORD
The user must have admin privileges (it's API key will be revoked during the tests)
- Clone the repository and launch the tests using the command :
```shell
$ python -m pytest -v
```
%package -n python3-rtpy
Summary: Python wrapper for the JFrog Artifactory REST API.
Provides: python-rtpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-rtpy
# rtpy
[![image](https://img.shields.io/pypi/v/rtpy.svg)](https://pypi.org/project/rtpy/)
[![image](https://img.shields.io/pypi/pyversions/rtpy.svg)](https://pypi.org/project/rtpy/)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)
[![Documentation Status](https://readthedocs.org/projects/rtpy/badge/?version=latest)](https://rtpy.readthedocs.io/en/latest/?badge=latest)
[![image](https://img.shields.io/pypi/l/rtpy.svg)](https://pypi.org/project/rtpy/)
Python wrapper for the **[JFrog Artifactory REST API](https://www.jfrog.com/confluence/display/RTF/Artifactory+REST+API)**
## Documentation
**[https://rtpy.rtfd.io](https://rtpy.rtfd.io)**
## Installation
```shell
$ pip install rtpy
```
## Usage
```python
import rtpy
# instantiate a rtpy.Rtpy object
settings = {}
settings["af_url"] = "http://..."
settings["api_key"] = "123QWA..."
# settings["username"] = "my_username"
# settings["password"] = "my_password"
af = rtpy.Rtpy(settings)
# use a method
r = af.system_and_configuration.system_health_ping()
print(r)
# OK
```
## Running the tests
### Requirements :
- Dependencies : see [tool.poetry.dependencies] and [tool.poetry.dev-dependencies] in [pyproject.toml](./pyproject.toml)
- Artifactory instance (with a valid license) running
**NEVER run the tests on a production instance!**
### Launch
- Set the following environment variables:
- AF_TEST_URL
- AF_TEST_USERNAME
- AF_TEST_PASSWORD
The user must have admin privileges (it's API key will be revoked during the tests)
- Clone the repository and launch the tests using the command :
```shell
$ python -m pytest -v
```
%package help
Summary: Development documents and examples for rtpy
Provides: python3-rtpy-doc
%description help
# rtpy
[![image](https://img.shields.io/pypi/v/rtpy.svg)](https://pypi.org/project/rtpy/)
[![image](https://img.shields.io/pypi/pyversions/rtpy.svg)](https://pypi.org/project/rtpy/)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)
[![Documentation Status](https://readthedocs.org/projects/rtpy/badge/?version=latest)](https://rtpy.readthedocs.io/en/latest/?badge=latest)
[![image](https://img.shields.io/pypi/l/rtpy.svg)](https://pypi.org/project/rtpy/)
Python wrapper for the **[JFrog Artifactory REST API](https://www.jfrog.com/confluence/display/RTF/Artifactory+REST+API)**
## Documentation
**[https://rtpy.rtfd.io](https://rtpy.rtfd.io)**
## Installation
```shell
$ pip install rtpy
```
## Usage
```python
import rtpy
# instantiate a rtpy.Rtpy object
settings = {}
settings["af_url"] = "http://..."
settings["api_key"] = "123QWA..."
# settings["username"] = "my_username"
# settings["password"] = "my_password"
af = rtpy.Rtpy(settings)
# use a method
r = af.system_and_configuration.system_health_ping()
print(r)
# OK
```
## Running the tests
### Requirements :
- Dependencies : see [tool.poetry.dependencies] and [tool.poetry.dev-dependencies] in [pyproject.toml](./pyproject.toml)
- Artifactory instance (with a valid license) running
**NEVER run the tests on a production instance!**
### Launch
- Set the following environment variables:
- AF_TEST_URL
- AF_TEST_USERNAME
- AF_TEST_PASSWORD
The user must have admin privileges (it's API key will be revoked during the tests)
- Clone the repository and launch the tests using the command :
```shell
$ python -m pytest -v
```
%prep
%autosetup -n rtpy-1.4.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-rtpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.4.9-1
- Package Spec generated