%global _empty_manifest_terminate_build 0
Name: python-Cuckoo
Version: 2.0.7
Release: 1
Summary: Automated Malware Analysis System
License: GPLv3
URL: https://cuckoosandbox.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/11/9c/85cd4af08962a4f4ff3ab00a2f453d343f5ff8ede9366978f4457e72d28a/Cuckoo-2.0.7.tar.gz
BuildArch: noarch
%description
.. image:: https://cuckoosandbox.org/assets/images/cuckoo-black.png
:alt: Cuckoo Sandbox
:target: https://cuckoosandbox.org/
`Cuckoo Sandbox `_ is the leading open source
automated malware analysis system.
What does that mean? It simply means that you can throw any suspicious file at
it and in a matter of seconds Cuckoo will provide you back some detailed
results outlining what such file did when executed inside an isolated
environment.
If you want to contribute to development, report a bug, make a feature request
or ask a question, please first take a look at our `community guidelines`_.
For development, please also take a look at the `contribution requirements`_.
Make sure you check our existing Issues and Pull Requests and that you join
our `IRC or Slack channel `_.
For setup instructions, please refer
`to `_
`our `_
`documentation `_.
This is a development version, we do not recommend its use in production; the
latest stable version may be installed through :code:`pip install -U cuckoo`.
You can find the full documentation of the latest stable release
`here `_.
.. image:: https://travis-ci.org/cuckoosandbox/cuckoo.png?branch=master
:alt: Linux Build Status
:target: https://travis-ci.org/cuckoosandbox/cuckoo
.. image:: https://ci.appveyor.com/api/projects/status/p892esebjdbhq653/branch/master?svg=true
:alt: Windows Build Status
:target: https://ci.appveyor.com/project/jbremer/cuckoo/branch/master
.. image:: https://coveralls.io/repos/github/cuckoosandbox/cuckoo/badge.svg?branch=master
:alt: Coverage Coverage Status
:target: https://coveralls.io/github/cuckoosandbox/cuckoo?branch=master
.. image:: https://codecov.io/gh/cuckoosandbox/cuckoo/branch/master/graph/badge.svg
:alt: Codecov Coverage Status
:target: https://codecov.io/gh/cuckoosandbox/cuckoo
.. _`community guidelines`: https://cuckoo.sh/docs/introduction/community.html
.. _`contribution requirements`: http://www.cuckoofoundation.org/contribute.html
%package -n python3-Cuckoo
Summary: Automated Malware Analysis System
Provides: python-Cuckoo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Cuckoo
.. image:: https://cuckoosandbox.org/assets/images/cuckoo-black.png
:alt: Cuckoo Sandbox
:target: https://cuckoosandbox.org/
`Cuckoo Sandbox `_ is the leading open source
automated malware analysis system.
What does that mean? It simply means that you can throw any suspicious file at
it and in a matter of seconds Cuckoo will provide you back some detailed
results outlining what such file did when executed inside an isolated
environment.
If you want to contribute to development, report a bug, make a feature request
or ask a question, please first take a look at our `community guidelines`_.
For development, please also take a look at the `contribution requirements`_.
Make sure you check our existing Issues and Pull Requests and that you join
our `IRC or Slack channel `_.
For setup instructions, please refer
`to `_
`our `_
`documentation `_.
This is a development version, we do not recommend its use in production; the
latest stable version may be installed through :code:`pip install -U cuckoo`.
You can find the full documentation of the latest stable release
`here `_.
.. image:: https://travis-ci.org/cuckoosandbox/cuckoo.png?branch=master
:alt: Linux Build Status
:target: https://travis-ci.org/cuckoosandbox/cuckoo
.. image:: https://ci.appveyor.com/api/projects/status/p892esebjdbhq653/branch/master?svg=true
:alt: Windows Build Status
:target: https://ci.appveyor.com/project/jbremer/cuckoo/branch/master
.. image:: https://coveralls.io/repos/github/cuckoosandbox/cuckoo/badge.svg?branch=master
:alt: Coverage Coverage Status
:target: https://coveralls.io/github/cuckoosandbox/cuckoo?branch=master
.. image:: https://codecov.io/gh/cuckoosandbox/cuckoo/branch/master/graph/badge.svg
:alt: Codecov Coverage Status
:target: https://codecov.io/gh/cuckoosandbox/cuckoo
.. _`community guidelines`: https://cuckoo.sh/docs/introduction/community.html
.. _`contribution requirements`: http://www.cuckoofoundation.org/contribute.html
%package help
Summary: Development documents and examples for Cuckoo
Provides: python3-Cuckoo-doc
%description help
.. image:: https://cuckoosandbox.org/assets/images/cuckoo-black.png
:alt: Cuckoo Sandbox
:target: https://cuckoosandbox.org/
`Cuckoo Sandbox `_ is the leading open source
automated malware analysis system.
What does that mean? It simply means that you can throw any suspicious file at
it and in a matter of seconds Cuckoo will provide you back some detailed
results outlining what such file did when executed inside an isolated
environment.
If you want to contribute to development, report a bug, make a feature request
or ask a question, please first take a look at our `community guidelines`_.
For development, please also take a look at the `contribution requirements`_.
Make sure you check our existing Issues and Pull Requests and that you join
our `IRC or Slack channel `_.
For setup instructions, please refer
`to `_
`our `_
`documentation `_.
This is a development version, we do not recommend its use in production; the
latest stable version may be installed through :code:`pip install -U cuckoo`.
You can find the full documentation of the latest stable release
`here `_.
.. image:: https://travis-ci.org/cuckoosandbox/cuckoo.png?branch=master
:alt: Linux Build Status
:target: https://travis-ci.org/cuckoosandbox/cuckoo
.. image:: https://ci.appveyor.com/api/projects/status/p892esebjdbhq653/branch/master?svg=true
:alt: Windows Build Status
:target: https://ci.appveyor.com/project/jbremer/cuckoo/branch/master
.. image:: https://coveralls.io/repos/github/cuckoosandbox/cuckoo/badge.svg?branch=master
:alt: Coverage Coverage Status
:target: https://coveralls.io/github/cuckoosandbox/cuckoo?branch=master
.. image:: https://codecov.io/gh/cuckoosandbox/cuckoo/branch/master/graph/badge.svg
:alt: Codecov Coverage Status
:target: https://codecov.io/gh/cuckoosandbox/cuckoo
.. _`community guidelines`: https://cuckoo.sh/docs/introduction/community.html
.. _`contribution requirements`: http://www.cuckoofoundation.org/contribute.html
%prep
%autosetup -n Cuckoo-2.0.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Cuckoo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 2.0.7-1
- Package Spec generated