%global _empty_manifest_terminate_build 0
Name: python-sender
Version: 0.3
Release: 1
Summary: Python SMTP Client for Humans
License: BSD
URL: https://github.com/fengsp/sender
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/71/ce/913050fc53b82860551d7074fa26d05c9d4438a08586ec22c86651055bbf/sender-0.3.tar.gz
BuildArch: noarch
%description
Sender is easy
``````````````
from sender import Mail
mail = Mail()
mail.send_message("Hello", fromaddr="from@example.com",
to="to@example.com", body="Hello world!")
Install
```````
$ pip install sender
Links
`````
* `documentation `_
* `github `_
* `development version
`_
%package -n python3-sender
Summary: Python SMTP Client for Humans
Provides: python-sender
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sender
Sender is easy
``````````````
from sender import Mail
mail = Mail()
mail.send_message("Hello", fromaddr="from@example.com",
to="to@example.com", body="Hello world!")
Install
```````
$ pip install sender
Links
`````
* `documentation `_
* `github `_
* `development version
`_
%package help
Summary: Development documents and examples for sender
Provides: python3-sender-doc
%description help
Sender is easy
``````````````
from sender import Mail
mail = Mail()
mail.send_message("Hello", fromaddr="from@example.com",
to="to@example.com", body="Hello world!")
Install
```````
$ pip install sender
Links
`````
* `documentation `_
* `github `_
* `development version
`_
%prep
%autosetup -n sender-0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sender -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.3-1
- Package Spec generated