%global _empty_manifest_terminate_build 0
Name:		python-Flask-CLI
Version:	0.4.0
Release:	1
Summary:	Backport of Flask 1.0 new click integration.
License:	BSD
URL:		http://github.com/inveniosoftware/flask-cli/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/96/aa/12256c6efd795e4d14a3b22a021ec337b403680ec57127a546c4b72daeb0/Flask-CLI-0.4.0.tar.gz
BuildArch:	noarch

Requires:	python3-Flask
Requires:	python3-click
Requires:	python3-Sphinx
Requires:	python3-check-manifest
Requires:	python3-coverage
Requires:	python3-isort
Requires:	python3-pydocstyle
Requires:	python3-pytest-cache
Requires:	python3-pytest-cov
Requires:	python3-pytest-pep8
Requires:	python3-pytest
Requires:	python3-Sphinx
Requires:	python3-check-manifest
Requires:	python3-coverage
Requires:	python3-isort
Requires:	python3-pydocstyle
Requires:	python3-pytest-cache
Requires:	python3-pytest-cov
Requires:	python3-pytest-pep8
Requires:	python3-pytest
Requires:	python3-Sphinx
Requires:	python3-check-manifest
Requires:	python3-coverage
Requires:	python3-isort
Requires:	python3-pydocstyle
Requires:	python3-pytest-cache
Requires:	python3-pytest-cov
Requires:	python3-pytest-pep8
Requires:	python3-pytest

%description


%package -n python3-Flask-CLI
Summary:	Backport of Flask 1.0 new click integration.
Provides:	python-Flask-CLI
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Flask-CLI


%package help
Summary:	Development documents and examples for Flask-CLI
Provides:	python3-Flask-CLI-doc
%description help


%prep
%autosetup -n Flask-CLI-0.4.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Flask-CLI -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0-1
- Package Spec generated