%global _empty_manifest_terminate_build 0
Name: python-PennyLane
Version: 0.29.1
Release: 1
Summary: PennyLane is a Python quantum machine learning library by Xanadu Inc.
License: Apache License 2.0
URL: https://github.com/XanaduAI/pennylane
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0e/e8/6d3c7fa27743c198073db9a62ed57ed9b3a767cda49b220c6b08405f6f27/PennyLane-0.29.1.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-networkx
Requires: python3-retworkx
Requires: python3-autograd
Requires: python3-toml
Requires: python3-appdirs
Requires: python3-semantic-version
Requires: python3-autoray
Requires: python3-cachetools
Requires: python3-pennylane-lightning
Requires: python3-requests
Requires: python3-cvxpy
Requires: python3-cvxopt
%description
PennyLane is a cross-platform Python library for differentiable
programming of quantum computers.
Train a quantum computer the same way as a neural network.
## Key Features
- *Machine learning on quantum hardware*. Connect to quantum hardware using **PyTorch**, **TensorFlow**, **JAX**, **Keras**, or **NumPy**. Build rich and flexible hybrid quantum-classical models.
- *Device-independent*. Run the same quantum circuit on different quantum backends. Install
[plugins](https://pennylane.ai/plugins.html) to access even more devices, including **Strawberry
Fields**, **Amazon Braket**, **IBM Q**, **Google Cirq**, **Rigetti Forest**, **Qulacs**, **Pasqal**, **Honeywell**, and more.
- *Follow the gradient*. Hardware-friendly **automatic differentiation** of quantum circuits.
- *Batteries included*. Built-in tools for **quantum machine learning**, **optimization**, and
**quantum chemistry**. Rapidly prototype using built-in quantum simulators with
backpropagation support.
## Installation
PennyLane requires Python version 3.8 and above. Installation of PennyLane, as well as all
dependencies, can be done using pip:
```console
python -m pip install pennylane
```
## Docker support
**Docker** support exists for building using **CPU** and **GPU** (Nvidia CUDA
11.1+) images. [See a more detailed description
here](https://pennylane.readthedocs.io/en/stable/development/guide/installation.html#docker).
## Getting started
For an introduction to quantum machine learning, guides and resources are available on
PennyLane's [quantum machine learning hub](https://pennylane.ai/qml/):
* [What is quantum machine learning?](https://pennylane.ai/qml/whatisqml.html)
* [QML tutorials and demos](https://pennylane.ai/qml/demonstrations.html)
* [Frequently asked questions](https://pennylane.ai/faq.html)
* [Key concepts of QML](https://pennylane.ai/qml/glossary.html)
* [QML videos](https://pennylane.ai/qml/videos.html)
You can also check out our [documentation](https://pennylane.readthedocs.io) for [quickstart
guides](https://pennylane.readthedocs.io/en/stable/introduction/pennylane.html) to using PennyLane,
and detailed developer guides on [how to write your
own](https://pennylane.readthedocs.io/en/stable/development/plugins.html) PennyLane-compatible
quantum device.
## Tutorials and demonstrations
Take a deeper dive into quantum machine learning by exploring cutting-edge algorithms on our [demonstrations
page](https://pennylane.ai/qml/demonstrations.html).
All demonstrations are fully executable, and can be downloaded as Jupyter notebooks and Python
scripts.
If you would like to contribute your own demo, see our [demo submission
guide](https://pennylane.ai/qml/demos_submission.html).
## Videos
Seeing is believing! Check out [our videos](https://pennylane.ai/qml/videos.html) to learn about
PennyLane, quantum computing concepts, and more.
## Contributing to PennyLane
We welcome contributions—simply fork the PennyLane repository, and then make a [pull
request](https://help.github.com/articles/about-pull-requests/) containing your contribution. All
contributors to PennyLane will be listed as authors on the releases. All users who contribute
significantly to the code (new plugins, new functionality, etc.) will be listed on the PennyLane
arXiv paper.
We also encourage bug reports, suggestions for new features and enhancements, and even links to cool
projects or applications built on PennyLane.
See our [contributions
page](https://github.com/PennyLaneAI/pennylane/blob/master/.github/CONTRIBUTING.md) and our
[developer hub](https://pennylane.readthedocs.io/en/stable/development/guide.html) for more
details.
## Support
- **Source Code:** https://github.com/PennyLaneAI/pennylane
- **Issue Tracker:** https://github.com/PennyLaneAI/pennylane/issues
If you are having issues, please let us know by posting the issue on our GitHub issue tracker.
We also have a [PennyLane discussion forum](https://discuss.pennylane.ai)—come join the community
and chat with the PennyLane team.
Note that we are committed to providing a friendly, safe, and welcoming environment for all.
Please read and respect the [Code of Conduct](.github/CODE_OF_CONDUCT.md).
## Authors
PennyLane is the work of [many contributors](https://github.com/PennyLaneAI/pennylane/graphs/contributors).
If you are doing research using PennyLane, please cite [our paper](https://arxiv.org/abs/1811.04968):
> Ville Bergholm et al. *PennyLane: Automatic differentiation of hybrid quantum-classical
> computations.* 2018. arXiv:1811.04968
## License
PennyLane is **free** and **open source**, released under the Apache License, Version 2.0.
%package -n python3-PennyLane
Summary: PennyLane is a Python quantum machine learning library by Xanadu Inc.
Provides: python-PennyLane
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PennyLane
PennyLane is a cross-platform Python library for differentiable
programming of quantum computers.
Train a quantum computer the same way as a neural network.
## Key Features
- *Machine learning on quantum hardware*. Connect to quantum hardware using **PyTorch**, **TensorFlow**, **JAX**, **Keras**, or **NumPy**. Build rich and flexible hybrid quantum-classical models.
- *Device-independent*. Run the same quantum circuit on different quantum backends. Install
[plugins](https://pennylane.ai/plugins.html) to access even more devices, including **Strawberry
Fields**, **Amazon Braket**, **IBM Q**, **Google Cirq**, **Rigetti Forest**, **Qulacs**, **Pasqal**, **Honeywell**, and more.
- *Follow the gradient*. Hardware-friendly **automatic differentiation** of quantum circuits.
- *Batteries included*. Built-in tools for **quantum machine learning**, **optimization**, and
**quantum chemistry**. Rapidly prototype using built-in quantum simulators with
backpropagation support.
## Installation
PennyLane requires Python version 3.8 and above. Installation of PennyLane, as well as all
dependencies, can be done using pip:
```console
python -m pip install pennylane
```
## Docker support
**Docker** support exists for building using **CPU** and **GPU** (Nvidia CUDA
11.1+) images. [See a more detailed description
here](https://pennylane.readthedocs.io/en/stable/development/guide/installation.html#docker).
## Getting started
For an introduction to quantum machine learning, guides and resources are available on
PennyLane's [quantum machine learning hub](https://pennylane.ai/qml/):
* [What is quantum machine learning?](https://pennylane.ai/qml/whatisqml.html)
* [QML tutorials and demos](https://pennylane.ai/qml/demonstrations.html)
* [Frequently asked questions](https://pennylane.ai/faq.html)
* [Key concepts of QML](https://pennylane.ai/qml/glossary.html)
* [QML videos](https://pennylane.ai/qml/videos.html)
You can also check out our [documentation](https://pennylane.readthedocs.io) for [quickstart
guides](https://pennylane.readthedocs.io/en/stable/introduction/pennylane.html) to using PennyLane,
and detailed developer guides on [how to write your
own](https://pennylane.readthedocs.io/en/stable/development/plugins.html) PennyLane-compatible
quantum device.
## Tutorials and demonstrations
Take a deeper dive into quantum machine learning by exploring cutting-edge algorithms on our [demonstrations
page](https://pennylane.ai/qml/demonstrations.html).
All demonstrations are fully executable, and can be downloaded as Jupyter notebooks and Python
scripts.
If you would like to contribute your own demo, see our [demo submission
guide](https://pennylane.ai/qml/demos_submission.html).
## Videos
Seeing is believing! Check out [our videos](https://pennylane.ai/qml/videos.html) to learn about
PennyLane, quantum computing concepts, and more.
## Contributing to PennyLane
We welcome contributions—simply fork the PennyLane repository, and then make a [pull
request](https://help.github.com/articles/about-pull-requests/) containing your contribution. All
contributors to PennyLane will be listed as authors on the releases. All users who contribute
significantly to the code (new plugins, new functionality, etc.) will be listed on the PennyLane
arXiv paper.
We also encourage bug reports, suggestions for new features and enhancements, and even links to cool
projects or applications built on PennyLane.
See our [contributions
page](https://github.com/PennyLaneAI/pennylane/blob/master/.github/CONTRIBUTING.md) and our
[developer hub](https://pennylane.readthedocs.io/en/stable/development/guide.html) for more
details.
## Support
- **Source Code:** https://github.com/PennyLaneAI/pennylane
- **Issue Tracker:** https://github.com/PennyLaneAI/pennylane/issues
If you are having issues, please let us know by posting the issue on our GitHub issue tracker.
We also have a [PennyLane discussion forum](https://discuss.pennylane.ai)—come join the community
and chat with the PennyLane team.
Note that we are committed to providing a friendly, safe, and welcoming environment for all.
Please read and respect the [Code of Conduct](.github/CODE_OF_CONDUCT.md).
## Authors
PennyLane is the work of [many contributors](https://github.com/PennyLaneAI/pennylane/graphs/contributors).
If you are doing research using PennyLane, please cite [our paper](https://arxiv.org/abs/1811.04968):
> Ville Bergholm et al. *PennyLane: Automatic differentiation of hybrid quantum-classical
> computations.* 2018. arXiv:1811.04968
## License
PennyLane is **free** and **open source**, released under the Apache License, Version 2.0.
%package help
Summary: Development documents and examples for PennyLane
Provides: python3-PennyLane-doc
%description help
PennyLane is a cross-platform Python library for differentiable
programming of quantum computers.
Train a quantum computer the same way as a neural network.
## Key Features
- *Machine learning on quantum hardware*. Connect to quantum hardware using **PyTorch**, **TensorFlow**, **JAX**, **Keras**, or **NumPy**. Build rich and flexible hybrid quantum-classical models.
- *Device-independent*. Run the same quantum circuit on different quantum backends. Install
[plugins](https://pennylane.ai/plugins.html) to access even more devices, including **Strawberry
Fields**, **Amazon Braket**, **IBM Q**, **Google Cirq**, **Rigetti Forest**, **Qulacs**, **Pasqal**, **Honeywell**, and more.
- *Follow the gradient*. Hardware-friendly **automatic differentiation** of quantum circuits.
- *Batteries included*. Built-in tools for **quantum machine learning**, **optimization**, and
**quantum chemistry**. Rapidly prototype using built-in quantum simulators with
backpropagation support.
## Installation
PennyLane requires Python version 3.8 and above. Installation of PennyLane, as well as all
dependencies, can be done using pip:
```console
python -m pip install pennylane
```
## Docker support
**Docker** support exists for building using **CPU** and **GPU** (Nvidia CUDA
11.1+) images. [See a more detailed description
here](https://pennylane.readthedocs.io/en/stable/development/guide/installation.html#docker).
## Getting started
For an introduction to quantum machine learning, guides and resources are available on
PennyLane's [quantum machine learning hub](https://pennylane.ai/qml/):
* [What is quantum machine learning?](https://pennylane.ai/qml/whatisqml.html)
* [QML tutorials and demos](https://pennylane.ai/qml/demonstrations.html)
* [Frequently asked questions](https://pennylane.ai/faq.html)
* [Key concepts of QML](https://pennylane.ai/qml/glossary.html)
* [QML videos](https://pennylane.ai/qml/videos.html)
You can also check out our [documentation](https://pennylane.readthedocs.io) for [quickstart
guides](https://pennylane.readthedocs.io/en/stable/introduction/pennylane.html) to using PennyLane,
and detailed developer guides on [how to write your
own](https://pennylane.readthedocs.io/en/stable/development/plugins.html) PennyLane-compatible
quantum device.
## Tutorials and demonstrations
Take a deeper dive into quantum machine learning by exploring cutting-edge algorithms on our [demonstrations
page](https://pennylane.ai/qml/demonstrations.html).
All demonstrations are fully executable, and can be downloaded as Jupyter notebooks and Python
scripts.
If you would like to contribute your own demo, see our [demo submission
guide](https://pennylane.ai/qml/demos_submission.html).
## Videos
Seeing is believing! Check out [our videos](https://pennylane.ai/qml/videos.html) to learn about
PennyLane, quantum computing concepts, and more.
## Contributing to PennyLane
We welcome contributions—simply fork the PennyLane repository, and then make a [pull
request](https://help.github.com/articles/about-pull-requests/) containing your contribution. All
contributors to PennyLane will be listed as authors on the releases. All users who contribute
significantly to the code (new plugins, new functionality, etc.) will be listed on the PennyLane
arXiv paper.
We also encourage bug reports, suggestions for new features and enhancements, and even links to cool
projects or applications built on PennyLane.
See our [contributions
page](https://github.com/PennyLaneAI/pennylane/blob/master/.github/CONTRIBUTING.md) and our
[developer hub](https://pennylane.readthedocs.io/en/stable/development/guide.html) for more
details.
## Support
- **Source Code:** https://github.com/PennyLaneAI/pennylane
- **Issue Tracker:** https://github.com/PennyLaneAI/pennylane/issues
If you are having issues, please let us know by posting the issue on our GitHub issue tracker.
We also have a [PennyLane discussion forum](https://discuss.pennylane.ai)—come join the community
and chat with the PennyLane team.
Note that we are committed to providing a friendly, safe, and welcoming environment for all.
Please read and respect the [Code of Conduct](.github/CODE_OF_CONDUCT.md).
## Authors
PennyLane is the work of [many contributors](https://github.com/PennyLaneAI/pennylane/graphs/contributors).
If you are doing research using PennyLane, please cite [our paper](https://arxiv.org/abs/1811.04968):
> Ville Bergholm et al. *PennyLane: Automatic differentiation of hybrid quantum-classical
> computations.* 2018. arXiv:1811.04968
## License
PennyLane is **free** and **open source**, released under the Apache License, Version 2.0.
%prep
%autosetup -n PennyLane-0.29.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PennyLane -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.29.1-1
- Package Spec generated