%global _empty_manifest_terminate_build 0
Name: python-getfilelistpy
Version: 1.0.7
Release: 1
Summary: This is a python library to retrieve the file list with the folder tree from the specific folder of Google Drive.
License: MIT License
URL: https://github.com/tanaikech/getfilelistpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/36/1781a5dc17ef666c8f6f046bff2a6a092a40ede56ae00396f42a8ea73e0b/getfilelistpy-1.0.7.tar.gz
BuildArch: noarch
Requires: python3-google-api-python-client
%description
# Licence
[MIT](LICENCE)
# Author
[Tanaike](https://tanaikech.github.io/about/)
If you have any questions and commissions for me, feel free to tell me.
# Update History
- v1.0.0 (November 17, 2018)
1. Initial release.
- v1.0.3 (July 16, 2019)
1. Markdown format was used to the readme file at [https://pypi.org/project/getfilelistpy/](https://pypi.org/project/getfilelistpy/).
- v1.0.4 (August 23, 2019)
1. For OAuth2, `oauth2client` and `google_auth_oauthlib` got to be able to be used. About the sample script for `google_auth_oauthlib`, please see [this](#googleauthoauthlibsample).
- v1.0.5 (May 15, 2020)
1. Shared drive got to be able to be used. The file list can be retrieved from both your Google Drive and the shared drive.
- For example, when the folder ID in the shared Drive is used `id` of `resource`, you can retrieve the file list from the folder in the shared Drive.
- v1.0.6 (June 1, 2020)
1. When the file is retrieved from the shared drive, the parameter was not completed. This bug was removed.
[TOP](#top)
%package -n python3-getfilelistpy
Summary: This is a python library to retrieve the file list with the folder tree from the specific folder of Google Drive.
Provides: python-getfilelistpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-getfilelistpy
# Licence
[MIT](LICENCE)
# Author
[Tanaike](https://tanaikech.github.io/about/)
If you have any questions and commissions for me, feel free to tell me.
# Update History
- v1.0.0 (November 17, 2018)
1. Initial release.
- v1.0.3 (July 16, 2019)
1. Markdown format was used to the readme file at [https://pypi.org/project/getfilelistpy/](https://pypi.org/project/getfilelistpy/).
- v1.0.4 (August 23, 2019)
1. For OAuth2, `oauth2client` and `google_auth_oauthlib` got to be able to be used. About the sample script for `google_auth_oauthlib`, please see [this](#googleauthoauthlibsample).
- v1.0.5 (May 15, 2020)
1. Shared drive got to be able to be used. The file list can be retrieved from both your Google Drive and the shared drive.
- For example, when the folder ID in the shared Drive is used `id` of `resource`, you can retrieve the file list from the folder in the shared Drive.
- v1.0.6 (June 1, 2020)
1. When the file is retrieved from the shared drive, the parameter was not completed. This bug was removed.
[TOP](#top)
%package help
Summary: Development documents and examples for getfilelistpy
Provides: python3-getfilelistpy-doc
%description help
# Licence
[MIT](LICENCE)
# Author
[Tanaike](https://tanaikech.github.io/about/)
If you have any questions and commissions for me, feel free to tell me.
# Update History
- v1.0.0 (November 17, 2018)
1. Initial release.
- v1.0.3 (July 16, 2019)
1. Markdown format was used to the readme file at [https://pypi.org/project/getfilelistpy/](https://pypi.org/project/getfilelistpy/).
- v1.0.4 (August 23, 2019)
1. For OAuth2, `oauth2client` and `google_auth_oauthlib` got to be able to be used. About the sample script for `google_auth_oauthlib`, please see [this](#googleauthoauthlibsample).
- v1.0.5 (May 15, 2020)
1. Shared drive got to be able to be used. The file list can be retrieved from both your Google Drive and the shared drive.
- For example, when the folder ID in the shared Drive is used `id` of `resource`, you can retrieve the file list from the folder in the shared Drive.
- v1.0.6 (June 1, 2020)
1. When the file is retrieved from the shared drive, the parameter was not completed. This bug was removed.
[TOP](#top)
%prep
%autosetup -n getfilelistpy-1.0.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-getfilelistpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 1.0.7-1
- Package Spec generated