%global _empty_manifest_terminate_build 0
Name:		python-djangocms-installer
Version:	2.0.0
Release:	1
Summary:	Command to easily bootstrap django CMS projects
License:	BSD
URL:		https://github.com/nephila/djangocms-installer
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6d/ad/b40a97659f6c8d945f540b731311f3ded7c9878b39e595c32266673ad46e/djangocms-installer-2.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-dj-database-url
Requires:	python3-six
Requires:	python3-tzlocal

%description


%package -n python3-djangocms-installer
Summary:	Command to easily bootstrap django CMS projects
Provides:	python-djangocms-installer
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-djangocms-installer


%package help
Summary:	Development documents and examples for djangocms-installer
Provides:	python3-djangocms-installer-doc
%description help


%prep
%autosetup -n djangocms-installer-2.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-djangocms-installer -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
- Package Spec generated