%global _empty_manifest_terminate_build 0
Name:		python-pulpcore
Version:	3.23.2
Release:	1
Summary:	Pulp Django Application and Related Modules
License:	GPLv2+
URL:		https://pulpproject.org
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/44/ac/f0ffcd8a7df23cdd91210294900bf14dd205b42626975faafd07a3289982/pulpcore-3.23.2.tar.gz
BuildArch:	noarch

Requires:	python3-asyncio-throttle
Requires:	python3-aiohttp
Requires:	python3-aiodns
Requires:	python3-aiofiles
Requires:	python3-backoff
Requires:	python3-click
Requires:	python3-cryptography
Requires:	python3-Django
Requires:	python3-django-currentuser
Requires:	python3-django-filter
Requires:	python3-django-guid
Requires:	python3-django-import-export
Requires:	python3-django-lifecycle
Requires:	python3-djangorestframework
Requires:	python3-djangorestframework-queryfields
Requires:	python3-drf-access-policy
Requires:	python3-drf-nested-routers
Requires:	python3-drf-spectacular
Requires:	python3-dynaconf
Requires:	python3-gunicorn
Requires:	python3-jinja2
Requires:	python3-naya
Requires:	python3-pulp-glue
Requires:	python3-protobuf
Requires:	python3-pygtrie
Requires:	python3-psycopg2
Requires:	python3-PyYAML
Requires:	python3-gnupg
Requires:	python3-redis
Requires:	python3-setuptools
Requires:	python3-url-normalize
Requires:	python3-whitenoise
Requires:	python3-yarl
Requires:	python3-django-storages[azure]
Requires:	python3-django-storages[google]
Requires:	python3-django-prometheus
Requires:	python3-django-storages[boto3]
Requires:	python3-django-storages[sftp]

%description
Check out our help page for ways to get help:
https://pulpproject.org/help/

%package -n python3-pulpcore
Summary:	Pulp Django Application and Related Modules
Provides:	python-pulpcore
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pulpcore
Check out our help page for ways to get help:
https://pulpproject.org/help/

%package help
Summary:	Development documents and examples for pulpcore
Provides:	python3-pulpcore-doc
%description help
Check out our help page for ways to get help:
https://pulpproject.org/help/

%prep
%autosetup -n pulpcore-3.23.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pulpcore -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 3.23.2-1
- Package Spec generated