%global _empty_manifest_terminate_build 0
Name:		python-kili
Version:	2.131.1
Release:	1
Summary:	Python client for Kili Technology labeling tool
License:	Apache Software License
URL:		https://github.com/kili-technology/kili-python-sdk
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/29/60/88ea817e42089580298a65337ff52c9a3aaf852480aafe83d052d5038f06/kili-2.131.1.tar.gz
BuildArch:	noarch

Requires:	python3-pandas
Requires:	python3-click
Requires:	python3-requests
Requires:	python3-tabulate
Requires:	python3-tenacity
Requires:	python3-tqdm
Requires:	python3-typeguard
Requires:	python3-typing-extensions
Requires:	python3-pyparsing
Requires:	python3-websocket-client
Requires:	python3-pyyaml
Requires:	python3-Pillow
Requires:	python3-cuid
Requires:	python3-pydantic
Requires:	python3-urllib3
Requires:	python3-ffmpeg-python
Requires:	python3-gql[requests,websockets]
Requires:	python3-filelock
Requires:	python3-bump2version
Requires:	python3-pytest
Requires:	python3-pytest-mock
Requires:	python3-pytest-cov
Requires:	python3-pytest-xdist[psutil]
Requires:	python3-mkdocs
Requires:	python3-mkdocs-material
Requires:	python3-mkdocstrings
Requires:	python3-mkdocstrings-python-legacy
Requires:	python3-mkdocs-click
Requires:	python3-mike
Requires:	python3-pymdown-extensions
Requires:	python3-black
Requires:	python3-pre-commit
Requires:	python3-pylint
Requires:	python3-flake8-unused-arguments
Requires:	python3-pyright
Requires:	python3-nbformat
Requires:	python3-nbconvert
Requires:	python3-ipykernel
Requires:	python3-opencv-python
Requires:	python3-opencv-python

%description
**SDK Reference**: <https://python-sdk-docs.kili-technology.com/>
**Kili Documentation**: <https://docs.kili-technology.com/docs>
**App**: <https://cloud.kili-technology.com/label/>

%package -n python3-kili
Summary:	Python client for Kili Technology labeling tool
Provides:	python-kili
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-kili
**SDK Reference**: <https://python-sdk-docs.kili-technology.com/>
**Kili Documentation**: <https://docs.kili-technology.com/docs>
**App**: <https://cloud.kili-technology.com/label/>

%package help
Summary:	Development documents and examples for kili
Provides:	python3-kili-doc
%description help
**SDK Reference**: <https://python-sdk-docs.kili-technology.com/>
**Kili Documentation**: <https://docs.kili-technology.com/docs>
**App**: <https://cloud.kili-technology.com/label/>

%prep
%autosetup -n kili-2.131.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-kili -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.131.1-1
- Package Spec generated