%global _empty_manifest_terminate_build 0
Name:		python-splicer
Version:	0.2.1
Release:	1
Summary:	the world is a database now you can query it with SQL
License:	UNKNOWN
URL:		http://github.com/trivio/splicer
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d6/88/fa02e80958597b9430a61d229f536f2fa54828cb2ce41c4d9973c8c7ca33/splicer-0.2.1.tar.gz
BuildArch:	noarch


%description
``splicer`` makes the entire world look like a SQL database. 
It is a python module for working with data from disparate sources 
using commands to those familiar with SQL. It aims to make quick 
one off queries and ETL scripts more declarative rather than procedural.
Inspired by projects like BigQuery, Postgres Foreign Data Wrappers
and Multicorn, except no database is required.
``splicer`` enables:
* Analysts to create Datasets linking various
  foreign tables together along with User Defined Functions written in python. 
  Once defined, the datasets can be queried via SQL Select statements to create 
  new Views of the Data.
* Extension Developers to create extensions that make various data sources
  REST endpoints, log files, NoSQL Servers, traditional Databases,
  CSV Files to behave like tables.
  ``splicer`` will take advantage of these various sources' capabilities where 
  appropriate and will compensate for sources that lack basic
  features. 
  For example if a database supports joins and you want to query
  two tables within that database, ``splicer`` will have that system
  perform the join for you. If however you're working with a less
  sophisticated source, like plain files, ``splicer`` will perform the
  operations for you locally.
Enough reading! [Try it out][1] 
[1]: https://splicer.readthedocs.org/en/latest/install.html#installation "Installing Splicer"

%package -n python3-splicer
Summary:	the world is a database now you can query it with SQL
Provides:	python-splicer
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-splicer
``splicer`` makes the entire world look like a SQL database. 
It is a python module for working with data from disparate sources 
using commands to those familiar with SQL. It aims to make quick 
one off queries and ETL scripts more declarative rather than procedural.
Inspired by projects like BigQuery, Postgres Foreign Data Wrappers
and Multicorn, except no database is required.
``splicer`` enables:
* Analysts to create Datasets linking various
  foreign tables together along with User Defined Functions written in python. 
  Once defined, the datasets can be queried via SQL Select statements to create 
  new Views of the Data.
* Extension Developers to create extensions that make various data sources
  REST endpoints, log files, NoSQL Servers, traditional Databases,
  CSV Files to behave like tables.
  ``splicer`` will take advantage of these various sources' capabilities where 
  appropriate and will compensate for sources that lack basic
  features. 
  For example if a database supports joins and you want to query
  two tables within that database, ``splicer`` will have that system
  perform the join for you. If however you're working with a less
  sophisticated source, like plain files, ``splicer`` will perform the
  operations for you locally.
Enough reading! [Try it out][1] 
[1]: https://splicer.readthedocs.org/en/latest/install.html#installation "Installing Splicer"

%package help
Summary:	Development documents and examples for splicer
Provides:	python3-splicer-doc
%description help
``splicer`` makes the entire world look like a SQL database. 
It is a python module for working with data from disparate sources 
using commands to those familiar with SQL. It aims to make quick 
one off queries and ETL scripts more declarative rather than procedural.
Inspired by projects like BigQuery, Postgres Foreign Data Wrappers
and Multicorn, except no database is required.
``splicer`` enables:
* Analysts to create Datasets linking various
  foreign tables together along with User Defined Functions written in python. 
  Once defined, the datasets can be queried via SQL Select statements to create 
  new Views of the Data.
* Extension Developers to create extensions that make various data sources
  REST endpoints, log files, NoSQL Servers, traditional Databases,
  CSV Files to behave like tables.
  ``splicer`` will take advantage of these various sources' capabilities where 
  appropriate and will compensate for sources that lack basic
  features. 
  For example if a database supports joins and you want to query
  two tables within that database, ``splicer`` will have that system
  perform the join for you. If however you're working with a less
  sophisticated source, like plain files, ``splicer`` will perform the
  operations for you locally.
Enough reading! [Try it out][1] 
[1]: https://splicer.readthedocs.org/en/latest/install.html#installation "Installing Splicer"

%prep
%autosetup -n splicer-0.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-splicer -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
- Package Spec generated