%global _empty_manifest_terminate_build 0
Name: python-daisykit
Version: 0.3.0.1
Release: 1
Summary: Deploy AI Systems Yourself (DAISY) Kit. DaisyKit Python is the wrapper of DaisyKit SDK, an easy AI framework for everyone.
License: Apache License 2.0
URL: https://daisykit.nrl.ai/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7d/71/6fed885b730223083f5aa7ea147cb8566301f745ef8ad6d168aed6cb2df5/daisykit-0.3.0.1.tar.gz
Requires: python3-numpy
Requires: python3-tqdm
Requires: python3-requests
Requires: python3-portalocker
Requires: python3-opencv-python
%description
# Daisykit Python
Daisykit is an easy AI toolkit for software engineers to integrate pretrained AI models and pipelines into their projects. You DON'T need to be an AI engineer to build AI software. This open source project includes:
- **Daisykit SDK - C++**, the core of models and algorithms in NCNN deep learning framework.
- **Daisykit Python** wrapper for easy integration with Python.
- **Daisykit Android** - Example app demonstrate how to use Daisykit SDK in Android.
## How to install ?
**For Windows:**
```
pip3 install daisykit
```
**For Ubuntu:**
- Install dependencies
```
sudo apt install pybind11-dev # Pybind11 - For Python/C++ Wrapper
sudo apt install libopencv-dev # For OpenCV
sudo apt install libvulkan-dev # Optional - For GPU support
```
- Install DaisyKit (compile from source)
```
pip3 install --upgrade pip # Ensure pip is updated
pip3 install daisykit
```
**For other platforms:**
- Install OpenCV, Pybind11 and Vulkan development package (if you want GPU support)
- Install DaisyKit (compile from source)
```
pip3 install --upgrade pip # Ensure pip is updated
pip3 install daisykit
```
## Examples
Read [Documentation](https://daisykit.nrl.ai).
## Note for Python build
Current CD (continuous delivery) flow is partial, which means we only have prebuilt linux wheels for x86_64 and for Windows.
- Prebuilt wheels for linux x86_64 are built with Github actions.
- Windows wheels (64bit) are built manually on a local machine.
- macOS prebuilt wheels are not available for now. However, you can install dependencies (OpenCV, Vulkan) manually, then install Daisykit with pip command.
We will be happy if you can make a pull request to make the CD build fully automated. A good choice is using Github flow for all building tasks.
**Current steps for Windows build:**
```sh
bash ./build_tools/py_windows/build_dk_all_pythons_windows.sh
bash ./build_tools/py_windows/build_dk_python_source_dist.sh
bash ./build_tools/upload_pypi.sh
```
## Bug report
Please open an issue on our official repository if you find any error.
%package -n python3-daisykit
Summary: Deploy AI Systems Yourself (DAISY) Kit. DaisyKit Python is the wrapper of DaisyKit SDK, an easy AI framework for everyone.
Provides: python-daisykit
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-daisykit
# Daisykit Python
Daisykit is an easy AI toolkit for software engineers to integrate pretrained AI models and pipelines into their projects. You DON'T need to be an AI engineer to build AI software. This open source project includes:
- **Daisykit SDK - C++**, the core of models and algorithms in NCNN deep learning framework.
- **Daisykit Python** wrapper for easy integration with Python.
- **Daisykit Android** - Example app demonstrate how to use Daisykit SDK in Android.
## How to install ?
**For Windows:**
```
pip3 install daisykit
```
**For Ubuntu:**
- Install dependencies
```
sudo apt install pybind11-dev # Pybind11 - For Python/C++ Wrapper
sudo apt install libopencv-dev # For OpenCV
sudo apt install libvulkan-dev # Optional - For GPU support
```
- Install DaisyKit (compile from source)
```
pip3 install --upgrade pip # Ensure pip is updated
pip3 install daisykit
```
**For other platforms:**
- Install OpenCV, Pybind11 and Vulkan development package (if you want GPU support)
- Install DaisyKit (compile from source)
```
pip3 install --upgrade pip # Ensure pip is updated
pip3 install daisykit
```
## Examples
Read [Documentation](https://daisykit.nrl.ai).
## Note for Python build
Current CD (continuous delivery) flow is partial, which means we only have prebuilt linux wheels for x86_64 and for Windows.
- Prebuilt wheels for linux x86_64 are built with Github actions.
- Windows wheels (64bit) are built manually on a local machine.
- macOS prebuilt wheels are not available for now. However, you can install dependencies (OpenCV, Vulkan) manually, then install Daisykit with pip command.
We will be happy if you can make a pull request to make the CD build fully automated. A good choice is using Github flow for all building tasks.
**Current steps for Windows build:**
```sh
bash ./build_tools/py_windows/build_dk_all_pythons_windows.sh
bash ./build_tools/py_windows/build_dk_python_source_dist.sh
bash ./build_tools/upload_pypi.sh
```
## Bug report
Please open an issue on our official repository if you find any error.
%package help
Summary: Development documents and examples for daisykit
Provides: python3-daisykit-doc
%description help
# Daisykit Python
Daisykit is an easy AI toolkit for software engineers to integrate pretrained AI models and pipelines into their projects. You DON'T need to be an AI engineer to build AI software. This open source project includes:
- **Daisykit SDK - C++**, the core of models and algorithms in NCNN deep learning framework.
- **Daisykit Python** wrapper for easy integration with Python.
- **Daisykit Android** - Example app demonstrate how to use Daisykit SDK in Android.
## How to install ?
**For Windows:**
```
pip3 install daisykit
```
**For Ubuntu:**
- Install dependencies
```
sudo apt install pybind11-dev # Pybind11 - For Python/C++ Wrapper
sudo apt install libopencv-dev # For OpenCV
sudo apt install libvulkan-dev # Optional - For GPU support
```
- Install DaisyKit (compile from source)
```
pip3 install --upgrade pip # Ensure pip is updated
pip3 install daisykit
```
**For other platforms:**
- Install OpenCV, Pybind11 and Vulkan development package (if you want GPU support)
- Install DaisyKit (compile from source)
```
pip3 install --upgrade pip # Ensure pip is updated
pip3 install daisykit
```
## Examples
Read [Documentation](https://daisykit.nrl.ai).
## Note for Python build
Current CD (continuous delivery) flow is partial, which means we only have prebuilt linux wheels for x86_64 and for Windows.
- Prebuilt wheels for linux x86_64 are built with Github actions.
- Windows wheels (64bit) are built manually on a local machine.
- macOS prebuilt wheels are not available for now. However, you can install dependencies (OpenCV, Vulkan) manually, then install Daisykit with pip command.
We will be happy if you can make a pull request to make the CD build fully automated. A good choice is using Github flow for all building tasks.
**Current steps for Windows build:**
```sh
bash ./build_tools/py_windows/build_dk_all_pythons_windows.sh
bash ./build_tools/py_windows/build_dk_python_source_dist.sh
bash ./build_tools/upload_pypi.sh
```
## Bug report
Please open an issue on our official repository if you find any error.
%prep
%autosetup -n daisykit-0.3.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-daisykit -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 0.3.0.1-1
- Package Spec generated