%global _empty_manifest_terminate_build 0
Name: python-deemix
Version: 3.6.6
Release: 1
Summary: A barebone deezer downloader library
License: GPL3
URL: https://pypi.org/project/deemix/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e5/a0/0830ad0f4bae4747dddeb5802e9bb466bb60842fbc9609b207f922aaa098/deemix-3.6.6.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-pycryptodomex
Requires: python3-mutagen
Requires: python3-requests
Requires: python3-deezer-py
Requires: python3-spotipy
%description
# ![](./icon.svg) deemix
## What is deemix?
deemix is a deezer downloader built from the ashes of Deezloader Remix. The base library (or core) can be used as a stand alone CLI app or implemented in an UI using the API.
## Installation
NOTE: If `python3` is "not a recognized command" try using `python` instead.
### From PyPi
You can install the library by using `pip`:
`python3 -m pip install deemix`
If you install it this way you can use the deemix CLI by using `deemix` directly in your terminal instead of `python3 -m deemix`
### Building from source
After installing Python open a terminal/command prompt and install the dependencies using `python3 -m pip install -r requirements.txt --user`
Run `python3 -m deemix --help` to see how to use the app in CLI mode.
## What's left to do?
- Write the API Documentation
- Fix whatever is broken
# License
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
%package -n python3-deemix
Summary: A barebone deezer downloader library
Provides: python-deemix
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-deemix
# ![](./icon.svg) deemix
## What is deemix?
deemix is a deezer downloader built from the ashes of Deezloader Remix. The base library (or core) can be used as a stand alone CLI app or implemented in an UI using the API.
## Installation
NOTE: If `python3` is "not a recognized command" try using `python` instead.
### From PyPi
You can install the library by using `pip`:
`python3 -m pip install deemix`
If you install it this way you can use the deemix CLI by using `deemix` directly in your terminal instead of `python3 -m deemix`
### Building from source
After installing Python open a terminal/command prompt and install the dependencies using `python3 -m pip install -r requirements.txt --user`
Run `python3 -m deemix --help` to see how to use the app in CLI mode.
## What's left to do?
- Write the API Documentation
- Fix whatever is broken
# License
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
%package help
Summary: Development documents and examples for deemix
Provides: python3-deemix-doc
%description help
# ![](./icon.svg) deemix
## What is deemix?
deemix is a deezer downloader built from the ashes of Deezloader Remix. The base library (or core) can be used as a stand alone CLI app or implemented in an UI using the API.
## Installation
NOTE: If `python3` is "not a recognized command" try using `python` instead.
### From PyPi
You can install the library by using `pip`:
`python3 -m pip install deemix`
If you install it this way you can use the deemix CLI by using `deemix` directly in your terminal instead of `python3 -m deemix`
### Building from source
After installing Python open a terminal/command prompt and install the dependencies using `python3 -m pip install -r requirements.txt --user`
Run `python3 -m deemix --help` to see how to use the app in CLI mode.
## What's left to do?
- Write the API Documentation
- Fix whatever is broken
# License
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
%prep
%autosetup -n deemix-3.6.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-deemix -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 3.6.6-1
- Package Spec generated