%global _empty_manifest_terminate_build 0
Name: python-wfastcgi
Version: 3.0.0
Release: 1
Summary: An IIS-Python bridge based on WSGI and FastCGI.
License: Apache License 2.0
URL: http://aka.ms/python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/c7/c67ab1c936b6294c3692d891ff6d4df1b82254a98f00e2cb72083b1ad796/wfastcgi-3.0.0.tar.gz
BuildArch: noarch
%description
wfastcgi.py provides a bridge between `IIS `__ and Python
using WSGI and FastCGI, similar to what ``mod_python`` provides for Apache HTTP
Server.
It can be used with any Python web application or framework that supports WSGI,
and provides an efficient way to handle requests and process pools through IIS.
%package -n python3-wfastcgi
Summary: An IIS-Python bridge based on WSGI and FastCGI.
Provides: python-wfastcgi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wfastcgi
wfastcgi.py provides a bridge between `IIS `__ and Python
using WSGI and FastCGI, similar to what ``mod_python`` provides for Apache HTTP
Server.
It can be used with any Python web application or framework that supports WSGI,
and provides an efficient way to handle requests and process pools through IIS.
%package help
Summary: Development documents and examples for wfastcgi
Provides: python3-wfastcgi-doc
%description help
wfastcgi.py provides a bridge between `IIS `__ and Python
using WSGI and FastCGI, similar to what ``mod_python`` provides for Apache HTTP
Server.
It can be used with any Python web application or framework that supports WSGI,
and provides an efficient way to handle requests and process pools through IIS.
%prep
%autosetup -n wfastcgi-3.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wfastcgi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 3.0.0-1
- Package Spec generated