%global _empty_manifest_terminate_build 0
Name: python-pyridy
Version: 1.0.0
Release: 1
Summary: Support library for measurements made with the Ridy Android App
License: Apache-2.0
URL: https://pypi.org/project/pyridy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/eb/23/2452e6f32f5c8066ecac5f02e4af50c4ddb2adc7f89bec756b2220f6545d/pyridy-1.0.0.tar.gz
BuildArch: noarch
Requires: python3-pytest
Requires: python3-numpy
Requires: python3-requests
Requires: python3-pandas
Requires: python3-matplotlib
Requires: python3-tqdm
Requires: python3-overpy
Requires: python3-geopy
Requires: python3-scipy
Requires: python3-pyproj
Requires: python3-ipyleaflet
Requires: python3-networkx
Requires: python3-HeapDict
Requires: python3-Shapely
Requires: python3-requests-cache
Requires: python3-rwthcolors
%description
# PyRidy

Python Support Library to import and process Ridy files
### About Ridy
Ridy is an Android App to record sensor data for uses in science and engineering. The app is currently actively being
developed at the [Chair and Institute for Rail Vehicles and Transport Systems (IFS)](http://www.ifs.rwth-aachen.de/en/start/)
At the institute Ridy is e.g. used for condition monitoring of railway tracks and several more use-cases are currently
researched upon.
Among other, Ridy can record:
* Acceleration
* Linear Acceleration (i.e., without g-Force)
* Magnetic Field
* Gyroscope
* Orientation
* GNSS Location (+ Android Raw GNSS Measurements)
* Pressure, Humidity, Temperature, Ambient Light
Compared to other existing apps Ridy can perform long measurements even in the background when the phone is locked.
The app supports two formats for data export, JSON and SQLITE. If you would like to use or try out the app please contact the
developer (see below) to get access.
### About PyRidy
PyRidy is the companion python library for the Ridy Android App. It provides easy access to the data no matter which
recording format was used. If pyridy is used, one does no longer need to manually write code to import the files.
In addition, pyridy provides several more features:
* Automatic conversion of sensor data into objects and numpy arrays
* Conversion of arrays to Pandas DataFrame objects
* Time synchronization of individual files (e.g. from different phones)
* Download of OSM Railway Data via the Overpass API
* Plotting of GPS tracks onto a map using ipyleaflet
### Documentation
[PyRidy Documentation](https://pyridy.readthedocs.io/)
#### Installation
Install using pip
```python
pip install pyridy
```
#### Usage
Information and examples on how to use the library can be found in the [PyRidy documentation](https://pyridy.readthedocs.io/)
### Creator
Philipp Leibner - philipp.leibner@ifs.rwth-aachen.de
### Contributor
Daniel Pujiula Buhl - daniel.pujiula@rwth-aachen.de
Sarra Bouchkati - sarra.bouchkati@rwth-aachen.de
%package -n python3-pyridy
Summary: Support library for measurements made with the Ridy Android App
Provides: python-pyridy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyridy
# PyRidy

Python Support Library to import and process Ridy files
### About Ridy
Ridy is an Android App to record sensor data for uses in science and engineering. The app is currently actively being
developed at the [Chair and Institute for Rail Vehicles and Transport Systems (IFS)](http://www.ifs.rwth-aachen.de/en/start/)
At the institute Ridy is e.g. used for condition monitoring of railway tracks and several more use-cases are currently
researched upon.
Among other, Ridy can record:
* Acceleration
* Linear Acceleration (i.e., without g-Force)
* Magnetic Field
* Gyroscope
* Orientation
* GNSS Location (+ Android Raw GNSS Measurements)
* Pressure, Humidity, Temperature, Ambient Light
Compared to other existing apps Ridy can perform long measurements even in the background when the phone is locked.
The app supports two formats for data export, JSON and SQLITE. If you would like to use or try out the app please contact the
developer (see below) to get access.
### About PyRidy
PyRidy is the companion python library for the Ridy Android App. It provides easy access to the data no matter which
recording format was used. If pyridy is used, one does no longer need to manually write code to import the files.
In addition, pyridy provides several more features:
* Automatic conversion of sensor data into objects and numpy arrays
* Conversion of arrays to Pandas DataFrame objects
* Time synchronization of individual files (e.g. from different phones)
* Download of OSM Railway Data via the Overpass API
* Plotting of GPS tracks onto a map using ipyleaflet
### Documentation
[PyRidy Documentation](https://pyridy.readthedocs.io/)
#### Installation
Install using pip
```python
pip install pyridy
```
#### Usage
Information and examples on how to use the library can be found in the [PyRidy documentation](https://pyridy.readthedocs.io/)
### Creator
Philipp Leibner - philipp.leibner@ifs.rwth-aachen.de
### Contributor
Daniel Pujiula Buhl - daniel.pujiula@rwth-aachen.de
Sarra Bouchkati - sarra.bouchkati@rwth-aachen.de
%package help
Summary: Development documents and examples for pyridy
Provides: python3-pyridy-doc
%description help
# PyRidy

Python Support Library to import and process Ridy files
### About Ridy
Ridy is an Android App to record sensor data for uses in science and engineering. The app is currently actively being
developed at the [Chair and Institute for Rail Vehicles and Transport Systems (IFS)](http://www.ifs.rwth-aachen.de/en/start/)
At the institute Ridy is e.g. used for condition monitoring of railway tracks and several more use-cases are currently
researched upon.
Among other, Ridy can record:
* Acceleration
* Linear Acceleration (i.e., without g-Force)
* Magnetic Field
* Gyroscope
* Orientation
* GNSS Location (+ Android Raw GNSS Measurements)
* Pressure, Humidity, Temperature, Ambient Light
Compared to other existing apps Ridy can perform long measurements even in the background when the phone is locked.
The app supports two formats for data export, JSON and SQLITE. If you would like to use or try out the app please contact the
developer (see below) to get access.
### About PyRidy
PyRidy is the companion python library for the Ridy Android App. It provides easy access to the data no matter which
recording format was used. If pyridy is used, one does no longer need to manually write code to import the files.
In addition, pyridy provides several more features:
* Automatic conversion of sensor data into objects and numpy arrays
* Conversion of arrays to Pandas DataFrame objects
* Time synchronization of individual files (e.g. from different phones)
* Download of OSM Railway Data via the Overpass API
* Plotting of GPS tracks onto a map using ipyleaflet
### Documentation
[PyRidy Documentation](https://pyridy.readthedocs.io/)
#### Installation
Install using pip
```python
pip install pyridy
```
#### Usage
Information and examples on how to use the library can be found in the [PyRidy documentation](https://pyridy.readthedocs.io/)
### Creator
Philipp Leibner - philipp.leibner@ifs.rwth-aachen.de
### Contributor
Daniel Pujiula Buhl - daniel.pujiula@rwth-aachen.de
Sarra Bouchkati - sarra.bouchkati@rwth-aachen.de
%prep
%autosetup -n pyridy-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyridy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 1.0.0-1
- Package Spec generated