%global _empty_manifest_terminate_build 0 Name: python-adapt Version: 0.4.2 Release: 1 Summary: Awesome Domain Adaptation Python Toolbox for Tensorflow and Scikit-learn License: BSD-2 URL: https://github.com/adapt-python/adapt.git Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d5/45/601daeb1a7af4e4d97950c7f020946052fe4785f2b671dd6174a7177c1e4/adapt-0.4.2.tar.gz BuildArch: noarch %description ADAPT is an open source library providing numerous tools to perform Transfer Learning and Domain Adaptation. The purpose of the ADAPT library is to facilitate the access to transfer learning algorithms for a large public, including industrial players. ADAPT is specifically designed for [Scikit-learn](https://scikit-learn.org/stable/) and [Tensorflow](https://www.tensorflow.org/) users with a "user-friendly" approach. All objects in ADAPT implement the ***fit***, ***predict*** and ***score*** methods like any scikit-learn object. A very detailed documentation with several examples is provided:
Sample bias correction |
Model-based Transfer |
Deep Domain Adaptation |
Multi-Fidelity Transfer |
Adapt Estimator ```python AdaptEstimator( estimator = """A scikit-learn estimator (like Ridge(alpha=1.) for example) or a Tensorflow Model""", Xt = "The target input features", yt = "The target output labels (if any)", **params = "Hyper-parameters of the AdaptEstimator" ) ``` |
Deep Adapt Estimator ```python DeepAdaptEstimator( encoder = "A Tensorflow Model (if required)", task = "A Tensorflow Model (if required)", discriminator = "A Tensorflow Model (if required)", Xt = "The target input features", yt = "The target output labels (if any)", **params = """Hyper-parameters of the DeepAdaptEstimator and the compile and fit params (optimizer, epochs...)""" ) ``` |
Scikit-learn Meta-Estimator ```python SklearnMetaEstimator( base_estimator = """A scikit-learn estimator (like Ridge(alpha=1.) for example)""", **params = "Hyper-parameters of the SklearnMetaEstimator" ) ``` |
Sample bias correction |
Model-based Transfer |
Deep Domain Adaptation |
Multi-Fidelity Transfer |
Adapt Estimator ```python AdaptEstimator( estimator = """A scikit-learn estimator (like Ridge(alpha=1.) for example) or a Tensorflow Model""", Xt = "The target input features", yt = "The target output labels (if any)", **params = "Hyper-parameters of the AdaptEstimator" ) ``` |
Deep Adapt Estimator ```python DeepAdaptEstimator( encoder = "A Tensorflow Model (if required)", task = "A Tensorflow Model (if required)", discriminator = "A Tensorflow Model (if required)", Xt = "The target input features", yt = "The target output labels (if any)", **params = """Hyper-parameters of the DeepAdaptEstimator and the compile and fit params (optimizer, epochs...)""" ) ``` |
Scikit-learn Meta-Estimator ```python SklearnMetaEstimator( base_estimator = """A scikit-learn estimator (like Ridge(alpha=1.) for example)""", **params = "Hyper-parameters of the SklearnMetaEstimator" ) ``` |
Sample bias correction |
Model-based Transfer |
Deep Domain Adaptation |
Multi-Fidelity Transfer |
Adapt Estimator ```python AdaptEstimator( estimator = """A scikit-learn estimator (like Ridge(alpha=1.) for example) or a Tensorflow Model""", Xt = "The target input features", yt = "The target output labels (if any)", **params = "Hyper-parameters of the AdaptEstimator" ) ``` |
Deep Adapt Estimator ```python DeepAdaptEstimator( encoder = "A Tensorflow Model (if required)", task = "A Tensorflow Model (if required)", discriminator = "A Tensorflow Model (if required)", Xt = "The target input features", yt = "The target output labels (if any)", **params = """Hyper-parameters of the DeepAdaptEstimator and the compile and fit params (optimizer, epochs...)""" ) ``` |
Scikit-learn Meta-Estimator ```python SklearnMetaEstimator( base_estimator = """A scikit-learn estimator (like Ridge(alpha=1.) for example)""", **params = "Hyper-parameters of the SklearnMetaEstimator" ) ``` |