%global _empty_manifest_terminate_build 0
Name: python-idle
Version: 1.0.4
Release: 1
Summary: Alternavtive of notepad
License: MIT License
URL: https://pypi.org/project/idle/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/4e/d1174fcfc7a7eec2e6cd7ad45ea1d8973e376f8672e7f7b1e9b928282cfc/idle-1.0.4.tar.gz
BuildArch: noarch
%description
### 🌟 Welocome to Idle Text Editor 🌟
| ![PyPI](https://img.shields.io/pypi/v/idle?style=for-the-badge) | ![PyPI - Format](https://img.shields.io/pypi/format/idle?style=for-the-badge) |
|------|-----|
| ![PowerShell Gallery](https://img.shields.io/powershellgallery/p/DNS.1.1.1.1?style=for-the-badge) | ![PyPI - License](https://img.shields.io/pypi/l/idle?style=for-the-badge) |
| ![Lines of code](https://img.shields.io/tokei/lines/github/devesh01032008/idle?style=for-the-badge) | ![GitHub release (latest by date)](https://img.shields.io/github/v/release/devesh01032008/idle?style=for-the-badge) |
This is a program written in tkinter which acts as text editor.This can be used to edit file and as alternative of notepad.
### Photos of idle text editor
| ![Demo Photo](img/idle-text-editor.jpg) | ![Save Photo](img/save-as-photo.jpg) |
|------|-------|
### Steps to Download textEditor
```
#For Linux
sudo apt install python3
pip3 install idle
#For Windows
pip install idle
#For macOs
brew install python3
pip install idle
```
It would automatically launch when it is imported in program and nothing is required to launch this program
### How to use it?
```
import idle
# run this command in python Interpretator
# this will automatically launch idle display
```
### About The Author
![Devesh Sharma](img/devesh.jpeg)
I am Devesh Sharma.I read in class 9. I live in samalkha,panipat located in India has created this program as alternative of text editor such as notepad
This program aim to provide a graphical user interface to users which uses python.
### 🌟 Ways to contact me 🌟
[Github](https://www.github.com/devesh01032008/)
[Email](mailto:deveshsharma1009@gmail.com)
### Show your support 🌟
```
Licenced
© Copyright 2021-22
All rights reserved
```
%package -n python3-idle
Summary: Alternavtive of notepad
Provides: python-idle
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-idle
### 🌟 Welocome to Idle Text Editor 🌟
| ![PyPI](https://img.shields.io/pypi/v/idle?style=for-the-badge) | ![PyPI - Format](https://img.shields.io/pypi/format/idle?style=for-the-badge) |
|------|-----|
| ![PowerShell Gallery](https://img.shields.io/powershellgallery/p/DNS.1.1.1.1?style=for-the-badge) | ![PyPI - License](https://img.shields.io/pypi/l/idle?style=for-the-badge) |
| ![Lines of code](https://img.shields.io/tokei/lines/github/devesh01032008/idle?style=for-the-badge) | ![GitHub release (latest by date)](https://img.shields.io/github/v/release/devesh01032008/idle?style=for-the-badge) |
This is a program written in tkinter which acts as text editor.This can be used to edit file and as alternative of notepad.
### Photos of idle text editor
| ![Demo Photo](img/idle-text-editor.jpg) | ![Save Photo](img/save-as-photo.jpg) |
|------|-------|
### Steps to Download textEditor
```
#For Linux
sudo apt install python3
pip3 install idle
#For Windows
pip install idle
#For macOs
brew install python3
pip install idle
```
It would automatically launch when it is imported in program and nothing is required to launch this program
### How to use it?
```
import idle
# run this command in python Interpretator
# this will automatically launch idle display
```
### About The Author
![Devesh Sharma](img/devesh.jpeg)
I am Devesh Sharma.I read in class 9. I live in samalkha,panipat located in India has created this program as alternative of text editor such as notepad
This program aim to provide a graphical user interface to users which uses python.
### 🌟 Ways to contact me 🌟
[Github](https://www.github.com/devesh01032008/)
[Email](mailto:deveshsharma1009@gmail.com)
### Show your support 🌟
```
Licenced
© Copyright 2021-22
All rights reserved
```
%package help
Summary: Development documents and examples for idle
Provides: python3-idle-doc
%description help
### 🌟 Welocome to Idle Text Editor 🌟
| ![PyPI](https://img.shields.io/pypi/v/idle?style=for-the-badge) | ![PyPI - Format](https://img.shields.io/pypi/format/idle?style=for-the-badge) |
|------|-----|
| ![PowerShell Gallery](https://img.shields.io/powershellgallery/p/DNS.1.1.1.1?style=for-the-badge) | ![PyPI - License](https://img.shields.io/pypi/l/idle?style=for-the-badge) |
| ![Lines of code](https://img.shields.io/tokei/lines/github/devesh01032008/idle?style=for-the-badge) | ![GitHub release (latest by date)](https://img.shields.io/github/v/release/devesh01032008/idle?style=for-the-badge) |
This is a program written in tkinter which acts as text editor.This can be used to edit file and as alternative of notepad.
### Photos of idle text editor
| ![Demo Photo](img/idle-text-editor.jpg) | ![Save Photo](img/save-as-photo.jpg) |
|------|-------|
### Steps to Download textEditor
```
#For Linux
sudo apt install python3
pip3 install idle
#For Windows
pip install idle
#For macOs
brew install python3
pip install idle
```
It would automatically launch when it is imported in program and nothing is required to launch this program
### How to use it?
```
import idle
# run this command in python Interpretator
# this will automatically launch idle display
```
### About The Author
![Devesh Sharma](img/devesh.jpeg)
I am Devesh Sharma.I read in class 9. I live in samalkha,panipat located in India has created this program as alternative of text editor such as notepad
This program aim to provide a graphical user interface to users which uses python.
### 🌟 Ways to contact me 🌟
[Github](https://www.github.com/devesh01032008/)
[Email](mailto:deveshsharma1009@gmail.com)
### Show your support 🌟
```
Licenced
© Copyright 2021-22
All rights reserved
```
%prep
%autosetup -n idle-1.0.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-idle -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.0.4-1
- Package Spec generated