%global _empty_manifest_terminate_build 0
Name:		python-iso639
Version:	0.1.4
Release:	1
Summary:	ISO639-2 support for Python.
License:	MIT
URL:		https://github.com/janpipek/iso639-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d5/23/6aecf85ed735ff017af073d1da764b8f24822f8ec17798fc83816d166826/iso639-0.1.4.tar.gz
BuildArch:	noarch


%description
A simple (really simple) library for working with ISO639-2 language codes.
Tested for Python 2.7 & 3.4.
Includes data from Congress library: http://www.loc.gov/standards/iso639-2/php/code_list.php (+ updates)

%package -n python3-iso639
Summary:	ISO639-2 support for Python.
Provides:	python-iso639
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-iso639
A simple (really simple) library for working with ISO639-2 language codes.
Tested for Python 2.7 & 3.4.
Includes data from Congress library: http://www.loc.gov/standards/iso639-2/php/code_list.php (+ updates)

%package help
Summary:	Development documents and examples for iso639
Provides:	python3-iso639-doc
%description help
A simple (really simple) library for working with ISO639-2 language codes.
Tested for Python 2.7 & 3.4.
Includes data from Congress library: http://www.loc.gov/standards/iso639-2/php/code_list.php (+ updates)

%prep
%autosetup -n iso639-0.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-iso639 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.4-1
- Package Spec generated