%global _empty_manifest_terminate_build 0
Name: python-mne
Version: 1.3.1
Release: 1
Summary: MNE-Python project for MEG and EEG data analysis.
License: BSD-3-Clause
URL: https://mne.tools/dev/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d6/ee/2dbb0a27d7431bec54c9300ae571f227fe5b21015c73a77dd641af684d21/mne-1.3.1.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-matplotlib
Requires: python3-tqdm
Requires: python3-pooch
Requires: python3-decorator
Requires: python3-packaging
Requires: python3-jinja2
Requires: python3-h5io
Requires: python3-pymatreader
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-timeout
Requires: python3-pytest-harvest
Requires: python3-flake8
Requires: python3-flake8-array-spacing
Requires: python3-numpydoc
Requires: python3-codespell
Requires: python3-pydocstyle
Requires: python3-check-manifest
Requires: python3-twine
Requires: python3-wheel
Requires: python3-nitime
Requires: python3-nbclient
Requires: python3-sphinx-gallery
Requires: python3-eeglabio
Requires: python3-EDFlib-Python
Requires: python3-pybv
Requires: python3-imageio-ffmpeg
%description
`MNE-Python software`_ is an open-source Python package for exploring,
visualizing, and analyzing human neurophysiological data such as MEG, EEG, sEEG,
ECoG, and more. It includes modules for data input/output, preprocessing,
visualization, source estimation, time-frequency analysis, connectivity analysis,
machine learning, and statistics.
Documentation
^^^^^^^^^^^^^
`MNE documentation`_ for MNE-Python is available online.
Installing MNE-Python
^^^^^^^^^^^^^^^^^^^^^
To install the latest stable version of MNE-Python, you can use pip_ in a terminal:
$ pip install -U mne
- MNE-Python 0.17 was the last release to support Python 2.7
- MNE-Python 0.18 requires Python 3.5 or higher
- MNE-Python 0.21 requires Python 3.6 or higher
- MNE-Python 0.24 requires Python 3.7 or higher
For more complete instructions and more advanced installation methods (e.g. for
the latest development version), see the `installation guide`_.
Get the latest code
^^^^^^^^^^^^^^^^^^^
To install the latest version of the code using pip_ open a terminal and type:
$ pip install -U https://github.com/mne-tools/mne-python/archive/main.zip
To get the latest code using `git `__, open a terminal and type:
$ git clone https://github.com/mne-tools/mne-python.git
Alternatively, you can also download a
`zip file of the latest development version `__.
Dependencies
^^^^^^^^^^^^
The minimum required dependencies to run MNE-Python are:
- Python >= 3.7
- NumPy >= 1.18.1
- SciPy >= 1.4.1
- Matplotlib >= 3.1.0
- pooch >= 1.5
- tqdm
- Jinja2
- decorator
For full functionality, some functions require:
- Scikit-learn >= 0.22.0
- joblib >= 0.15 (for parallelization control)
- Numba >= 0.48.0
- NiBabel >= 2.5.0
- OpenMEEG >= 2.5.5
- Pandas >= 1.0.0
- Picard >= 0.3
- CuPy >= 7.1.1 (for NVIDIA CUDA acceleration)
- DIPY >= 1.1.0
- Imageio >= 2.6.1
- PyVista >= 0.32
- pyvistaqt >= 0.4
- mffpy >= 0.5.7
- h5py
- h5io
- pymatreader
Contributing to MNE-Python
^^^^^^^^^^^^^^^^^^^^^^^^^^
Please see the documentation on the MNE-Python homepage:
https://mne.tools/dev/install/contributing.html
Forum
^^^^^^
https://mne.discourse.group
Licensing
^^^^^^^^^
MNE-Python is **BSD-licenced** (BSD-3-Clause):
This software is OSI Certified Open Source Software.
OSI Certified is a certification mark of the Open Source Initiative.
Copyright (c) 2011-2022, authors of MNE-Python.
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
* Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
* Neither the names of MNE-Python authors nor the names of any
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.
**This software is provided by the copyright holders and contributors
"as is" and any express or implied warranties, including, but not
limited to, the implied warranties of merchantability and fitness for
a particular purpose are disclaimed. In no event shall the copyright
owner or contributors be liable for any direct, indirect, incidental,
special, exemplary, or consequential damages (including, but not
limited to, procurement of substitute goods or services; loss of use,
data, or profits; or business interruption) however caused and on any
theory of liability, whether in contract, strict liability, or tort
(including negligence or otherwise) arising in any way out of the use
of this software, even if advised of the possibility of such
damage.**
%package -n python3-mne
Summary: MNE-Python project for MEG and EEG data analysis.
Provides: python-mne
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mne
`MNE-Python software`_ is an open-source Python package for exploring,
visualizing, and analyzing human neurophysiological data such as MEG, EEG, sEEG,
ECoG, and more. It includes modules for data input/output, preprocessing,
visualization, source estimation, time-frequency analysis, connectivity analysis,
machine learning, and statistics.
Documentation
^^^^^^^^^^^^^
`MNE documentation`_ for MNE-Python is available online.
Installing MNE-Python
^^^^^^^^^^^^^^^^^^^^^
To install the latest stable version of MNE-Python, you can use pip_ in a terminal:
$ pip install -U mne
- MNE-Python 0.17 was the last release to support Python 2.7
- MNE-Python 0.18 requires Python 3.5 or higher
- MNE-Python 0.21 requires Python 3.6 or higher
- MNE-Python 0.24 requires Python 3.7 or higher
For more complete instructions and more advanced installation methods (e.g. for
the latest development version), see the `installation guide`_.
Get the latest code
^^^^^^^^^^^^^^^^^^^
To install the latest version of the code using pip_ open a terminal and type:
$ pip install -U https://github.com/mne-tools/mne-python/archive/main.zip
To get the latest code using `git `__, open a terminal and type:
$ git clone https://github.com/mne-tools/mne-python.git
Alternatively, you can also download a
`zip file of the latest development version `__.
Dependencies
^^^^^^^^^^^^
The minimum required dependencies to run MNE-Python are:
- Python >= 3.7
- NumPy >= 1.18.1
- SciPy >= 1.4.1
- Matplotlib >= 3.1.0
- pooch >= 1.5
- tqdm
- Jinja2
- decorator
For full functionality, some functions require:
- Scikit-learn >= 0.22.0
- joblib >= 0.15 (for parallelization control)
- Numba >= 0.48.0
- NiBabel >= 2.5.0
- OpenMEEG >= 2.5.5
- Pandas >= 1.0.0
- Picard >= 0.3
- CuPy >= 7.1.1 (for NVIDIA CUDA acceleration)
- DIPY >= 1.1.0
- Imageio >= 2.6.1
- PyVista >= 0.32
- pyvistaqt >= 0.4
- mffpy >= 0.5.7
- h5py
- h5io
- pymatreader
Contributing to MNE-Python
^^^^^^^^^^^^^^^^^^^^^^^^^^
Please see the documentation on the MNE-Python homepage:
https://mne.tools/dev/install/contributing.html
Forum
^^^^^^
https://mne.discourse.group
Licensing
^^^^^^^^^
MNE-Python is **BSD-licenced** (BSD-3-Clause):
This software is OSI Certified Open Source Software.
OSI Certified is a certification mark of the Open Source Initiative.
Copyright (c) 2011-2022, authors of MNE-Python.
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
* Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
* Neither the names of MNE-Python authors nor the names of any
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.
**This software is provided by the copyright holders and contributors
"as is" and any express or implied warranties, including, but not
limited to, the implied warranties of merchantability and fitness for
a particular purpose are disclaimed. In no event shall the copyright
owner or contributors be liable for any direct, indirect, incidental,
special, exemplary, or consequential damages (including, but not
limited to, procurement of substitute goods or services; loss of use,
data, or profits; or business interruption) however caused and on any
theory of liability, whether in contract, strict liability, or tort
(including negligence or otherwise) arising in any way out of the use
of this software, even if advised of the possibility of such
damage.**
%package help
Summary: Development documents and examples for mne
Provides: python3-mne-doc
%description help
`MNE-Python software`_ is an open-source Python package for exploring,
visualizing, and analyzing human neurophysiological data such as MEG, EEG, sEEG,
ECoG, and more. It includes modules for data input/output, preprocessing,
visualization, source estimation, time-frequency analysis, connectivity analysis,
machine learning, and statistics.
Documentation
^^^^^^^^^^^^^
`MNE documentation`_ for MNE-Python is available online.
Installing MNE-Python
^^^^^^^^^^^^^^^^^^^^^
To install the latest stable version of MNE-Python, you can use pip_ in a terminal:
$ pip install -U mne
- MNE-Python 0.17 was the last release to support Python 2.7
- MNE-Python 0.18 requires Python 3.5 or higher
- MNE-Python 0.21 requires Python 3.6 or higher
- MNE-Python 0.24 requires Python 3.7 or higher
For more complete instructions and more advanced installation methods (e.g. for
the latest development version), see the `installation guide`_.
Get the latest code
^^^^^^^^^^^^^^^^^^^
To install the latest version of the code using pip_ open a terminal and type:
$ pip install -U https://github.com/mne-tools/mne-python/archive/main.zip
To get the latest code using `git `__, open a terminal and type:
$ git clone https://github.com/mne-tools/mne-python.git
Alternatively, you can also download a
`zip file of the latest development version `__.
Dependencies
^^^^^^^^^^^^
The minimum required dependencies to run MNE-Python are:
- Python >= 3.7
- NumPy >= 1.18.1
- SciPy >= 1.4.1
- Matplotlib >= 3.1.0
- pooch >= 1.5
- tqdm
- Jinja2
- decorator
For full functionality, some functions require:
- Scikit-learn >= 0.22.0
- joblib >= 0.15 (for parallelization control)
- Numba >= 0.48.0
- NiBabel >= 2.5.0
- OpenMEEG >= 2.5.5
- Pandas >= 1.0.0
- Picard >= 0.3
- CuPy >= 7.1.1 (for NVIDIA CUDA acceleration)
- DIPY >= 1.1.0
- Imageio >= 2.6.1
- PyVista >= 0.32
- pyvistaqt >= 0.4
- mffpy >= 0.5.7
- h5py
- h5io
- pymatreader
Contributing to MNE-Python
^^^^^^^^^^^^^^^^^^^^^^^^^^
Please see the documentation on the MNE-Python homepage:
https://mne.tools/dev/install/contributing.html
Forum
^^^^^^
https://mne.discourse.group
Licensing
^^^^^^^^^
MNE-Python is **BSD-licenced** (BSD-3-Clause):
This software is OSI Certified Open Source Software.
OSI Certified is a certification mark of the Open Source Initiative.
Copyright (c) 2011-2022, authors of MNE-Python.
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
* Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
* Neither the names of MNE-Python authors nor the names of any
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.
**This software is provided by the copyright holders and contributors
"as is" and any express or implied warranties, including, but not
limited to, the implied warranties of merchantability and fitness for
a particular purpose are disclaimed. In no event shall the copyright
owner or contributors be liable for any direct, indirect, incidental,
special, exemplary, or consequential damages (including, but not
limited to, procurement of substitute goods or services; loss of use,
data, or profits; or business interruption) however caused and on any
theory of liability, whether in contract, strict liability, or tort
(including negligence or otherwise) arising in any way out of the use
of this software, even if advised of the possibility of such
damage.**
%prep
%autosetup -n mne-1.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mne -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.3.1-1
- Package Spec generated