%global _empty_manifest_terminate_build 0
Name: python-musicbrainzngs
Version: 0.7.1
Release: 1
Summary: Python bindings for the MusicBrainz NGS and the Cover Art Archive webservices
License: BSD 2-clause
URL: https://python-musicbrainzngs.readthedocs.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0a/67/3e74ae93d90ceeba72ed1a266dd3ca9abd625f315f0afd35f9b034acedd1/musicbrainzngs-0.7.1.tar.gz
BuildArch: noarch
%description
Musicbrainz NGS bindings
########################
This library implements webservice bindings for the Musicbrainz NGS site, also known as /ws/2
and the `Cover Art Archive `_.
For more information on the musicbrainz webservice see ``_.
Usage
*****
.. code:: python
# Import the module
import musicbrainzngs
# If you plan to submit data, authenticate
musicbrainzngs.auth("user", "password")
# Tell musicbrainz what your app is, and how to contact you
# (this step is required, as per the webservice access rules
# at http://wiki.musicbrainz.org/XML_Web_Service/Rate_Limiting )
musicbrainzngs.set_useragent("Example music app", "0.1", "http://example.com/music")
# If you are connecting to a different server
musicbrainzngs.set_hostname("beta.musicbrainz.org")
See the ``query.py`` file for more examples.
More documentation is available at
`Read the Docs `_.
Contribute
**********
If you want to contribute to this repository, please read `the
contribution guidelines
`_ first.
Authors
*******
These bindings were written by `Alastair Porter `_.
Contributions have been made by:
* `Adrian Sampson `_
* `Corey Farwell `_
* `Galen Hazelwood `_
* `Greg Ward `_
* `Ian McEwen `_
* `Jérémie Detrey `_
* `Johannes Dewender `_
* `Michael Marineau `_
* `Patrick Speiser `_
* `Pavan Chander `_
* `Paul Bailey `_
* `Rui Gonçalves `_
* `Ryan Helinski `_
* `Sam Doshi `_
* `Shadab Zafar `_
* `Simon Chopin `_
* `Thomas Vander Stichele `_
* `Wieland Hoffmann `_
License
*******
This library is released under the simplified BSD license except for the file
``musicbrainzngs/compat.py`` which is licensed under the ISC license.
See COPYING for details.
%package -n python3-musicbrainzngs
Summary: Python bindings for the MusicBrainz NGS and the Cover Art Archive webservices
Provides: python-musicbrainzngs
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-musicbrainzngs
Musicbrainz NGS bindings
########################
This library implements webservice bindings for the Musicbrainz NGS site, also known as /ws/2
and the `Cover Art Archive `_.
For more information on the musicbrainz webservice see ``_.
Usage
*****
.. code:: python
# Import the module
import musicbrainzngs
# If you plan to submit data, authenticate
musicbrainzngs.auth("user", "password")
# Tell musicbrainz what your app is, and how to contact you
# (this step is required, as per the webservice access rules
# at http://wiki.musicbrainz.org/XML_Web_Service/Rate_Limiting )
musicbrainzngs.set_useragent("Example music app", "0.1", "http://example.com/music")
# If you are connecting to a different server
musicbrainzngs.set_hostname("beta.musicbrainz.org")
See the ``query.py`` file for more examples.
More documentation is available at
`Read the Docs `_.
Contribute
**********
If you want to contribute to this repository, please read `the
contribution guidelines
`_ first.
Authors
*******
These bindings were written by `Alastair Porter `_.
Contributions have been made by:
* `Adrian Sampson `_
* `Corey Farwell `_
* `Galen Hazelwood `_
* `Greg Ward `_
* `Ian McEwen `_
* `Jérémie Detrey `_
* `Johannes Dewender `_
* `Michael Marineau `_
* `Patrick Speiser `_
* `Pavan Chander `_
* `Paul Bailey `_
* `Rui Gonçalves `_
* `Ryan Helinski `_
* `Sam Doshi `_
* `Shadab Zafar `_
* `Simon Chopin `_
* `Thomas Vander Stichele `_
* `Wieland Hoffmann `_
License
*******
This library is released under the simplified BSD license except for the file
``musicbrainzngs/compat.py`` which is licensed under the ISC license.
See COPYING for details.
%package help
Summary: Development documents and examples for musicbrainzngs
Provides: python3-musicbrainzngs-doc
%description help
Musicbrainz NGS bindings
########################
This library implements webservice bindings for the Musicbrainz NGS site, also known as /ws/2
and the `Cover Art Archive `_.
For more information on the musicbrainz webservice see ``_.
Usage
*****
.. code:: python
# Import the module
import musicbrainzngs
# If you plan to submit data, authenticate
musicbrainzngs.auth("user", "password")
# Tell musicbrainz what your app is, and how to contact you
# (this step is required, as per the webservice access rules
# at http://wiki.musicbrainz.org/XML_Web_Service/Rate_Limiting )
musicbrainzngs.set_useragent("Example music app", "0.1", "http://example.com/music")
# If you are connecting to a different server
musicbrainzngs.set_hostname("beta.musicbrainz.org")
See the ``query.py`` file for more examples.
More documentation is available at
`Read the Docs `_.
Contribute
**********
If you want to contribute to this repository, please read `the
contribution guidelines
`_ first.
Authors
*******
These bindings were written by `Alastair Porter `_.
Contributions have been made by:
* `Adrian Sampson `_
* `Corey Farwell `_
* `Galen Hazelwood `_
* `Greg Ward `_
* `Ian McEwen `_
* `Jérémie Detrey `_
* `Johannes Dewender `_
* `Michael Marineau `_
* `Patrick Speiser `_
* `Pavan Chander `_
* `Paul Bailey `_
* `Rui Gonçalves `_
* `Ryan Helinski `_
* `Sam Doshi `_
* `Shadab Zafar `_
* `Simon Chopin `_
* `Thomas Vander Stichele `_
* `Wieland Hoffmann `_
License
*******
This library is released under the simplified BSD license except for the file
``musicbrainzngs/compat.py`` which is licensed under the ISC license.
See COPYING for details.
%prep
%autosetup -n musicbrainzngs-0.7.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-musicbrainzngs -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.7.1-1
- Package Spec generated