%global _empty_manifest_terminate_build 0
Name: python-pyarlo
Version: 0.2.4
Release: 1
Summary: Python Arlo is a library written in Python 2.7/3x that exposes the Netgear Arlo cameras as Python objects.
License: LGPLv3+
URL: https://github.com/tchellomello/python-arlo
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/1d/fa44296189b5e3ad2e110c00aeed6f16a28c4769a26cca6929c875d86fb5/pyarlo-0.2.4.tar.gz
BuildArch: noarch
%description
Python Arlo is a library written in Python 2.7/3x that exposes the Netgear Arlo cameras as Python objects.
Developer Documentation: `http://python-arlo.readthedocs.io/ `_
%package -n python3-pyarlo
Summary: Python Arlo is a library written in Python 2.7/3x that exposes the Netgear Arlo cameras as Python objects.
Provides: python-pyarlo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyarlo
Python Arlo is a library written in Python 2.7/3x that exposes the Netgear Arlo cameras as Python objects.
Developer Documentation: `http://python-arlo.readthedocs.io/ `_
%package help
Summary: Development documents and examples for pyarlo
Provides: python3-pyarlo-doc
%description help
Python Arlo is a library written in Python 2.7/3x that exposes the Netgear Arlo cameras as Python objects.
Developer Documentation: `http://python-arlo.readthedocs.io/ `_
%prep
%autosetup -n pyarlo-0.2.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyarlo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.2.4-1
- Package Spec generated