%global _empty_manifest_terminate_build 0
Name: python-pytest-asyncio
Version: 0.21.0
Release: 1
Summary: Pytest support for asyncio
License: Apache 2.0
URL: https://github.com/pytest-dev/pytest-asyncio
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/85/c7/9db0c6215f12f26b590c24acc96d048e03989315f198454540dff95109cd/pytest-asyncio-0.21.0.tar.gz
BuildArch: noarch
Requires: python3-pytest
Requires: python3-typing-extensions
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-coverage
Requires: python3-hypothesis
Requires: python3-flaky
Requires: python3-mypy
Requires: python3-pytest-trio
%description
`pytest-asyncio `_ is a `pytest `_ plugin. It facilitates testing of code that uses the `asyncio `_ library.
Specifically, pytest-asyncio provides support for coroutines as test functions. This allows users to *await* code inside their tests. For example, the following code is executed as a test item by pytest:
@pytest.mark.asyncio
async def test_some_asyncio_code():
res = await library.do_something()
assert b"expected result" == res
More details can be found in the `documentation `_.
Note that test classes subclassing the standard `unittest `__ library are not supported. Users
are advised to use `unittest.IsolatedAsyncioTestCase `__
or an async framework such as `asynctest `__.
pytest-asyncio is available under the `Apache License 2.0 `_.
%package -n python3-pytest-asyncio
Summary: Pytest support for asyncio
Provides: python-pytest-asyncio
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytest-asyncio
`pytest-asyncio `_ is a `pytest `_ plugin. It facilitates testing of code that uses the `asyncio `_ library.
Specifically, pytest-asyncio provides support for coroutines as test functions. This allows users to *await* code inside their tests. For example, the following code is executed as a test item by pytest:
@pytest.mark.asyncio
async def test_some_asyncio_code():
res = await library.do_something()
assert b"expected result" == res
More details can be found in the `documentation `_.
Note that test classes subclassing the standard `unittest `__ library are not supported. Users
are advised to use `unittest.IsolatedAsyncioTestCase `__
or an async framework such as `asynctest `__.
pytest-asyncio is available under the `Apache License 2.0 `_.
%package help
Summary: Development documents and examples for pytest-asyncio
Provides: python3-pytest-asyncio-doc
%description help
`pytest-asyncio `_ is a `pytest `_ plugin. It facilitates testing of code that uses the `asyncio `_ library.
Specifically, pytest-asyncio provides support for coroutines as test functions. This allows users to *await* code inside their tests. For example, the following code is executed as a test item by pytest:
@pytest.mark.asyncio
async def test_some_asyncio_code():
res = await library.do_something()
assert b"expected result" == res
More details can be found in the `documentation `_.
Note that test classes subclassing the standard `unittest `__ library are not supported. Users
are advised to use `unittest.IsolatedAsyncioTestCase `__
or an async framework such as `asynctest `__.
pytest-asyncio is available under the `Apache License 2.0 `_.
%prep
%autosetup -n pytest-asyncio-0.21.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytest-asyncio -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.21.0-1
- Package Spec generated