%global _empty_manifest_terminate_build 0
Name:		python-freezegun
Version:	1.2.2
Release:	1
Summary:	Let your Python tests travel through time
License:	Apache 2.0
URL:		https://github.com/spulec/freezegun
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/1d/97/002ac49ec52858538b4aa6f6831f83c2af562c17340bdf6043be695f39ac/freezegun-1.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-dateutil

%description
FreezeGun is a library that allows your Python tests to travel through time by mocking the datetime module.

%package -n python3-freezegun
Summary:	Let your Python tests travel through time
Provides:	python-freezegun
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-freezegun
FreezeGun is a library that allows your Python tests to travel through time by mocking the datetime module.

%package help
Summary:	Development documents and examples for freezegun
Provides:	python3-freezegun-doc
%description help
FreezeGun is a library that allows your Python tests to travel through time by mocking the datetime module.

%prep
%autosetup -n freezegun-1.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-freezegun -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
- Package Spec generated