%global _empty_manifest_terminate_build 0
Name: python-Flask-AppBuilder
Version: 4.3.1
Release: 1
Summary: Simple and rapid application development framework, built on top of Flask. includes detailed security, auto CRUD generation for your models, google charts and much more.
License: BSD
URL: https://github.com/dpgaspar/flask-appbuilder/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/34/4f/8cdc85fa365e2e1e4e308f99bbc069bbeff9bdcd09f522af62fd3ab9f613/Flask-AppBuilder-4.3.1.tar.gz
BuildArch: noarch
Requires: python3-apispec[yaml]
Requires: python3-colorama
Requires: python3-click
Requires: python3-email-validator
Requires: python3-Flask
Requires: python3-Flask-Babel
Requires: python3-Flask-Limiter
Requires: python3-Flask-Login
Requires: python3-Flask-SQLAlchemy
Requires: python3-Flask-WTF
Requires: python3-Flask-JWT-Extended
Requires: python3-jsonschema
Requires: python3-marshmallow
Requires: python3-marshmallow-enum
Requires: python3-marshmallow-sqlalchemy
Requires: python3-dateutil
Requires: python3-prison
Requires: python3-PyJWT
Requires: python3-SQLAlchemy
Requires: python3-sqlalchemy-utils
Requires: python3-WTForms
Requires: python3-jmespath
Requires: python3-Authlib
Requires: python3-Flask-OpenID
%description
Simple and rapid application development framework, built on top of `Flask `_.
includes detailed security, auto CRUD generation for your models, google charts and much more.
Extensive configuration of all functionality, easily integrate with normal Flask/Jinja2 development.
- Documentation: `Documentation `_
- Mailing list: `Google group `_
- Chat: `Gitter `_
- Examples: `examples `_
Checkout installation video on `YouTube `_
Quick how to `Demo from the docs `_ (login has guest/welcome).
%package -n python3-Flask-AppBuilder
Summary: Simple and rapid application development framework, built on top of Flask. includes detailed security, auto CRUD generation for your models, google charts and much more.
Provides: python-Flask-AppBuilder
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Flask-AppBuilder
Simple and rapid application development framework, built on top of `Flask `_.
includes detailed security, auto CRUD generation for your models, google charts and much more.
Extensive configuration of all functionality, easily integrate with normal Flask/Jinja2 development.
- Documentation: `Documentation `_
- Mailing list: `Google group `_
- Chat: `Gitter `_
- Examples: `examples `_
Checkout installation video on `YouTube `_
Quick how to `Demo from the docs `_ (login has guest/welcome).
%package help
Summary: Development documents and examples for Flask-AppBuilder
Provides: python3-Flask-AppBuilder-doc
%description help
Simple and rapid application development framework, built on top of `Flask `_.
includes detailed security, auto CRUD generation for your models, google charts and much more.
Extensive configuration of all functionality, easily integrate with normal Flask/Jinja2 development.
- Documentation: `Documentation `_
- Mailing list: `Google group `_
- Chat: `Gitter `_
- Examples: `examples `_
Checkout installation video on `YouTube `_
Quick how to `Demo from the docs `_ (login has guest/welcome).
%prep
%autosetup -n Flask-AppBuilder-4.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-AppBuilder -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 4.3.1-1
- Package Spec generated