%global _empty_manifest_terminate_build 0
Name:		python-bandit
Version:	1.7.5
Release:	1
Summary:	Security oriented static analyser for python code.
License:	Apache-2.0 license
URL:		https://bandit.readthedocs.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5e/67/997278e785edf155bd57163ae7030f979a0907857365cb30815d93b5354b/bandit-1.7.5.tar.gz
BuildArch:	noarch

Requires:	python3-GitPython
Requires:	python3-PyYAML
Requires:	python3-stevedore
Requires:	python3-rich
Requires:	python3-colorama
Requires:	python3-coverage
Requires:	python3-fixtures
Requires:	python3-flake8
Requires:	python3-stestr
Requires:	python3-testscenarios
Requires:	python3-testtools
Requires:	python3-beautifulsoup4
Requires:	python3-pylint
Requires:	python3-tomli
Requires:	python3-tomli
Requires:	python3-PyYAML

%description
A security linter from PyCQA
* Free software: Apache license
* Documentation: https://bandit.readthedocs.io/en/latest/
* Source: https://github.com/PyCQA/bandit
* Bugs: https://github.com/PyCQA/bandit/issues
* Contributing: https://github.com/PyCQA/bandit/blob/main/CONTRIBUTING.md

%package -n python3-bandit
Summary:	Security oriented static analyser for python code.
Provides:	python-bandit
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bandit
A security linter from PyCQA
* Free software: Apache license
* Documentation: https://bandit.readthedocs.io/en/latest/
* Source: https://github.com/PyCQA/bandit
* Bugs: https://github.com/PyCQA/bandit/issues
* Contributing: https://github.com/PyCQA/bandit/blob/main/CONTRIBUTING.md

%package help
Summary:	Development documents and examples for bandit
Provides:	python3-bandit-doc
%description help
A security linter from PyCQA
* Free software: Apache license
* Documentation: https://bandit.readthedocs.io/en/latest/
* Source: https://github.com/PyCQA/bandit
* Bugs: https://github.com/PyCQA/bandit/issues
* Contributing: https://github.com/PyCQA/bandit/blob/main/CONTRIBUTING.md

%prep
%autosetup -n bandit-1.7.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bandit -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.5-1
- Package Spec generated