%global _empty_manifest_terminate_build 0
Name:		python-pamqp
Version:	3.2.1
Release:	1
Summary:	RabbitMQ Focused AMQP low-level library
License:	BSD 3-Clause License
URL:		https://github.com/gmr/pamqp
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b6/83/7eee9c8e5f1b030d3fe2740aa84f209bdd1fdaa6a476eee296581834cf4f/pamqp-3.2.1.tar.gz
BuildArch:	noarch

Requires:	python3-lxml
Requires:	python3-requests
Requires:	python3-yapf
Requires:	python3-coverage
Requires:	python3-flake8
Requires:	python3-flake8-comprehensions
Requires:	python3-flake8-deprecated
Requires:	python3-flake8-import-order
Requires:	python3-flake8-print
Requires:	python3-flake8-quotes
Requires:	python3-flake8-rst-docstrings
Requires:	python3-flake8-tuple
Requires:	python3-yapf

%description
pamqp is a low level AMQP 0-9-1 frame encoding and decoding library for Python 3.
pamqp is not a end-user client library for talking to RabbitMQ but rather is
used by client libraries for marshaling and unmarshaling AMQP frames.
|Version| |Status| |Coverage| |License| |Maintainability| |Downloads|

%package -n python3-pamqp
Summary:	RabbitMQ Focused AMQP low-level library
Provides:	python-pamqp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pamqp
pamqp is a low level AMQP 0-9-1 frame encoding and decoding library for Python 3.
pamqp is not a end-user client library for talking to RabbitMQ but rather is
used by client libraries for marshaling and unmarshaling AMQP frames.
|Version| |Status| |Coverage| |License| |Maintainability| |Downloads|

%package help
Summary:	Development documents and examples for pamqp
Provides:	python3-pamqp-doc
%description help
pamqp is a low level AMQP 0-9-1 frame encoding and decoding library for Python 3.
pamqp is not a end-user client library for talking to RabbitMQ but rather is
used by client libraries for marshaling and unmarshaling AMQP frames.
|Version| |Status| |Coverage| |License| |Maintainability| |Downloads|

%prep
%autosetup -n pamqp-3.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pamqp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.1-1
- Package Spec generated