%global _empty_manifest_terminate_build 0
Name:		python-qds_sdk
Version:	1.16.1
Release:	1
Summary:	Python SDK for coding to the Qubole Data Service API
License:	Apache License 2.0
URL:		https://github.com/qubole/qds-sdk-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d1/95/8b00e40ee0b3dd75832073298fc89fc3eaa48697fa36c7edd0bd39994284/qds_sdk-1.16.1.tar.gz
BuildArch:	noarch


%description
A Python module that provides the tools you need to authenticate with,
and use the Qubole Data Service API.

%package -n python3-qds_sdk
Summary:	Python SDK for coding to the Qubole Data Service API
Provides:	python-qds_sdk
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-qds_sdk
A Python module that provides the tools you need to authenticate with,
and use the Qubole Data Service API.

%package help
Summary:	Development documents and examples for qds_sdk
Provides:	python3-qds_sdk-doc
%description help
A Python module that provides the tools you need to authenticate with,
and use the Qubole Data Service API.

%prep
%autosetup -n qds_sdk-1.16.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-qds_sdk -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.16.1-1
- Package Spec generated