%global _empty_manifest_terminate_build 0
Name:		python-fastcore
Version:	1.5.29
Release:	1
Summary:	Python supercharged for fastai development
License:	Apache Software License 2.0
URL:		https://github.com/fastai/fastcore/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/1f/62/bb0d880d3a9306a6a042ab41ea61b082f8d2c378019f8b3d37693b9a0b44/fastcore-1.5.29.tar.gz
BuildArch:	noarch

Requires:	python3-pip
Requires:	python3-packaging
Requires:	python3-numpy
Requires:	python3-nbdev
Requires:	python3-matplotlib
Requires:	python3-pillow
Requires:	python3-torch
Requires:	python3-pandas
Requires:	python3-jupyterlab

%description
<!-- WARNING: THIS FILE WAS AUTOGENERATED! DO NOT EDIT! -->
Python is a powerful, dynamic language. Rather than bake everything into
the language, it lets the programmer customize it to make it work for
them. `fastcore` uses this flexibility to add to Python features
inspired by other languages we’ve loved, like multiple dispatch from
Julia, mixins from Ruby, and currying, binding, and more from Haskell.
It also adds some “missing features” and clean up some rough edges in
the Python standard library, such as simplifying parallel processing,
and bringing ideas from NumPy over to Python’s `list` type.
## Getting started
To install fastcore run: `conda install fastcore -c fastai` (if you use
Anaconda, which we recommend) or `pip install fastcore`. For an
[editable
install](https://stackoverflow.com/questions/35064426/when-would-the-e-editable-option-be-useful-with-pip-install),
clone this repo and run: `pip install -e ".[dev]"`. fastcore is tested
to work on Ubuntu, macOS and Windows (versions tested are those show
with the `-latest` suffix
[here](https://docs.github.com/en/actions/reference/specifications-for-github-hosted-runners#supported-runners-and-hardware-resources).
`fastcore` contains many features, including:
- `fastcore.test`: Simple testing functions
- `fastcore.foundation`: Mixins, delegation, composition, and more
- `fastcore.xtras`: Utility functions to help with functional-style
  programming, parallel processing, and more
- `fastcore.dispatch`: Multiple dispatch methods
- `fastcore.transform`: Pipelines of composed partially reversible
  transformations
To get started, we recommend you read through [the fastcore
tour](https://fastcore.fast.ai/tour.html).
## Contributing
After you clone this repository, please run `nbdev_install_hooks` in
your terminal. This sets up git hooks, which clean up the notebooks to
remove the extraneous stuff stored in the notebooks (e.g. which cells
you ran) which causes unnecessary merge conflicts.
To run the tests in parallel, launch `nbdev_test`.
Before submitting a PR, check that the local library and notebooks
match.
- If you made a change to the notebooks in one of the exported cells,
  you can export it to the library with `nbdev_prepare`.
- If you made a change to the library, you can export it back to the
  notebooks with `nbdev_update`.

%package -n python3-fastcore
Summary:	Python supercharged for fastai development
Provides:	python-fastcore
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-fastcore
<!-- WARNING: THIS FILE WAS AUTOGENERATED! DO NOT EDIT! -->
Python is a powerful, dynamic language. Rather than bake everything into
the language, it lets the programmer customize it to make it work for
them. `fastcore` uses this flexibility to add to Python features
inspired by other languages we’ve loved, like multiple dispatch from
Julia, mixins from Ruby, and currying, binding, and more from Haskell.
It also adds some “missing features” and clean up some rough edges in
the Python standard library, such as simplifying parallel processing,
and bringing ideas from NumPy over to Python’s `list` type.
## Getting started
To install fastcore run: `conda install fastcore -c fastai` (if you use
Anaconda, which we recommend) or `pip install fastcore`. For an
[editable
install](https://stackoverflow.com/questions/35064426/when-would-the-e-editable-option-be-useful-with-pip-install),
clone this repo and run: `pip install -e ".[dev]"`. fastcore is tested
to work on Ubuntu, macOS and Windows (versions tested are those show
with the `-latest` suffix
[here](https://docs.github.com/en/actions/reference/specifications-for-github-hosted-runners#supported-runners-and-hardware-resources).
`fastcore` contains many features, including:
- `fastcore.test`: Simple testing functions
- `fastcore.foundation`: Mixins, delegation, composition, and more
- `fastcore.xtras`: Utility functions to help with functional-style
  programming, parallel processing, and more
- `fastcore.dispatch`: Multiple dispatch methods
- `fastcore.transform`: Pipelines of composed partially reversible
  transformations
To get started, we recommend you read through [the fastcore
tour](https://fastcore.fast.ai/tour.html).
## Contributing
After you clone this repository, please run `nbdev_install_hooks` in
your terminal. This sets up git hooks, which clean up the notebooks to
remove the extraneous stuff stored in the notebooks (e.g. which cells
you ran) which causes unnecessary merge conflicts.
To run the tests in parallel, launch `nbdev_test`.
Before submitting a PR, check that the local library and notebooks
match.
- If you made a change to the notebooks in one of the exported cells,
  you can export it to the library with `nbdev_prepare`.
- If you made a change to the library, you can export it back to the
  notebooks with `nbdev_update`.

%package help
Summary:	Development documents and examples for fastcore
Provides:	python3-fastcore-doc
%description help
<!-- WARNING: THIS FILE WAS AUTOGENERATED! DO NOT EDIT! -->
Python is a powerful, dynamic language. Rather than bake everything into
the language, it lets the programmer customize it to make it work for
them. `fastcore` uses this flexibility to add to Python features
inspired by other languages we’ve loved, like multiple dispatch from
Julia, mixins from Ruby, and currying, binding, and more from Haskell.
It also adds some “missing features” and clean up some rough edges in
the Python standard library, such as simplifying parallel processing,
and bringing ideas from NumPy over to Python’s `list` type.
## Getting started
To install fastcore run: `conda install fastcore -c fastai` (if you use
Anaconda, which we recommend) or `pip install fastcore`. For an
[editable
install](https://stackoverflow.com/questions/35064426/when-would-the-e-editable-option-be-useful-with-pip-install),
clone this repo and run: `pip install -e ".[dev]"`. fastcore is tested
to work on Ubuntu, macOS and Windows (versions tested are those show
with the `-latest` suffix
[here](https://docs.github.com/en/actions/reference/specifications-for-github-hosted-runners#supported-runners-and-hardware-resources).
`fastcore` contains many features, including:
- `fastcore.test`: Simple testing functions
- `fastcore.foundation`: Mixins, delegation, composition, and more
- `fastcore.xtras`: Utility functions to help with functional-style
  programming, parallel processing, and more
- `fastcore.dispatch`: Multiple dispatch methods
- `fastcore.transform`: Pipelines of composed partially reversible
  transformations
To get started, we recommend you read through [the fastcore
tour](https://fastcore.fast.ai/tour.html).
## Contributing
After you clone this repository, please run `nbdev_install_hooks` in
your terminal. This sets up git hooks, which clean up the notebooks to
remove the extraneous stuff stored in the notebooks (e.g. which cells
you ran) which causes unnecessary merge conflicts.
To run the tests in parallel, launch `nbdev_test`.
Before submitting a PR, check that the local library and notebooks
match.
- If you made a change to the notebooks in one of the exported cells,
  you can export it to the library with `nbdev_prepare`.
- If you made a change to the library, you can export it back to the
  notebooks with `nbdev_update`.

%prep
%autosetup -n fastcore-1.5.29

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-fastcore -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.29-1
- Package Spec generated