%global _empty_manifest_terminate_build 0 Name: python-openml Version: 0.13.1 Release: 1 Summary: Python API for OpenML License: BSD 3-clause URL: https://openml.org/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fd/f6/91ade3eb03f51e3d47c3439d7317558e9bc154fed842007148969fec896a/openml-0.13.1.tar.gz BuildArch: noarch %description # OpenML-Python [![All Contributors](https://img.shields.io/badge/all_contributors-2-orange.svg?style=flat-square)](#contributors-) A python interface for [OpenML](http://openml.org), an online platform for open science collaboration in machine learning. It can be used to download or upload OpenML data such as datasets and machine learning experiment results. ## General * [Documentation](https://openml.github.io/openml-python). * [Contribution guidelines](https://github.com/openml/openml-python/blob/develop/CONTRIBUTING.md). [![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg)](https://opensource.org/licenses/BSD-3-Clause) ## Citing OpenML-Python If you use OpenML-Python in a scientific publication, we would appreciate a reference to the following paper: [Matthias Feurer, Jan N. van Rijn, Arlind Kadra, Pieter Gijsbers, Neeratyoy Mallik, Sahithya Ravi, Andreas Müller, Joaquin Vanschoren, Frank Hutter
**OpenML-Python: an extensible Python API for OpenML**
*arXiv:1911.02490 [cs.LG]*](https://arxiv.org/abs/1911.02490) Bibtex entry: ```bibtex @article{feurer-arxiv19a, author = {Matthias Feurer and Jan N. van Rijn and Arlind Kadra and Pieter Gijsbers and Neeratyoy Mallik and Sahithya Ravi and Andreas Müller and Joaquin Vanschoren and Frank Hutter}, title = {OpenML-Python: an extensible Python API for OpenML}, journal = {arXiv:1911.02490}, year = {2019}, } ``` ## Contributors ✨ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

a-moadel

📖 💡

Neeratyoy Mallik

💻 📖 💡
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package -n python3-openml Summary: Python API for OpenML Provides: python-openml BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-openml # OpenML-Python [![All Contributors](https://img.shields.io/badge/all_contributors-2-orange.svg?style=flat-square)](#contributors-) A python interface for [OpenML](http://openml.org), an online platform for open science collaboration in machine learning. It can be used to download or upload OpenML data such as datasets and machine learning experiment results. ## General * [Documentation](https://openml.github.io/openml-python). * [Contribution guidelines](https://github.com/openml/openml-python/blob/develop/CONTRIBUTING.md). [![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg)](https://opensource.org/licenses/BSD-3-Clause) ## Citing OpenML-Python If you use OpenML-Python in a scientific publication, we would appreciate a reference to the following paper: [Matthias Feurer, Jan N. van Rijn, Arlind Kadra, Pieter Gijsbers, Neeratyoy Mallik, Sahithya Ravi, Andreas Müller, Joaquin Vanschoren, Frank Hutter
**OpenML-Python: an extensible Python API for OpenML**
*arXiv:1911.02490 [cs.LG]*](https://arxiv.org/abs/1911.02490) Bibtex entry: ```bibtex @article{feurer-arxiv19a, author = {Matthias Feurer and Jan N. van Rijn and Arlind Kadra and Pieter Gijsbers and Neeratyoy Mallik and Sahithya Ravi and Andreas Müller and Joaquin Vanschoren and Frank Hutter}, title = {OpenML-Python: an extensible Python API for OpenML}, journal = {arXiv:1911.02490}, year = {2019}, } ``` ## Contributors ✨ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

a-moadel

📖 💡

Neeratyoy Mallik

💻 📖 💡
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package help Summary: Development documents and examples for openml Provides: python3-openml-doc %description help # OpenML-Python [![All Contributors](https://img.shields.io/badge/all_contributors-2-orange.svg?style=flat-square)](#contributors-) A python interface for [OpenML](http://openml.org), an online platform for open science collaboration in machine learning. It can be used to download or upload OpenML data such as datasets and machine learning experiment results. ## General * [Documentation](https://openml.github.io/openml-python). * [Contribution guidelines](https://github.com/openml/openml-python/blob/develop/CONTRIBUTING.md). [![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg)](https://opensource.org/licenses/BSD-3-Clause) ## Citing OpenML-Python If you use OpenML-Python in a scientific publication, we would appreciate a reference to the following paper: [Matthias Feurer, Jan N. van Rijn, Arlind Kadra, Pieter Gijsbers, Neeratyoy Mallik, Sahithya Ravi, Andreas Müller, Joaquin Vanschoren, Frank Hutter
**OpenML-Python: an extensible Python API for OpenML**
*arXiv:1911.02490 [cs.LG]*](https://arxiv.org/abs/1911.02490) Bibtex entry: ```bibtex @article{feurer-arxiv19a, author = {Matthias Feurer and Jan N. van Rijn and Arlind Kadra and Pieter Gijsbers and Neeratyoy Mallik and Sahithya Ravi and Andreas Müller and Joaquin Vanschoren and Frank Hutter}, title = {OpenML-Python: an extensible Python API for OpenML}, journal = {arXiv:1911.02490}, year = {2019}, } ``` ## Contributors ✨ Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):

a-moadel

📖 💡

Neeratyoy Mallik

💻 📖 💡
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %prep %autosetup -n openml-0.13.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-openml -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri Apr 21 2023 Python_Bot - 0.13.1-1 - Package Spec generated